Access via Ethernet

I plugged a USB to Ethernet adapter instead of the WiFi dongle. Via a switch I have connected a laptop. Unfortunately the laptop does not receive an IP address. Does the Skylark DHCP server not assign IP addresses for Ethernet?

The Dreamcatcher only works as a client as far as i know when using somethign else then Wifi.

@kenbarbi Hi Ken, You had hinted at this in your documentary. Maybe you can make it clearer. Thanks

@Syed
@Tysonpower
@Robert
@kenbarbi
@Abhishek
Robert, the Dreamcatcher and Skylark are configured for a specific purpose, not as a platform for hacking or re-purposing to perform other non-supported functions. @kenbarbi ken’s user manual is sufficient to the task of explaining how to set up and use the current versions of Dreamcatcher and Skylark within the intended parameters of the project. It is not intended to be a comprehensive technical manual. For those of us dedicated to helping Syed with the development of this device, this manual has all the necessary information, and was carefully vetted and endorsed by a number of seasoned “fellow users” before it was placed on the download site for all users to access. It is provided as a service to those of us who would carefully read and use it. It is not provided by a paid author nor by a professional writer, but by a “fellow user” and contributing fellow users such as @Tysonpower on their own personal time and resources. Most of us “fellow users” are literate enough in English to put this information, as it is written, to profitable use as it pertains to the Dreamcatcher/Skylark project.

1 Like

@maxboysdad Thanks for the advice. And many thanks to all who are involved in this project.
@kenbarbi has described the use of an Ethernet adapter in its very good manual. The use of an Ethernet adapter has nothing to do with hacking. A small hint that DHCP is not set up for Ethernet can’t hurt.

1 Like

Here’s the wording , Robert (and others), (from the User’s Manual for the Dreamcatcher v3.05 with Skylark 5.7) we used to address the use of a USB to Ethernet Network Adapter, and the method of determining the Dreamcatcher’s IP address on your Client Network. Please let me know where additional clarification is needed so we can make the appropriate changes. Ken

Step 8. Alternate Connectivity Approach is to use a USB to Ethernet Network Adapter instead of going through the Othernet WiFi Hotspot or Network Client approach. Be careful, NOT ALL USB to Ethernet Network Adapters work both natively under Skylark and Armbian. Specifically a TP-Link TL-UE300 works properly.

This Ethernet Dongle is natively supported, so works out of the box. Just replace the EDUP WiFi Dongle (Fig. 1) with the Ethernet Dongle. The downside of this approach is you need to determine the actual IP address as in Section IV Step 4 using your router or another program.

Step 4. You will be connected to Dreamcatcher’s Skylark Program through your local WiFi from your router. You can go to any computer on your router’s network, and use any Web Browser to access Skylark through its newly assigned IP address, or by typing my.othernet.is (which requires an internet connection to work). If you cannot find the Dreamcatcher’s IP address using your router or my.othernet.is , suggest you use a shareware program such as Angry IP Scanner (https://angryip.org) (Fig. 27a) for Windows, MAC, and Linux; or Advanced IP Scanner (www.advanced-ip-scanner.com).

Ah I’ll get me one of those as have had issues with the wifi connectivity, thanks. they are £11 from Amazon uk.

1 Like

Hi Ken,
If a USB to Ethernet Network Adapter (TP-Link TL-UE300) is used instead of the WiFi dongle, the Dreamcatcher does not assign an IP address via DHCP. In the above sentence ‘Hotspot’ should therefore be deleted.

Of course I should have looked at the file /etc/dnsmasq.conf
It says “interface=wlan0”
An entry for the interface of the Ethernet dongle is missing. Surely you can add the corresponding entries there. But how can they be saved permanently?

I wanted to determine the interface of the Ethernet dongle. but the Dreamcatcher was crashed again (see Malfunction of my Dreamcatcher ). Only after numerous attempts (switch off, switch on, pull out the plug, …) did it work again.

Yep - - your right on the mark regarding the “Hotspot” word. I’ll correct that.

As to saving, I’ve not tried that, but I believe any change you make on the fly will be lost when you reboot the Dreamcatcher. Hopefully, with the USB to Ethernet Network Adapter plugged in, your client router will always assign the same IP address. Ken

If you know the Ethernet cards mac address you can tell the router In it’s setting to reserve it’s up so only it gets that ip not all routers support this but alot do.

But I did not want to connect the Dreamcatcher to a router. The DHCP server in the Dreamcatcher must assign the IP addresses.

Hi Guys, I’m another newbie. Othernet is a really great concept that has been very well executed. I hope it continues to grow, as it has loads of potential. @kenbarbi the guide makes it a breeze to set up, I had it working including a lock on Astra 3B in about 15 mins.

My 3.05 receiver is running v5.8. I need to run it in ‘Connect to a WiFi router’ mode and it works fine using the supplied EDUP wifi dongle. Ken has kindly told us we can use a TL-UE300 ethernet adapter instead of Wifi. I need to operate like this because the Wifi it too patchy between the receiver and my router (long distance with obstacles).

Am I correct in thinking that with the UE300 I simply plug it in to the 3.05, connect to my router, then switch the 3.05 to ‘Connect to a Wifi Router’ mode? The Ethernet light flashes as normal on the router and UL-300 adapter, but the 3.05 receiver does not appear as a client on my DHCP client list (it does when I switch to wifi instead of ethernet).

I am probably missing something obvious, but it would be great if you can confirm which mode the 3.05 receiver should be in, to work with the UE300 adapter over ethernet into a router. Thanks for reading!

Welcome Richard to Othernet with all of us HAMS and hackers. With the ethernet adapter plugged in, and your Dreamcatcher connected to your appropriate network, the Dreamcatcher should get assigned an IP address by your router.

But after re reading your post, it looks to me that you may not have clicked APPLY AND REBOOT when going from the Othernet WiFi hotspot to "Connect to a WiFi Router. If your router doesn’t show the Dreamcatcher (it should) IP, then I suspect you might not have initiated the connection.

image
Jerry @maxboysdad can you add anything here? Ken

Hi Ken and Richard, I would say that you are spot on as it stands, let’s see if that takes care of it. The Connect with a Wifi router is the only choice that would support the UE-300 if I remember right. If that isn’t working, Richard, please post again and I will get out my second unit and see what gives. I do have a UE-300 that works, but I don’t remember having to change anything to get the connection, maybe it just needs the Apply and Reboot as Ken said.

Hi Ken and Jerry, thanks for the reply. I’ve tried just about every combination I can think of, including the one you kindly suggest. I’m in the satellite and IT sectors, so have a reasonable understanding of the kit.

Here’s a good example. With the EDUP wifi dongle plugged in: 1) enter wifi client details, 2) set network mode to ‘connect to a router’, 3) ‘apply and reboot’. It then connects via wifi to the router and I can access it over the LAN. 4) Turn off receiver with power button, unplug the wifi dongle and plug-in UE-300 ethernet adapter, 5) switch receiver on - it fails to connect to the router. If I switch back to the wifi dongle, it then connects fine, so it hasn’t lost the connect to router setting.

I’ve tried with and without data entered into the ‘wifi client field’, in case it was trying to log-on to the router when of course being ethernet it doesn’t need to. I’ve tried hot-swapping the EDUP dongle for the ethernet dongle.

I’m using a spare router for testing with LAN addresses in the 192.168.0.100 starting range. My plan is to try with another router and alternative address range in case the UE-300/receiver combo doesn’t support the above (although it does when using wifi).

Thanks guys your help is much appreciated. I will keep trying ideas here. Richard.

Richard is still having problems, Jerry. You are in the best position to help as you have the gear set up there and working. Ken

OK. Earliest I can begin will be this afternoon (Sunday), providing I don’t get re-tasked in the mean time. I will post results as soon as I can.

I had a few minutes and went ahead to set it up. When I booted the Dreamcatcher, it had been previously set up as a hot spot. I only changed out the Edup for the UE-300. However, it connected immediately to the router and was accessible using a browser once I went into the router and obtained the url. So perhaps it needs to be set up as a hot spot first? I know that it worked right off, so perhaps this is the solution. Got to get moving now, will check back later if there are questions. Jerry

1 Like

Hi Jerry, you are spot-on. With the receiver already running as a ‘wifi hotspot’, if you cycle it off, switch over to the ethernet dongle and power on; then voila it’s a client on the router’s LAN.

It looks like I was overthinking it, by trying to make it connect using the ‘connect to a router’ set-up. Plugging the ethernet dongle in somehow forced the hotspot mode to work as an ethernet client.

I can now go a bury a long armoured CAT6 in my backyard. Thanks to you both for helping.

2 Likes

Jerry, I’m going to add this instruction to the Dreamcatcher User’s Guides. Ken

2 Likes