Beta testing RxOS release 4.0 - Skylark. Link in thread!


#181

Good to hear others are having the same problems I’m having :smiling_imp:

@Abhishek is working this issue, and I have sent him the files he needs to figure it out. At least now, I know I am not crazy. Keep looking at this post to see what he comes up with.

I’m pushing the Alpha Lantern to see what it can do. You are essentially using the same components which should respond the same way. Ken, in Annapolis, Maryland


#182

@sglee You make an excellent point about auto-booting in remote areas. We’re working on a solution to this.


#183

Hello @Abhishek

Without the USB stick, my re flashed Lantern shut down after about 10 hours - - it powered completely off. Exactly the same symptoms as before on reboot.

Your thoughts. Ken


#184

Last night sometime Skylark crashed. I had a running uptime of over three days.

I went to log into the desktop and it was not responding, neither was I able to ssh in either.

Power cycled and pressed the power button to boot up. System started and I can log in again. But there is no status from the SDR at all on the desktop.

I have done a couple of hard reboots as well as restarts from the command line. No luck.

Do you want any logs or information from me before I reflash the CHIP?

-Cecil
AA5CE


#185

Logs after reboot. Update with PS.

Pastebin Logs

-Cecil
AA5CE


#186

Same here in Annapolis, Maryland. New failure with SNR dropping to neg values and fluttering there. I opened my Lantern and found the CHIP computer warm and the SDR cold with LNA light red. Normally, the CHIP is warm, red light is on, and SDR is HOT. I rebooted and got a stable SNR of 5.76 with NO fluttering. Don’t think this good :confused:

Your thoughts @Abhishek Ken


#187

I’m thinking now of going back to my original CHIP (the one I bricked that came with the Alpha), and the original SDN/LNA that came with the Alpha.

Til now, I have been using the newer hardware. Ken


#188

Uptime now at three hours. The radio is reporting the following, but a static report, not updating in real time.

22:30:35 up 3:06, load average: 1.84, 0.98, 0.86

It is strange that the SDR is acting so wierd and taking so long to come up. Then the status is still strange.

I am going to leave it running and will update in a few hours.

-Cecil
AA5CE


#189

Check out all the red balloons around Washington
Ken


#190

I’m having a good run so far it seems. An uptime of 18 hours, no hangs, or powerdowns. I took a few pictures with my thermal camera following @kenbarbi s idea that SDR may not be getting powered at times. The boards look normal, warm. If I encounter issues again I’ll take another set of pictures.


#191

Still no real time updates… But the static screen seems to think that packets are being received.

Cecil
AA5CE


#192

So 39 minutes in after a reboot and my Tuner Status has not populated, however the good news is that on my setup the CHIP, SDR, and LNA are all running and warm. Perhaps for some this is a mixed hardware / software problem. Have you tried the RTL and LNA on a computer with SDR# or something? See if a USB keyboard works on the CHIP’s USB port? Try a short extension cable between the USB port on the CHIP and the RTL? Each are ways you could get a better idea if either the CHIP’s USB port or the RTL’s USB plug are not making a good connection. I’d think the chances of a hardware problem on two brand new USB ports would be very low, but it’s worth testing just to rule it out. -clavo


#193

Well same boot cycle, uptime is just over 23 hours. Some time during the night the status screen has started updating again in real time.

There must be someting wrong in the startup scripting or there is some issue with the symlinks that are doing the status updates.

Clavo mentioned using a short USB extension cable. I was having issues with the CHIP’s on board 802.11 wireless. I added a usb extension and placed a snap on ferrite isolator with 4 turns of the extension through it. All the noise issues went away, plus the RSL on the SDR jumped from 0-1 to 3-4. So it is a good idea to try.

-Cecil
AA5CE

EDIT:
P.S. Ran a new boot of the CHIP and the real time updating seems to start showing around 2 hrs after the boot.


#194

Here are my results so far:

Environment:

Mac OS Sierra
installed virtual box and extensions
Flashed CHIP with no issues

New status is much easier to align antenna.

Issues I have had:

  • Status will lock up and not update
  • I have had some wifi issues with only being able to connect one system at a time or not at all until reboot
  • The Status now show a file at 99% for the last 6+ hours and no change. Doesn’t look like anything else is downloading.
  • Had a window go off screen with no way to get it back that I could figure out.

#195

Just hit apply on Satellite tab to restart the feed and it kicked the file and now downloading new files!

Tried this before but it finally worked this time.


#196

@Abhishek is working on a few bugs.


#197

Lantern Failures

I’ve been trying all sorts of combinations of my CHIPs, LNAs, SDRs, batteries, chargers, etc. and my system keeps powering down after an hour or so. I have reflashed my CHIPs, and it still powers off. I can’t imagine it to be a software issue.

At this time, I’m letting my Lantern rest in the power off condition for the night. My wall wart is drawing 5 Watts of power (I’m using an AC power meter to measure the draw), so I’m thinking the Boston Power battery might be the culprit needing to be fully charged before the Lantern can run properly. Other than that - - what could be wrong?

Ken


#198

After almost two weeks running I can say this is my experience with release 4.0 so far:

Positive:

  • The software seems to be more stable for me
  • Seem to give me a better, more stable SNR

Could be improved:

  • In the previous version, it was easier to see the current status with one click. I would like a simple easy accesable panel showing SNR, last download and current download with percentage.
  • I would really like you to improve the way to see the downloaded content, including media files
  • Since the update, my Chip does no longer startup automatically when you apply the power as it was before. That is one thing I really would like to have again

#199

Follow-up on Alpha Lantern Powering Down

After 10 hours of recharge the shut-down Lantern running at 5 watts at the outset to zero watts 10 hours later, I powered up the Lantern and it has been running flawlessly - - 10 hours anyway, but that beats my last week’s experience. I am now running with SNR 5 to 8 dB on Americas 98 W without problems.

I seem to recall someone mentioning the Lantern will power down if the Boston Li Ion battery dropped below some specific voltage even if the Lantern were connected to external power thru a USB source. If so, my Li Ion battery must have discharged (although that’s hard to imagine since my Lantern is permanently powered from a USB source).

Am I on target here? @Abhishek @Syed Ken


#200

We are definitely bringing back auto boot on power.