Beta testing RxOS release 4.0 - Skylark. Link in thread!


#101

After a reflash I can now get it to broadcast a ‘outernet’ hotspot again. It still won’t connect to my network though.

Same network device as it previously worked well with, no security/password enabled. Device is on channel 6.


#102

this is very weird as nothing has changed on the wifi front.

could you check the /etc/rxos_config.json file - near the end there will be a section for network config, “sta” mode, which will include the ssid and password you configured. Just could you see that and verify that they were correctly saved to file?


#103

The file contains

~
~
~

(lots of these no text)

I deleted it and rebooted but it now doesn’t bring up ‘outernet’ any more.

Accessing by USB I can see the file is recreated and contains default config text.


#104

the entire file was empty?

if you do just a “cat” on it, not open it in vi, is there any output at all?


#105

Sorry I just reflashed again. I’ll check with cat if it happens again.


#106

Is it a bug in the new software? I have a SNR of about 4 since the upgrade to Skylark, but in the status display I see my receiver 2x red.


#107

Hi Palbeda

I ran into something similar to what you report. Once, my balloons were red and my SNR was 4, and not changing. By that I mean, the SNR wasn’t bouncing around from hi to low values.

I had to reboot my CHIP twice to clear up that problem. Don’t know if it’s a bug or not, but it only happened to me once. Hope this helps - - let us all know. Ken


#108

Outernet kit with Skylar installed in Helsinki, Finland.

Seems to work quite nicely - even when the signal strength is not that great here. SNR goes up and down from 0 to about 4 - and yesterday afternoon/evening no signal at all, and I was already thinking that I broke the CHIP with the flashing of Skylar :slight_smile:


#109

All way get “USB device not recognized” after it is.

I even did this on a all most fresh load of windows 10 on a Lattepanda but same thing. But this time I unplug the Chip USB when it started to find the FEL chip to flash it. I plug the USB back in and it was working for about 2 min. Then Windows said same thing “USB device not recognized” and the flasher got a error.

Any one else have this happen? If so how do you fix it.

I even burn the OuternetFlasher-disk1.iso to a little CD but I guess it don’t boot.

-Raymond Day


#110

Your flashing seems to have gone fine from the screenshot. That second “Starting Outernet Flash” you can ignore (its just goes into that in case you want to flash another one - it won’t hurt a CHIP already flashed in the first round, like yours was).

once the “please be patient” message showed up, did you wait for 5 minutes or so, as suggested? Did the LED on CHIP start blinking? If it did, the flashing completed successfully.

Don’t worry about “usb device not recognized”. Thats all right. Windows doesn’t know what to do with CHIP.

oh, and no - the ISO won’t boot - it was made exclusively to be booted inside VirtualBox, not real hardware.

After the LED has started blinking, you should still be able to access the chip by starting a browser and visiting http://10.10.10.10

do not unplug the CHIP before the LED starts blinking!


#111

When Windows gets the “usb device not recognized” then the VirtualBox gets a error too. It just stops and it never gets done.

I am using it with Windows 10. Maybe that’s why.

It did not flashing.

-Raymond Day


#112

What error does Virtualbox get?

From your screenshot, if you see the message “Your CHIP is now flashed”, thats the end of flashing as far as virtualbox is concerned (though the CHIP itself will still take another 3-4 minutes to prepare itself, so DON’T unplug it). If your error happens after the “Your CHIP is now flashed”, it got flashed fine. Feel free to close virtual box at that point. Its not doing anything anymore.

As I said, your flashing seems to have completed fine, as far as the virtualbox part is concerned. If you unplugged the CHIP before its LED started blinking, then you might need to redo the flashing.


#113

It never blinks. I will try it tomorrow. I have to go to work now. Thanks for you help.

Going to reload Windows 10 on the Lattepanda and then I will try it again. I put Windows 10 on it with my own Windows but can download the Windows 10 right from Lattepanda and it should work very good. Right now it don’t do sound. So that my work then.

-Raymond Day


#114

No joy under Windows 10 or Ubuntu 14.04 LTS. Have installed VM and Extension pack. CHIP in FEL mode. In Windows 10, prior to launching VM, see libusbK device, C.H.I.P. Flashing mode. Upon start of this device is dropped from Device Manger list. However, see attached device 1F3A:EFE8[02B3] listed as ONDA (unverified) V972 tabletflashing mode [02B3]

Running VM hangs as shown in screenshot. Code: bad EIP value. Any ideas???

Tks, Bob

VM then reboots every 60 seconds. Letting cycle for > 5 minutes does not make a difference


#115

I had this issue with Windows 10 too. Luckily I was able to get it going under Ubuntu as the root user.


#116

Thanks Mark. Alas tried it logged in as root under Ubuntu and again, same behavior. No dice.

Hopefully a solution that works for me will emerge.

b.


#117

Do you have VT-x enabled in BIOS? I also had a similar error (Bad EIP value), until I changed the BIOS setting.


#118

Your machine either doesn’t have hardware virtualization support (VT-x), or it is disabled in BIOS. That is the EIP value problem.

Additionally, seems you have used the NTC chrome flasher on windows - thats the libusbK driver. That will interfere with the Outernet Flasher VM by intercepting the CHIP in flashing mode before the VM gets access to it.

Best bet is to figure out the virtualization part in BIOS first, and then flash under linux as root.


#119

Hi Abhishek and Syed,

It worked under Windows 10. Just enabled VT-x in BIOS. BTW, did not have to remove libusbK driver. Starting VM seems to disconnect the CHIP from the driver. What I did observe is that second “Starting Outernet Flash” showed up. I waited 5 minutes but had to power cycle.

Thanks! Will now set the system up again outside.

Bob


#120

My [quote=“N6RFM, post:119, topic:2660”]
enabled VT-x in BIOS
[/quote] was all ready on in my BIOS. Because I reset to go in the BIOS I tested it again.

The 2nd time it does the Waiting for CHIP in FEL mode and wile it did the … I unplug the USB and back in the CHIP. Then it started to flash it.

It says this at the end:

"Your CHIP is now flashed. It will now boot and prepare the system.
Status LED will start blinking when it’s ready. Only then is it safe to
disconnect.

Please be patiend. This can take 5-6 minutes."

About a minute later it came back to:

[email protected]:~$ _

About 3 sec after that Windows did a pop up saying USB device not recognized

It’s been about a hour and the Status LED is not blinking just stays on. I guess it did not finish the flashing because Windows 10 before it can flash does a USB device not recognized

Got a Raspberry Pi 3 any way and wow so easy to set up and get it working on that.

So giving up on this chip.

-Raymond Day