Beta testing RxOS release 4.0 - Skylark. Link in thread!


#141

for the 3.1 could you try the clean flash method - if you are comfortable with linux, it should work easily. if not, will have to think of something else.


#142

Just to test the radio+lna+bias tee function, you could also use OuternetInABox:

https://archive.outernet.is/images/OuternetInABox/Release_2/


#143

You did run the VM as root yes?


#144

The supplied OVA is not compatible with VMware Workstation. there are some errors with the networking and the cdrom iso configuration.

I have created a vmx configuration file using the ISO extracted from the ova. just put it in a directory along side the OuternetFlasher-disk1.iso extracted from the ova

The link below is to the VMX file based on the ovf config file.
https://drive.google.com/open?id=0B1-2zNc0JecES0VwTkpMTFR0VkU

I have tested using VMware Workstation flashing my own device and it worked without a problem.1 note is that its connected to a USB3 interface. if you only have USB2 you will need to edit the config in VMware workstation changing the USB interface to USB2.


#145

brilliant!

Could you try exporting an OVA of this from VMware?


#146

Sure.

https://drive.google.com/open?id=0B1-2zNc0JecET2F6MVI3UTJ4c0E


#147

Possible bug/suggestion.
Seems to exist in the 3 and 4 releases.
Related to my USB0 ip clash issue

The files in /mnt/conf/etc/network/interfaces.d are simlinks to /etc/network/profiles.d/
Its basically simlinking a folder of simlinks to somewhere that isn’t modifiable.
While yes its possible to delete these simlinks and make a real file with the needed changes i think the better option would be to also have the profiles.d folder in the conf partition so changes are preserved without having to delete the simlinks that exist. The other possible option is to have the simlinks in interfaces.d point to config files on /mnt/conf directly.

Additionally given that if one needs to change ip addresses the content of the /etc/conf.d/dnsmasq config files need to be adjusted to the new ips. i think the entire of the /etc/conf.d should be on the /mnt/conf partition not just the wireless folder.


#148

Minor security issue. (login required or active session)

The file manager allows manually entering paths with directory traversal.
home:///…/…/mnt/conf/etc

The FS api allows for directory traversal as well.

Arbitrary files can be uploaded. I was not able to read or download files.
However its possible to overwrite a file that exists it must be deleted 1st which can be done by making a direct call to the delete or rename commands
(testing with the /etc/version file as its restored on reboot)

curl 'http://10.10.10.182/FS/delete' -H 'Origin: http://10.10, deflate' -H 'Accept-Language: en,en-AU;q=0.8' -H 'Content-Type: application/json' -H 'Referer: http://10.10.10.182/' -H 'Cookie: session=43f25da32e32bf4e387681cc2c6a8813' -H 'Connection: keep-alive' -H 'DNT: 1' --data-binary '{"path":"home:///../../etc/version"}' --compressed

{“result”:true,“error”:false}

once this is done the upload method can be used.
only changes to persistent locations are kept like the /mnt/conf directory


#149

could you please create an issue at


#150

I have the beta up and running. VM flasher worked with no issues.

When in access point mode the CHIP 802.11 is VERRY BAD. I was able to get connected to it one time in 20.

I used that one time to switch it over to my router. After two reboots it was available on my local LAN.

I SSH’ed into the unit with no issue. The README says that I can use su get root permissions, but it asks for a password. Please provide this.

When I go to the Tuner app I could see RSL and SNR as well as packet counts in real time when the CHIP was an access point(10.0.0.1). When I log into the unit on my LAN with the CHIP as a node on my LAN (192.168.1.20) I do not get any Status updates in the app.

What is the command line, or what file are the real time stats of the radio link available in?

Thanks!

-Cecil
AA5CE


#151

New Problem

After running 2 weeks running without even a single hiccup, Skylark started to shut dowm.

In the last two days my Alpha Lantern powered down every morning - - asleep I think. Well, I brought it back with a reboot, and it ran 1 more day and then shut down again - - all lights on the CHIP off each time.

After reboot, I checked my satellite SNR data and could not even see my normal screens - - I had nothing - - no satellite - - no signal data.

My solution was to to re-flash my CHIP, which (after setting up the WiFi and selecting the correct satellite) everything worked fine.

@Abhishek any thoughts? Ken


#152

@CRCasey for su, can you try ‘outernet’


#153

whoa!

I would have liked to look at the logs before the reflash.

I was a hang, but an actual power down?

When you say you couldn’t see signal data: the UI loaded but the data was not updating? Or the UI did not load? Or there was absolutely no entries in the “status” window? Was other stuff working? Wifi settings appeared fine?


#154

@Syed

Tried ‘outernet’ for the superuser, no luck, still can not use su.

[rxOS][[email protected]:~]$ su
Password:
su: incorrect password
[rxOS][[email protected]:~]$

Thanks for the idea though. Any others to try?

-Cecil
AA5CE


#155

sudo su -


#156

Hi. This is my first post although I’ve been following events for a few months now.

My PCs are all using Windows 10 but I can use the Linux command line at a basic level.

I have a couple of observations.

The first concerns flashing:

I have three CHIPs all are version 1 and look identical. Number one CHIP came from Outernet as part of the DIY kit along with the patch antenna, lna and E4000 dongle. Numbers two and three came direct from NTC. All three behave the same when flashed using virtual box. There are no displayed errors and the flashing process ends with the white status led blinking for a few seconds before going steady. To be cautious I then waited for at least 5 minutes before disconnecting.

Number 1 CHIP briefly flashes it’s LEDs when power is applied. Pressing the reset button on the CHIP starts the boot process the power led comes on and the status led flashes for a few seconds before going steady. After a few more seconds the green led on the lna comes on - I’m using the v3 relations-dongle with the software controlled bias t. I’m able to see the outernet wireless access point and connect to it. From there on everything worked well and I was able to achieve lock and download lots of files over a few days. My setup showed up on the status page and everything worked well for a few days.

Going back to CHIPs 2 and 3. When power is applied both the LEDs on the CHIP illuminate immediately. The status led flashes for a few seconds and then goes steady. The outernet wireless connection does not become visible and the green led on the lna does not come on. Both CHIPs 1and 2 behave exactly in the same way.

I an only assume that CHIPs 2 and 3 are different to CHIP 1 or that they are both faulty.

The second is that CHIP 1 is no longer working correctly.

Having worked ok for a number of days during which time the battery pack discharged a number of time and had to be charged I find that clicking on the file or tuner app buttons I get a spinning circle with a cross in it displayed on the top bar and the information content is not displayed. If I hit the app button again I get another spinning circle with a cross in it. However the weather app still works and is a joy to behold although it doesn’t seem animate ocean currents.

Sorry this is a bit long winded but wanted to capture as much as I could to aid in the development process.


#157

Meant to say CHIPs 2 and 3 behave in exactly the same way. Put it down to brain fade.


#158

How recently did you receive these from NTC? Are these the old 8GB ones or the new 4GB ones?
Did they finish flashing completely? - flash complete in VM, then wait for 5 minutes, LED flashing, the whole thing?

The reason CHIP 1 doesn’t power up without pressing the power button is the recent addition of the “no auto boot” patch to prevent power glitches from damaging the firmware.

If CHIP 2 & 3 are in fact remaining ON when power is applied, and don’t require you to press the “reset/power on” button to start them up, then it definitely looks like the firmware did not flash to them. If they are the “new” ones, those might have some issues. I should receive my own “new” 4GB CHIPs and will try and fix whats wrong with them. If you are able to use a usb-uart if could help by sharing the UART boot log.

To the second problem. Could you get into the CHIP using SSH and get me the dmesg log and contents of /var/log/messages?


#159

Ordered some months ago. Received within the last month. Sorry can’t be more precise.

Yes, they completed flashing completely. Used the same Windows 10 machine, usb port and lead and virtual box software. Was very cautious and followed instructions exactly. Did it a number of times on CHIPs 2 and 3 with the same result. Only flashed CHIP 1 once.

Understand the power button use. Do power glitches include the battery pack dying? If so, CHIP 1 has suffered a number of those.

Yes, CHIPs 2 and 3 light both LEDs immediately power is applied. CHIP 1 doesn’t. It requires the power button to be pressed briefly before booting up.

Do not know if they are 4GB or 8GB. Is is possible to tell visually?

Not sure how to set up a usb - uart connection to a CHIP. Will look into it.

Will try to get the dmesg content and logs from CHIP 1.


#160

share hi res pictures of both sides of the CHIP 2/3 - should be able to tell from the flash chip markings.