Beta testing RxOS release 4.0 - Skylark. Link in thread!


#161

If the big chip on the top of CHIP is a hynix then it is 8GB. if the chip is a toshiba it is 4GB only


#162

Bingo.

Thanks @Syed.

One more question now, once a file is finished coming down it is verified, unpacked, then stored. Is there a logfile for that process? If so where is it located? I would like to add it to the log viewer application.

Thank you!

-Cecil
AA5CE


#163

Sorry about the logs - - I didn’t think of that. If it happens again I’ll copy them out for you.

Not a hang but a power off on the CHIP and tuner/LNA. The reboot I did was a standard push of the CHIP power button for a few seconds until the CHIP started. At first I thought my USB power wall wart went bad, and the CHIP was running on the battery until it ran down - - but that’s not what happened. I checked that angle because I had a wall wart go bad once before and the system shut down after the battery discharged.

As to the data signal, on the third day of power downing, my SNR would lock at some high level like 6.5 dB and stay there. Normally, the SNR flutters around some central level. I took the unit indoors out of satellite site, and the SNR remained locked, Then more reboots with similar results. Interesting point was with no signal my SNR fluttered around neg 0.5 or so, and when I brought it out to see the satellite, SNR immediately went up to a high level and locked there.

Well, after half a day of this fooling around, and all of a sudden, my Tuner tab only showed my satellite pick, and the Status tab was blank. I even tried re Applying my satellite selection, but no luck there either.

More rebooting finished out the day - - then both tabs became totally empty. I even tried swapping out LNAs and SDRs during all the above tests (as I have both kinds) and it made no difference. This pointed to the CHIP as the culprit.

A simple reflash fixed everything. So I will continue my watch.

Next time, which Logs should I copy out? Ken


#164

kernel messages, system messages and running processes


#165

Hope I don’t need to, but that’s what I’ll send you. Based on my past experience, the Alpha Lantern should run several weeks before experiencing this problem. Ken


#166

The files you would want to copy are the Kernel Messages, and the System Messages, and maybe Processes.

Also if you want to know your flash size, take a look at system messages for the lines like these…

Jan 1 00:00:09 skylark user.info kernel: [ 1.045000] nand: device found, Manufacturer ID: 0xad, Chip ID: 0xde
Jan 1 00:00:09 skylark user.info kernel: [ 1.050000] nand: Hynix H27QCG8T2E5R‐BCF 64G 3.3V 8-bit
Jan 1 00:00:09 skylark user.info kernel: [ 1.055000] nand: 8192 MiB, MLC, erase size: 4096 KiB, page size: 16384, OOB size: 1664
Jan 1 00:00:09 skylark user.info kernel: [ 1.065000] Scanning device for bad blocks

If you look at the third nand line you will see the system saying that it has 8192 Meg bits of Flash and a block erase size of 4096 bytes.

-Cecil


#167

OK - - will do. Thanks, Cecil. Ken


#168

Is it worth setting it up for these to be ‘phoned home’ every 24hr? Most of us wouldn’t mind you accessing this data and so long as it’s made clear to users I don’t see a problem with it?


#169

I am not sure how many people are running the Beta, but that may be way more info than the devs could use.

I would not mind sending up logs either… if it is useful.

-C


#170

CHIP noumber 1 has a Hylix intergrated circuit.
CHIPs numbers 2 and 3 both have Toshiba

I’ve had a look at the CHIP documentation and I don’t have the USB - UART lead…


#171

I have the log files from a Putty session. How do I upload them?


#172

If the files are less than 500kB, can you share it through Pastebin?


#173

Here’s a Putty session file. The first part is dmesg the second part is /var/log/messages. Hope this is what you are looking for. Let me know if you require anything else.

http://pastebin.com/qihyMYqB

Terry


#174

Just downloaded the RxOS 4.0, going for flashing…:relaxed:


#175

Skylark Failed Again

My Alpha Lantern failed again after being up about 48 hours in exactly the same way.

Just before the Tuner status stopped reporting anything looking like this:

It got locked up with a reported SNR of 4.4. I did a reboot, by the way, to get the above screen. My Lantern is reporting in on the overall status with red balloons as I would expect.

I am e mailing the logs to @Abhishek for a look. One thing I did note was the System logs only store system information from the last reboot. Seems like before with the rxOS, they kept a running account.

In a normal boot up process after all the modules are loaded, the system time changes when you get a connection as shown here:

Now I do not set a current system time:

I’ll standby, @Abhishek before I do anything else. The CHIP I’m using is the original CHIP that came with the Alpha Lantern. I have not used the replacement CHIP yet, although I have flashed Skylark to it. Ken


#176

Ok. I think i might have a good lead on this.

Thanks Ken, this was a good observation, and very helpful.

Could you also email me the complete outputs of (each of) the following commands (in putty):

top
df
cat /var/log/messages
dmesg
ifconfig

After that, reflash this CHIP (leave your replacement as is, I don’t think this is related to the specific CHIP at all, its definitely a bug).

Once reflashed, put it in operation, but leave off your external USB stick/drive. See if that changes the situation any over the next few days.

Also, ensure that the radio is plugged in securely - if there is any play/movement in the usb connection, it will cause the tuner status to hang, so thats one possibility (separate from the earlier mentioned bug in skylark).

Thanks again.


#177

OK - - PUTTY results are e mailed. I am reflashing the CHIP and putting it back in service WITHOUT my USB memory stick. Ken


#178

Just installed and booted RxOs with VirtualBox 5.1 in Win. 10 in Tanzania(East Africa)
Success installation but got the following problem:
:- The CHIP wont boot automatically,only by pressing the reset button on the CHIP - This will be a problem in case of an unmonitored device and power disruption occured.
Otherwise, everything is good just waiting for a file from outernet satellite now. Here is a screenshot of skylark 1.0 with all windows opened.


#179

The upgrade was a success. Just wait few more minutes, unplug the chip from computer, then power it up. It will blink once and turn off. Hold the reset button on the chip for about 3 seconds, the chip will boot normally. After that, just use it as usual.


#180

I have now tested the latest beta, Skylark and also I have some problems of that the system goes off by itself. Not only to some standby but full poweroff.

My system is the DIY CHIP version and no extra devices connected to it. Power is fed via good quality USB power source.

-Mac / Helsinki, Finland