Brand new CHIP, not working


#21

So when trying to run the chip-flash.sh file i get the error “ERROR: missing command ‘fel’” even though i have done the sunxi-tools part, by downloading it from git, doing the make and fel=$(pwd).

Any ideas ?

I’m using this guide http://rxos.readthedocs.io/en/develop/getting_started/chip.html


#22

Are you trying the older version or the new beta? The newer version can be flashed by a virtual machine. Do you have Virtual box installed?


#23

Hi Syed,

So i’ve tried running the Virtualbox method but it’s not able to detect the CHIP in FEL mode.

When i run lsusb i can clearly see the CHIP device with the correct vendor ID.

The only problem i know i have is the my virtualbox can’t run on USB 2.0 for some reason, but it works on USB 1.1.
Does this affect the flasher ?

I tried it on a windows machine as well, but exactly the same problem.

Any advise ?


#24

Just to double check: Did you short the FEL and GND pins on the header?


#25

Hi agian,

Yes i have shorted the FEL and GND pins.

When the CHIP is connected to the computer it starts automatically.


#26

Wow. You’ve stumped me (though that’s not terribly difficult to do). Let’s get @Abhishek’s feedback on this. Otherwise we can provide another option.


#27

which vendor ID is it? the device has three different device:vendor IDs depending on which stage of boot it is in. Can you tell me which one you see?


#28

Hi @Abhishek,

The lsusb reports the following.

Bus 005 Device 002: ID 1f3a:efe8 Onda (unverified) V972 tablet in flashing mode


#29

Oh! Did you install VirtualBox extensions pack?

Missing extension pack would cause you to not have USB 2.0 support in your VirtualBox.


#30

Hi agian,

I did install it, but still getting the error.

Is USB 2.0 curcial ?


#31

honestly, I have never even tried it with usb 1.1.

But clearly if the VirtualBox isn’t seeing the CHIP in FEL mode, it seems to be required. But more importantly, I am concerned as to why your VirtualBox doesn’t have 2.0 support - that might the real trouble here.

In any case - If flashing has not worked, you should still have the old firmware on it. I am curious how you could ping it but could not connect to it via ssh or http. Is that still true?


#32

Hi @Abhishek

That is correct, when starting it in normal mode i can see it on my network.

I can ping it, but i can’t access it through browser, ftp or ssh.

I have no idea what is going on.


#33

does it finish booting? its LED starts blinking, blinks at about 1Hz, and then stops after a minute?


#34

I plug it into the USB (Without FEL and GND short) it blinks once.

I press the power button, constant light for more than 1 minute.

Nothing else happens


#35

there are two LEDs on it - a smaller one, farther from the board edge - this is the power LED, and this is what “blinks once” when you plug it in. It should also remain lit after you press the power button.

Right next to it, nearer to the board edge, is the status LED. Does that light up/stay lit/blink?


#36

The status led power us and stays lit from what i can see.

It’s a bit difficult to be 100% sure since the power LED is so much brighter than the status LED


#37

no, the brighter one is the status led. that should be the one to blink.

It seems your unit is not booting up - I am still surprised its responding to pings. This is over wifi or usb?


#38

WiFi, it’s connecting to my own network.

I’m at a total loss here…


#39

could you try connecting to it over (micro)usb connection? the USB has a network adapter function, it should “just work” under linux and windows 10.

How do you know its connecting to your wifi? How do you know the IP it got assigned? Are you checking these in your router management screen?


#40

I know it’s connecting because when it’s off i can’t reach it, and when it’s on i can.
I also know because both the Fing app and my Fortigate firewall can see it when it is turned on.

I have tried connecting it to both linux and windows 10 with the micro usb connection, but it does not appear as any network connection.