Brand new CHIP, not working


#41

this is surreal.

could you post the dmesg log from linux from the point you plug it into a linux machine via microusb, and then power it up and for 2 to 3 minutes after that?


#42

Wait a second here - -

I have 2 CHIPs - - one has a single light and one has two lights. If I plug either into my Win 10 USB port, both will blink once then go out until I connect the FELL to GND. If my CHIP is plugged in, and I add the FEL to GND short, the CHIPS come alive. At that point I can proceed into the FLASH mode.

But a caution here - - I need to “futs around a bit” to get the Outernet Flash to see my FELed chip. Several attempts are sometimes required. In the Air Force - - this is referred to as a “fur ball”. In golf it is referred to as a “mulligan”. :grinning:

Don’t loss patience or give up!!

Ken


#43

So @Abhishek you are never going to believe this…

I disconnected the CHIP, cleared the dmesg log and plugged it back in.

Light blinks once, and i press the power button.

Start looking at the dmesg log when all of a sudden i see “Wired connection 1 connected”.

Without any reason, without me doing anything this little computer suddenly started working again.

I can connect to the “Librarian” through the USB connection.

I have no idea what is happening here, but i guess flashing it would be a good idea?
Is it possible to flash skylark through the settings on librarian ?


#44

I received my DIY outernet receiver kit for Christmas.

When I plug it in, the power light blinks, but doesn’t come on. pressing the power button doesn’t do anything.

When the FEL pin is grounded, the power light comes on and stays on. I was able to reflash the CHIP with Skylark, but I get the same response as soon as I power cycle the CHIP.

I connected a serial console to see if it could shed any light on the problem. Here is what I get:

U-Boot SPL 2016.01 (Jan 01 2016 - 00:00:00)
0x00000100
started by pluging in while battery connected -> powering down again

I am powering the chip via a 2amp USB power supply. I don’t have anything connected to the battery terminals on the CHIP. I get the same result when powered by a computer, or USB battery supply.

If I have the RTL SDR and LNA connected, I get a very short flash, and nothing on the serial console.

I have inspected the CHIP, but there are no obvious solder bridges or faults.

Any ideas?


#45

I saw pretty much exactly the same results when I tried to power mine directly from a Samsung 2amp Phone charger!
I tried another ( generic Chinese one that came with a USB HDD) that is 2 amp and it worked no problems ( on a short USB cable… a longer cable made it stop working again! )

So, my unscientific advice, try every 2amp or greater usb charger you have around the house! I think that the Samsung (and possibly other) ones limit the current depending on how they see the charge in the phone, and maybe they “see” the Chip etc. like a fully charged phone, and just don’t power it enough…

Good luck ( great present for Xmas!)


#46

I use a 2 amp 5 vdc charger (esentially a 10 watt charger) with a 10 foot USB cable. When connected to the Lantern (CHIP + AMP + SDR + Boston Power Cell) I see 6 ac watts when I plug the USB charger into a “Killowatt Meter”. Rates down in the 4 ac watt range spelled trouble for me with problematic cables and chargers. Ken


#47

My Outernet system, with the CHIP, a USB hub, the RTL, a 32GB flash drive, and the LNA, pulls between .88 and 1.1 amps at 5vdc.

The CHIP alone only pulls about .6A (600mw) at full tilt, as outlined in this assessment form the CHIP forum:

Idle: ~0.25 A (one spike of 0.33 A observed per minute)
CPU full load: ~ 0.5 A (cat /dev/zero > /dev/null)
Idle and connected to wireless AP: ~0.25 A (a few spike of 0.33 A observed per minute)
Downloading file with WiFi: 0.33 ~ 0.6 A (fluctuate between 0.33 - 0.45 most of the time)

So, even at full load on the CHIP, with the RTL and LNA going, I still wouldn’t expect to see more than 1.2-1.3A. Not enough to crash a typical 2A charger.

I suspect the issue may be more around voltage than current. Long USB cords tend to drop the voltage as well as limit current. Let’s assume best case the USB cable conductor is maybe 26ga wire. Run the voltage drop calculator at 1.2A load with a 10ft. cable:

Voltage drop: 0.98
Voltage drop percentage: 19.60%
Voltage at the end: 4.02

Ouch! Now, you probably aren’t using 10’ of cable, but, it’s apparent that can have a big effect on system power.

I also ran into some silliness with chargers. I tried on a no-name one that is rated at 2A, and it would only work with the 3ft. USB extension. If I added another 2ft. extender, the CHIP wouldn’t boot. If I changed to a Samsung phone charger, it works with the two extensions.

Now, the real test came when I tried to use a 15’ USB extension that works fine with a RaspberryPI/RTL ADS-B setup. It didn’t work with the CHIP/RTL/LNA. Go figure. CHIP may be very voltage sensitive.


#48

I’ve tried 3 different USB chargers from 2amp thru 2.5 amp that run a raspberry Pi 3 flawlessly.
I tried powering from a USB port on a Dell computer. The “STAT” light flashes once and the serial console says the “powering down…” message.

I just measured the voltage on the CHIP 5v pin using my 3 different power supplies. All 3 show 4.88 volts.

Voltage at the 3.3V pin peaks momentarily then drops to zero. With the FEL pin grounded, the voltage stays at 3.28.

I tried using a 3.3V lithium battery plugged into the Battery connector, and I get nothing, not a flash, or message.


#49

Two weeks ago I shipped both my CHIPs and the Boston Battery pack back to Chicago. They were experiencing some of the same symptoms seen above. @Syed and @Abhishek took a look at them and agreed they saw some of the same problems.

They sent replacements which didn’t arrive before my departure for Panama - - thus I’m working with an Outernet In A Box. I don’t know if they put a note in the new gear or not, but it would be interesting to see if what they found has any relevance here. Ken


#50

At this point, it appears I’ve got a bad CHIP. No matter what I do, it won’t power up unless the FEL jumper is installed. @Syed, How do I get it replaced?

In the meantime, I’m using the LNA and Antenna with a Raspberry Pi 3, but I’d rather use the CHIP so I can run the most recent code.


#51

Does the power LED “flash” momentarily when you connect power via micro-usb to it?

Then press the power button for about 2 seconds.


#52

Yes, when powered via micro-usb the “STAT” led flashes briefly.

Pressing the power button for 2 seconds does nothing.

I connected a TTL serial adapter to the console port on the CHIP, it says:

U-Boot SPL 2016.01 (Jan 01 2016 - 00:00:00)
0x00000100
started by pluging in while battery connected -> powering down again

#54

thats weird. it can’t be a busted chip if the flashing worked.

i am assuming you tried a longer press as well, but just to be sure?

Also, try without the battery? and/or a different usb power cable?


#55

I held the power button for at least 10 seconds, possibly more. I tried 3 different power supplies, all rated 2 amp or better. Tried powering it from the USB port on my Dell computer. Tried powering it from a 1.5amp USB battery. they all did the same thing: a single flash and the “powering down” message on the console. I tried different USB cables to no avail.

A google search of the error message brings up this: https://github.com/NextThingCo/CHIP-u-boot/pull/4/files . It appears to me that U-Boot is getting bad information from the AXP209 power controller. In FEL mode, U-Boot ignores the battery state, so I could flash the chip with skylark, but after that it still won’t power on.

For kicks, I tried an Lithium battery plugged into the JST connector on the CHIP. It didn’t do anything at all, no LED flash, nothing.


#56

I don’t know - the power button should work in this scenario. Maybe @syed can organize a replacement? I don’t think its busted, but can’t figure out why its not powering up.

See the thing is: the chip powers on, gets to uboot. uboot checks if it was powered on “automatically” or by pressing the button.

A last ditch would be try flashing the official NTC images and see what happens.

Which image did you flash? You could also, as a test, try the image from:
https://archive.outernet.is/images/rxOS-CHIP/3.1-201610122246/

which doesn’t have the “no-auto-boot” patch.


#57

Will most definitely send a replacement. Can you email us at [email protected] with your original order number?


#58

Just received the DIY kit w/ pre-flashed chip. I get the same “your receiver doesn’t seem to …” message when connecting to its accesspoint.

Would like to re-flash with latest (although this one may already have it - is there a way to check? I can get cmd-line access over the USB cable).

I don’t have VirtualBox (am using Paralels on Mac for VMs). But would it be possible to provide an image which is compatible with NTC’s CHIP Flasher? It’s effortless (using Chrome): http://flash.getchip.com - no need to install anything, but it doesn’t accept the skylark*.ova file provided by Outernet. If you could provide a flasher-compatible image, that would make things considerably simpler IMO - the flasher works cross-platform, and explains exactly how to perform the re-flashing.


#59

the NTC flasher is a proprietary tool and NTC has not made it available to us.

The OVA is equivalently easy and comes with detailed instructions as well.

if you are seeing the “your receiver doesn’t seem to…” message, it doesn’t look like you are connect to the CHIP accesspoint. That message is given by the redirector webservice, not by the software on the receiver.


#60

Ah - ok. Their flasher does have the ability to select any local file, can’t you provide a file in the proper format (assuming that is open)?

But thanks, I did figure out the error, and indeed, by connecting to 10.0.0.1 instead, I can access the web interface and set everything up. It’s receiving, yeay! \o/


#61

thats exactly what is not open.