Lighthouse test


#1

Im testing the lighthouse. I have connected the satellite dish, i have input the satellite configuration from the wiki. in my case is eutelsat 113w. but it says tuner configuration could not be saved. what could be the problem?


#2

Can you please check the application logs section in dashboard and paste it here?


#3

log download here


#4

and other log:
[2015-01-01 00:06:29 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:06:29 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:06:26 (+0000)] INFO Found 0 updates
[2015-01-01 00:06:23 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:06:23 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:06:20 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:06:20 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:06:17 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:06:17 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:06:14 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:06:14 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:06:11 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:06:11 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:06:08 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:06:08 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:06:05 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:06:05 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:06:02 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:06:02 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:59 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:59 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:56 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:56 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:53 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:53 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:49 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:49 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:46 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:46 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:43 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:43 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:40 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:40 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:37 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:37 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:34 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:34 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:31 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:31 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:28 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:28 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:25 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:25 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:22 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:22 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:19 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:19 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:16 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:16 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:12 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:12 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:09 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:09 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:06 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:06 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:03 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:03 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:05:00 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:05:00 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:57 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:57 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:54 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:54 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:51 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:51 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:48 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:47 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:46 (+0000)] INFO ONDD: tuner settings updated
[2015-01-01 00:04:46 (+0000)] DEBUG ONDD: received response code 204
[2015-01-01 00:04:46 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>
[2015-01-01 00:04:46 (+0000)] DEBUG ONDD: sending payload: yesQPSKDVB-S148918011719
[2015-01-01 00:04:44 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:44 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:41 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:41 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:38 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:38 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:35 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:35 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:35 (+0000)] INFO Found 0 updates
[2015-01-01 00:04:22 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:22 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:19 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:19 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:16 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:16 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:13 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:13 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:09 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:09 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:06 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:06 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:03 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:03 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:04:00 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:04:00 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:03:57 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:03:57 (+0000)] DEBUG ONDD: sending payload:
[2015-01-01 00:03:54 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no00.00
[2015-01-01 00:03:54 (+0000)] DEBUG ONDD: sending payload:


#5

Hm, I don’t see anything that would suggest tuner settings have not been saved. Did you use custom settings or the provided preset? Also, what Lighthouse version does it say it is in the footer?


#6

version: lighthouse 0.6.005. i used custom setting, because eutelsat doesnt appear in the presets


#7

its seems, is saving now. eutelsat is active? we still dont recieve signal


#8

Try upgrading to this image:

http://archive.outernet.is/images/Lighthouse/1.0.000/

To upgrade:

  1. put the .pkg file on USB stick
  2. rename it to wt200.pkg
  3. plug the USB stick into your Lighthouse
  4. wait for all LEDs to go out and unplug the USB stick
  5. wait for Lighthouse to boot back up

Let me know how it goes.


#9

thank you branko, how much time should it take? i have plugged it in like 20 minutes ago and led are still on


#10

It shouldn’t take more than 60 seconds total.

When you plug it in the first time, the middle LED should start blinking fast. Then it goes into slow blinking for up to 30 seconds, then all LEDs go out.

Could you review the steps and see if you’ve missed anything? If it doesn’t work, please download the system log from the Dashboard > Application logs and email it to [email protected].


#11

I tried with another usb and it worked. i will now try to connect again to eutelsat that now appears as a preset


#12

To clarify, did you try another USB flash drive, or another USB port?

Let us know how it goes!


#13

To clarify the last question the problem was the usb memory.

We have being doing tests. But we cannot make it work. Signal is always zero. We are using eutelsat preset. What else can we do.


#14

Could you post the system logs somewhere or email them to [email protected]? They can be downloaded from the dashboard > application logs section.


#15

i have sent them to the email


#16

Hm, this is a bit weird. The tuner seems to get a lock, but it’s subsequently reported that there is no lock. For reference:

# SETTING THE TUNER SETTINGS
[2015-01-01 00:02:59 (+0000)] DEBUG    ONDD: sending payload: <put uri="/settings"><tone>yes</tone><modulation>QPSK</modulation><delivery>DVB-S</delivery><frequency>1339</frequency><voltage>18</voltage><azimuth>0</azimuth><symbolrate>11719</symbolrate></put>
[2015-01-01 00:02:59 (+0000)] DEBUG    ONDD: received data: <?xml version="1.0" encoding="UTF-8"?><response code="204"/>
[2015-01-01 00:02:59 (+0000)] DEBUG    ONDD: received response code 204
[2015-01-01 00:02:59 (+0000)] INFO     ONDD: tuner settings updated

# SAME THING IN THE SYSTEM LOG
Jan  1 00:02:59 outernet user.info ondd[1129]: [main] tuning to 1339 Mhz 11719 KSym
Jan  1 00:02:59 outernet user.info kernel: [  [email protected]] i2c i2c-1: avl6211_set_frontend: delivery_system=5 frequency=1339000 symbol_rate=11719000
Jan  1 00:02:59 outernet user.info kernel: [  [email protected]] i2c i2c-1: BF is 64,BW is 10688
Jan  1 00:03:00 outernet user.info kernel: [  [email protected]] i2c i2c-1: Tuner successfully lock! <-- THIS

I’ll need to dig deeper to see what’s going on.


#17

ok, thank you


#18

i have made a new test today and still cant connect. looking again the system log it says its connected.

this a fragment of the system log:
Jan 1 00:11:13 outernet user.info outernet.monitor: Collecting data
Jan 1 00:11:13 outernet user.info outernet.monitor: Connected to socket
Jan 1 00:11:13 outernet user.info outernet.monitor: Connected to socket
Jan 1 00:11:13 outernet user.info outernet.monitor: Finished collecting data in 0.0623099803925 seconds
Jan 1 00:11:13 outernet user.info outernet.monitor: Transmitting buffered data
Jan 1 00:11:14 outernet user.info outernet.monitor: Could not establish connection to http://status.outernet.is/heartbeat/: HTTP Error 404: Not Found
Jan 1 00:11:27 outernet user.warn kernel: [ [email protected]] efuse version is not selected.
Jan 1 00:11:27 outernet user.info kernel: [ [email protected]] ID is not found
Jan 1 00:11:27 outernet user.warn kernel: [ [email protected]] efuse version is not selected.
Jan 1 00:11:27 outernet user.info kernel: [ [email protected]] ID is not found
Jan 1 00:11:27 outernet user.err wptdm[1136]: curl failed: (7) Error

I will send the complete log to your email. i hope this can help towards finding the problem. Thank you


#19

This is the heartbeat script, not the tuner settings. Tuner-related stuff appear as ‘ondd’ in the logs.


#20

you are right, i forgot to paste the important part. I also have sent the complete log to [email protected]

Jan 1 00:16:21 outernet user.info ondd[1129]: [main] tuning to 1489 Mhz 11719 KSym
Jan 1 00:16:21 outernet user.info kernel: [ [email protected]] i2c i2c-1: avl6211_set_frontend: delivery_system=5 frequency=1489000 symbol_rate=11719000
Jan 1 00:16:21 outernet user.info kernel: [ [email protected]] i2c i2c-1: BF is 64,BW is 10688
Jan 1 00:16:21 outernet user.info kernel: [ [email protected]] i2c i2c-1: Tuner successfully lock!