New ORx image for Raspberry Pi


#21

There is a fix that should fix this issue in the pipeline. I don’t have an ETA for the release, but some time in July most likely.


#22

Thanks - - I’m glad I’m not imaging things. In the interim my fix is to put the system on an ac timer that turns the receiver of every 4 hours for a couple of minutes thereby resetting it. Ken


#23

Hi, just about to start my DIY build. I have dropped the image on an 8gig SD card, worried that the library might get too big over time. Can I use an external USB HDD to store the library? What config changes will I need?

Cheers.

– Well, that didn’t go too well… first boot to login, used outernet as U/N and P/W, now what? Also, not scaling to the HDMI screen either. My command line is off the bottom… Tinker time…


#24

External storage has not been thoroughly tested, but there’s support. You need to label your external HDD EXT_STORE or ext_store (case-insensitive) and it will be detected and mounted on boot.

The main interface is web-based. Access the Pi at its IP address.

What’s type of monitor are you using? Screen size?

EDIT: Also, what kind of hardware are you using?


#25

Awesome Branko - Thanks

B+, Rx’er in the post!


#26

Btw, I just remembered. Don’t bother connecting the ext HDD directly to Pi. It has fuses on the USB hub that cut power if device tries to draw too much of it, and it has a weird definition of ‘too much’. Use powered external USB hub.


#27

Thanks, again. I’m going to get set up and deal with external storage after.

I’m got in through web GUI, just need my DVB tuner to arrive now.

Quick question. Is WIFI hotspot configurable through the GUI too?

Excited about your project. Hoping to support.


#28

WiFi hotspot is currently only configurable through configuration files in /opt/orx. The reason those are not in /etc is that /opt/orx is persistent, while /etc and other system folders are initramfs (changes do not persist across reboots).


#29

Plugged everything up today, just need to point my dish. I have a netgear router acting as DHCP server, also creating wifi hotspot.

Despite my little trips, it was very easy to do. Downloaded image worked first time, on my B+, with a HD Star DVB tuner (I think) courtest of Raspberry Pi.

Tomorow im going to get the LNB attched and get some content in the library!


#30

Hi from Switzerland,

installed the image, hooked up my cinergySusb receiver and immediately was able to get in via the web interface and a ssh session. The tuner is recognized and works. My problem is, I have a DISEQ switch with 4 LNB’s. My Hotbird LNB is number 2. Therefore I must send a DISEQ command to be able to use this LNB. Is there any way to do this?

Any help is much appreciated.
Cheers
andbroe


#31

DiSEqC support of any kind currently does not exist. I don’t have an ETA for it either as we’re working on different things right now.


#32

Hi Branko,
thanks for the quick replay. So th get things going, I will have to arrange for an single LNB setup. Ok will do. Hope we will see DISEQ support one day.

Regards


#33

I’m not sure how DiSEqC switching works, but it may be possible to perform the switching using an STB or a computer, and then plug the ORx back in.


#34

Hi Ambroe - - I’ve tried what you are doing with my DISEQ switch/motor on my 80 cm dish here outside of Washington, DC, on Galaxy 19, but it won’t work. I too have 4 LNBs connected to a DISEQ switch, but leave it connected to my FTA receiver for general FTA viewing, and dish pointing. I directly connect my Geniatech/RaspberryPi to the 4th LNB port (which is – as in your case should also be – linearly polarized) at the base of my dish. I use the WiFi hotspot in the PI to operate the Librarian from in the house after I point my dish to Galaxy 19.

If you are not too far from the dish in your house, you can bypass the DISEQ switch by connecting a jumper cable from port 4 or 2 (both would be the linear polarized LNBs you need to use) to your house cable and then set the Geniatech/Pi up inside. I tried that, but I have a 100 meter run and too great a loss. Downside of this approach, if you get it to work, is you loose all control of your antenna and can only view the single satellite you pre-point to. Ken