Skylark 1.2 feedback


#42

Hey guys, got mine back up and running! After gathering a bit of info I did the same as Neil except I changed mine from hotspot to “Connect to WiFi Router”. It already had my settings. When I did the apply it didn’t seem to work at first so I power cycled. Came back up working just fine. The tuner status page appears to be working again now too. I did NOT try to manually re-do the OTA update.

In regards to the dhcp not working it definitely looks like the dhcp service wasn’t running after the update, here is my proof:

After update but before I saved the network settings:

[Skylark][[email protected]:~]$ ps auxw | grep dhcp
16199 outernet grep dhcp
[Skylark][[email protected]:~]$

AFTER network settings were saved and system power cycled:

[Skylark][[email protected]:~]$ ps auxw | grep dhcp
325 root udhcpc -n -p /run/udhcpc.wlan0.pid -i wlan0 -x hostname skylark
16749 outernet grep dhcp
[Skylark][[email protected]:~]$


#43

Hi again
It is morning here now & just for the record @Abhishek , It seems to be running V1.2 without issue so far ( after forcing DHCP on , of course…
The zero byte file in the opacs directory are all still there though, so I am not sure when that garbage collection should occur…
Pity about the DHCP issue, otherwise it came close to working :slight_smile:


#44

Thanks everyone, for all the diagnostics and tests.

Yesterday was a mess - my own receivers failed (lost frame lock) right around the same time as the Alphasat backend failed, which happened pretty much the same time as I sent out the OTA. I had planned to come back and help solve the OTA issues after dealing with the Alphasat problem, but by the time I was done, It had already been a 17 hour stretch total, and I crashed.

Apologies for disappearing while receivers were failing.

The OTA kinda worked - meaning the rootfs update. The DHCP config seems to have been borked. I have a guess on what happened, but everyone who kept the archive as suggested by @kf4hzu, could you please email those to me on abhishek at outernet dot is.

I am still going thru the rest of the messages regarding the failures, and reply to those.

As far as expected product changes are concerned - do those work allright? How about mobile experience?

Guest user also needs to be put thru its paces.


#45

Should have occurred by now. Which means it didn’t work either. The files are actually harmless by themselves - I originally coded it such that if the opak extraction failed, the origin opak won’t be removed from the opaks folder. That helped with detecting such failures. The zero byte files fail, cause technically they are not archives, obviously.

if you wish, you can just select them in file manager and remove them.


#46

Yes. The config cleanup post-ota needs more solid work.


#47

just so this info goes out:

User scripts:

Skylark 1.2 has support for starting a user script at bootup. For the technically inclined, look at /etc/init.d/S99user, that should tell you all.

Instructions:

first become root

sudo su -

then make a directory called bin in /mnt/conf

mkdir /mnt/conf/bin

in this directory create your script and call it user.sh

vi /mnt/conf/bin/user.sh

as an example, heres a script that logs the snr every 10 seconds

#!/bin/sh

while true
do
	a=$(wget -q -O - http://127.0.0.1/DIRECT/getTunerStatus | jq .result.snr)
	echo -n $(date) ": "
	echo $a
	sleep 10
done >> /mnt/downloads/snrlog.txt

make sure the script is executable, and owned by root

chown root:root /mnt/conf/bin/user.sh
chmod 755 /mnt/conf/bin/user.sh

Thats it. This script will automatically run at boot.

be careful though:

  1. The script is run at the end of boot. So if you make changes to any service files or configs, you should restart that service as well.
  2. Be careful about how much RAM and CPU you consume in this script. Its a very limited system.

SkyLark 4.4 External API Documentation
#48

OK Thanks
:slight_smile:


#49

If the CHIP is booting up, WiFi starting with no DHCP, but not starting Skylark or the LNA power, what is the procedure to get it working? Flash and start over?


#50

are you accessing it over usb? is ssh working?


#51

Ted, have a look at my step by step instructions in the other thread to get the DHCP going again via wifi


#52

If skylark isn’t running you won’t be able to do what Neil did, you might try a reboot or two first?

If you can get skylark working follow Neil’s instructions to manually IP your system (if running windows) and simply go in and set the wifi stuff the way you want and click the save and restart. this seems to have fixed several systems, including mine.

FYI, my tuner app wasn’t working either, started working after reseting the wifi settings.


#53

@Abhishek I played around just a little bit with the “user” login. It appears that the locks on the network and tuner settings are working and it does throw an error when you get into them. One thing I have noticed that is mildly annoying is that even when you last logged in as “outernet” the password field is populated with “guest” automatically. It may be that when you set it to populate on initial login that it will always do that, but maybe you should have it either always populate the “guest” username too, or maybe don’t populate the password field. Not a big deal though.

One issue I am having is in resizing the window panes in the apps. If I try to resize the left pane where you make selections it seems like my cursor is set from then on out to adjust that pane, if I move from right to left the window edge slides with my cursor. I am not sure if that is from the upgrade or if it was happening before (I only ran about one day before the update).

Almost forgot to mention, I tried the small device access too. I was using my Samsung S6 so the screen was small enough that it wasn’t very useful given the design of the UI, but using firefox I was able to log in and open some apps. I do think I recall that scrolling worked in the news app at least, but not on network or tuner (which you stated). I also agree that using other browsers is not in the cards yet, tried it with the Android default browser and with Chrome both with very poor results. Anyway it appears to be working via firefox, but as you suggested on a 4 inch screen the experience is less than stellar. May have to try it soon on one of my kids tablets.

Other than the tuner app failing on the OTA update too I haven’t seen any other issues so far. In fact it may be purely coincidental but the first day I had my kit I couldn’t get lock sitting in a south facing window, never got above a 2 SNR. Last night when I moved my setup back inside to the exact same window with the same placement I am getting an SNR of 4-6. Probably just conditions changed but that is a big jump, didn’t know if there were any software updates that might have helped.


#54

Have rebooted several times and allowed it to sit running overnight. No Skylark, no LNA power. Have not tried over USB. WiFi is working, can connect with manual IP, no Skylark. SSH responds.


#55

My initial OTA update worked fine until I went to change the network setting to join my local network. I reflashed, and did the manual update. Now I am scared to try to change the network setting from AP. Anyway, using firefox from my andoid, gave a good gui performance.

Very cool. Good work, folks.


#56

It seems to me after I rebooted CHIP I was not able to connect CHIP wifi from my laptop.
I will probably re-flash back to 1.


#57

I connected a TTL-to-RS232 gadget and checked the serial messages. After the usual bootup
messages it repeatedly displayed “cannot open /dev/ttyGS0”.
When pressing ENTER I noticed that below this, a login prompt was present.
I logged in, moved /mnt/conf/etc to /mnt/downloads and rebooted.
Then, the receiver worked as normal (but unconfigured, of course).
I re-configured the network to connect to my WiFi, and downloaded the old saved /mnt/conf and
the current one. I did not notice any difference that would cause the problem.
Apparently the action of “setting everything to defaults” fixes it, but not in /mnt/conf.
After this recovery, the visible devices on micro USB also re-appeared.


#58

@Abhishek, A couple of people have reported

  1. No wifi connectivity.
  2. No LNA power.

Unlike some with “simple” DHCP issues my problem is that I can’t associate with the Outernet SSID. I previously had the default hotspot and wifi settings. Could this be a “country” problem again?
I also have no LNA power.

Do you want me to try anything before I reflash back to 1.1?

Gary


#59

As above, you can fix it by connecting serial terminal (115200 baud), login, rm -r /mnt/conf/etc and reboot.


#60

Is this update still available for ‘europe’? Because i don’t find him.


#61

Try what I did. Don’t click apply and reboot. Instead change your settings and then reboot via ssh.