Skylark 1.2 feedback


#82

I uploaded v1.2 to opaks, let it work…

And at first there were problems as noted above (nothing under tuner settings etc, not assigning an IP on a phone…)
but with setting the country and rebooting, those issues resolved and all is working great now.

It took a while and repeated tries for 10.0.0.1 to load on the (android) phone but now it works fine using firefox.

_update about 2 hours later

strangely now I can connect to outernet wifi fine on both laptop and phone but 10.0.0.1 won’t reliably load on either phone or laptop.

Error messages are:
“10.0.0.1 says: Failed to launch Application
An error occurred while trying to launch: CoreWM
Failed to launch ‘CoreWM’, Application mainifest not found!”


Failed to initialize OS.js


failed to launch application
error by CoreWM
application ‘CoreWM preloading failed: /packages/default/CoreWM/scheme.html’,
’/pagages/default/CoreWM/combined.js’


on phone: Ajax error after login window greying out and unresponsive (don’t remember error code but it was about 3 letters)

After leaving the outernet running, logging out and doing other things for a while, and trying again I was allowed access to 10.0.0.1, and it seems ok.


#83

I think @Abhishek said that he thought the issue was related to user settings. It seems like most reported problems are due to a user setting? (Network settings, satellite settings) so it seems like this validates what he said. Further it seems from the comments that any change that saves a user setting resolves the issue. Just my observation.


#84

Did the 1.2 update proceed complete free of issues for anyone?
Maybe it works OK only when everything is at defaults, as indicated by some reports that it works
OK when done on a system flashed to 1.0 just before.
Maybe as soon as the WiFi has been configured to anything else than open Outernet AP, it fails
during the update. Mine was configured as client, and like what others reported it failed in the mode
"switched back to Outernet AP without password and no DHCP". As I had no system that could
connect to that, I had to reset it via the serial port (and then it was OK again).


#85

Only had time to have a look at the update just now, I’m on Alphasat so down and uploaded the file myself. Prepared for a long night getting this thing to work, As sort of an anticlimax the update did exactly what is was supposed to do.

The CHIP rebooted as an AP, connected to it, switched the network settings back to my LAN, a reboot and everything works smoothly no problems sofar…


#86

All working fine now, glad to see the Guest user added now.


#87

There appears to be a small issue with the logfile rotation.
On my system there now are 2 files in /var/log: messages and messages.0
The messages.0 file is apparently a “rotated” messages file after it became too large (although I
have not yet found the place where this rotation is done), however now the rsyslogd is writing to
the messages file while ubihealthd keeps writing to the messages.0 file (the original messages file it
opened before it was rotated).
It looks like ubihealthd has not been notified of the logfile rotation. This could mean trouble when,
on the next rotation, the file that klogd is writing would be compressed.
(/usr/bin/node also has this file open for logging… probably not all programs should be logging to
the same file, or they should all do it via rsyslogd)


#88

I just received the kit on Feb 3 and am already locked out. Wifi is off.
First I was able to log in and tried reception of Alphasat. Only Code Lock, no Frame Lock during 1 hour of recpetion at 7-8db SNR. I verified the hardware: with Outernetinabox recption immediately started,
even down to 1-2dB SNR! Maybe beginners should be directed to try Outernetinabox first.
In the log viewer I saw some error with usb-eth. I entered my Wifi settings but backed out without saving/changing network mode. After rebooting, the Wifi AP was off.
So far I was unable to connect to it locally (composite video is a pain nowadays).
How can SSH into it? I am familiar with RPi and other boards (AVR, Arduinos) but not with CHIP.


#89

I have The same problem, The solution for me : reflash to version 1 ( https://outernet.is/docs/ ) then install version 1.2 and afther that you may changing The wifi and other settings. https://discuss.outernet.is/t/first-skylark-ota-features-and-release-info/3170/21


#90

For me that would be the last resort. Only some of my computers support hardware virtualization. Those who do already run some other virtualization software and I fear Virtualbox will break them. I tried to serially connect, but the CHIP appears only as “CDC Composite Gagdet”, not as COM port (Win7). I found the driver discussion here:https://bbs.nextthing.co/t/need-gadget-serial-v2-4-driver-for-windows-7/2044/11
I will try this.


#91

You can also use a TTL-RS232 converter or TTL serial USB cable and connect it to the serial port
of the CHIP to recover it. This does not require special drivers.


#92

BTW, I noticed on my system that the CHIP won’t boot up correctly after a short power loss. It needs to be off for some 5 minutes to make boot work. The faulty boot symptom is that Wifi won’t come up. When everything works, the LED will start blinking several seconds after power-on (it will later turn back into constant-on). On faulty boots, the LED will stay constantly on.


#93

I have never had to wait 5 minutes but I have been in a similar situation if I just pulled the plug and put it back in. Usually repeating a second time or waiting a minute or so it will come up just fine. Sometimes I just have a solid white light, sometimes the LNA doesn’t seem to power up. Like I said though, another reboot or just shutting it down and waiting a short time and I don’t seem to have the issue. Good to mention it though!


#94

Like @dschieszer says, I have had it needing to start “cold” a couple of times, and sometimes you need to remove the power completely, but only for a few seconds, and then it will start OK afterwards.

It is good to keep in mind that the CHIP hardware is absolute bleeding edge technology, and we are running beta software on it, so this sort of issue could be from anywhere. I suspect that sometimes that hardware doesn’t initialise correctly, thus teh need to power down to “cold” start.


#95

Just a quick update on USB charging cords

Last week I posted a comment about some USB charging cords not working (meaning mysterious loss of WiFi connectivity, reboots, and shut downs) while other USB cords worked fine. The short quick charging cord I finally settled on has run flawlessly. I replaced it with one of my questionable cords (they run everything else I own) and the problems returned.

Consider this proof of CHIP power finickiness, and further justification for Outernet to ship DIY kits and Lanterns with “approved USB charging cords” (Hint-hint @Syed)

The USB charger has not made any difference so long as it is at least a 2 (or more) dc amp unit. Ken


#96

Yep! Reviewing cables; have for different ones on my desk.


#97

@pe1chl
Rob, my system was as per default and I had the problems as recorded.


#98

More feedback.

I left the system to run for a couple of days. All went well. Tonight I decided to see if setting the country code would help with the poor wifi performance.

The country code was accepted and after a reboot the wifi came back fine. Good news!

But … once again no LNA power.

Here is an extract form the system status page.
Is there any more information that I can provide to assist?
I am going to remove the /mnt/conf/ directory as that was the cure previously.

[fail] Process demod
[fail] Interface usb0 is up

               **********************************
               ***** SOME TESTS HAVE FAILED *****
               **********************************

NOTE: Some items need more time to pass. For example, servers may need time
before they start responding. Other items may need manual intervention before
they become operational. When in doubt, rerun the tests after a short delay.

Summary:
Tests run: 17
Tests failed: 2

Storage usage:
/boot 39% 129.7M
/ 0% 32.0M
/mnt/conf 0% 31.5M
/mnt/downloads 1% 6.8G
/home/guest/downloads 1% 6.8G

Uptime:
00:04:49 up 5 min, load average: 0.20, 0.43, 0.21

UPDATE
I removed the directory, rebooted and still no LNA LED. Rebooted again and success.
I am starting to suspect that I have hardware problems…
What is the best way to track this down? It’s clear that the demod process is failing but is it because of hardware or software? Is there a debug file of some sort for the SDR?

UPDATE 2
On second thoughts others have also reported the lack of the LNA lighting up after the OTA so I am back to suspecting something to do with the OTA update.


#99

NEED HELP!

I was able to static set the IP and gain access to the CHIP. I uploaded the 1.2 file and it disappeared as expected. I let it sit for 20 minutes, I did not see it reboot. So I shut it iff and restart. Still no DHCP. How do I fix this? is there a version 1.3? I do not have access to RS232 or flashing tools.


#100

When you can still connect in some way (using fixed address, using ethernet-over-USB, using RS232)
the usual way to fix this is:

  • ssh to the receiver
  • login as outernet (password outernet)
  • sudo sh
  • rm -r /mnt/conf/etc
  • sync
  • reboot

This brings the receiver back to default settings.


#101

@Gary_Smith Hi,

Quick review of the symptoms…

No LED on the LNA.
Also no Demod process, so it is failing for some reason.

My guess is that the SDR is not getting enough power from the USB port and is failing.

So maybe the whole CHIP computer is not getting enough power from your power input. Believe me, this is not uncommon, the CHIP is a bit of a power hog when it is starting up, and people here have found that any sag in the input voltage supply is going to cause issues.

This drop can come from two major areas. The first is the AC/USB converter itself, a 2A output is recommended. Secondly, and maybe harder to account for is the USB Cable itself between the converter and the Micro USB power input of the CHIP. Light weight thin jumpers may ruin your day, even some good jumpers may not be as good as you think they are.

You will also find a small white JST connector on the CHIP, this is battery power backup. And it can supply an extra boost if the input power gets a bit squishy. (tech term, highly accurate) You can find batteries to plug in there for 10-15 dollars that will help as well.

Finally there is an issue you have not gotten far enough along to have, which is noise in the receiver and LNA. So if you get to that point just do a search on shielding and ferrite chokes.

Let us know what you have for power now.

-C