Skylark 1.2 feedback


#122

My assumption (I could be wrong, I’m sure someone will chime in) is that is the correct behavior for the weather, in that you are looking at the most recently downloaded data, which was from yesterday, and then actually clicking ahead to yesterday’s forecast for today.


#123

Correct!


#124

I guess this is my fault :slight_smile: I requested the change because, as you pointed out, it doesn’t keep the position you are in when it refreshes. I figured having a longer refresh timer was a quick and easy patch. If there is a way to redesign it to refresh and still maintain the page and index position, great, but I would imagine the priority for that will be relatively low compared to some of the other outstanding things. I’m sure it will eventually be improved. Actually if you know javascript pretty well you could make the needed changes yourself and submit a pull request on GitHub :smiley:


#125

Possible that because it seem most users opt to connect the LNA directly to the RTL-SDR, the LNA board is getting stressed, flexed, and breaking the SMD solder points.

Guys… Use SMA jumpers, save hardware.


#126

Hi All
I have a really strange problem with the hotspot (maybe it was also in v1.0 ??)
I can connect all the time with Win 10 machines.
However my Linux or Android devices will generally only connect if one of the Windows machines is connected !
Once connected they are OK, I can disconnect the Win machine.
However when I disconnect/reconnect the other machines they will not connect
until I re-connect the Win machine !!
I see the SSID OK.
Geoff VK2ZAZ


#127

That is a head scratcher


#128

Are you on a small screen? On a laptop, this should not be the case.


#129

Geoff
This may actually be tricking you…
I bet the Windoze machine is closer to the CHIP right?

I found that the CHIP would not connect to my windows machine inside despite the fact that I could"see" the hotspot from the CHIP that was outside… about 10m away… it just failed to connect…

If i went outside with my phone and went really close to the CHIP and connected, and then I walked inside and “carried” the signal with my phone I could magically connect from the PC!!

I suspect that the CHIP transmits with very, very, low power by default, except for it’s SSID broadcast. once it is connected though it does the normal “WiFI” thing during polling where it will change power levels to keep a connection, thus once one device is connected ones that could not “hear” the CHIP responding through the 2.6 Ghz “hash”, can suddenly hear the responses.

there is a lot of criticism of the CHIP on-board wifi out there. The antenna it uses is useless :frowning:
Neil
M0KNC ( Used to be VK4KNA millions of years ago! )


#130

I saw same issues when the CHIP was running as hotspot. Then I configured it to connect to my home network. Even though this goes across the whole house and the outside wall (my receiver is in a plastic outside cabinet), my router shows the signal strength from the CHIP with 4 out of 5 bars.
It has never had any issues connecting to the home network even though it is much further away than it was possible to connect to it being a hotspot.
This proofs that it is indeed a very good antenna and Wifi as such works just fine.
There might be a specific issue when it is configured as hotspot.
Not sure what it could be. Maybe it overheats when constantly transmitting beacons? Maybe it is configured with a lower power setting?


#131

laptop with 2304 x 1440 resolution.


#132

Hi All
Yes, Neil is 100% correct, I had just worked it out before he replied.
Using iwlist wlan0 scan on the Ubuntu box as I moved it around the room
I could see the problem.
All my machines were withing 2 meters of the C.H.I.P. but obviously some computers just received better than others.
Certainly an interesting little exercise.
Now that I know, it is not really a problem.
Regards
Geoff


#133

What has really worked out well for me is using a $15 TP-Link “repeater”. After that, no problems connecting to the Outernet even from down the block.


#134

I thought about trying this as a more portable option but haven’t got around to ordering it yet.


#135

Today i decided to give Skylark a chance, so i flashed my chip with the 1.0 version, then did a manual update to 1.2 as described here. Since I couldnt find a way to change the default “outernet” pass in the web interface, i did a passwd in the command line and change the password. However, this locked me out of the web interface (can no longer log in with the default username/pw, nor with the new pw (ssh works with the new password, it’s just the web interface that doesn’t). Guest account still works. Changing back the password from the command line to the default doesn’t help either, webui stilld doesn’t work.
So my question is, is this normal? And is there any way to fix it? (a part from re-flashing)
Thanks in advance


#136

As is written elsewhere, use passwd -a MD5
Then it works OK.


#137

thanks, that worked


#138

Please change the startup of ubihealthd, adding the flag -v 3
This sets the loglevel so that it does not log the INFO messages (but still logs errors).
Also, the messages (and also those of the “/usr/bin/node” program) should not be written to
/var/log/messages because that one is rotated. A separate file should be used for each, or better:
a pipe to logger should be used instead.


#139

done. thanks!


#140

after 2 weeks uptime, my CHIP went off the Wifi this morning and I had to reboot:

Feb 21 14:22:38 skylark user.info ondd[21496]: [carousel] completed: opaks/da6a-DeMarcus_Cousins.html.tbz2                                             
Feb 21 14:35:39 skylark user.warn kernel: [1590808.730000] ubi0 warning: ubi_eba_atomic_leb_change: LEB 2:1 changed from full to partially-written stat
Feb 21 14:35:39 skylark user.warn kernel: [1590808.770000] ubi0 warning: ubi_eba_atomic_leb_change: LEB 2:2 changed from full to partially-written stat
Feb 21 14:47:26 skylark user.notice cleanup: Starting cleanup                                                                                          
Feb 21 14:47:27 skylark user.notice cleanup: Needs 409600 KiB, but there is already 7058100 KiB, nothing to do                                         
Feb 21 14:55:40 skylark user.info ondd[21496]: [carousel] completed: opaks/05b0-news-pack.2017-02-21_1443.tbz2                                         
Feb 21 14:55:52 skylark user.info ondd[21496]: [carousel] completed: opaks/1b78-messages-2017-02-21_14_50.txt.tbz2                                     
Jan  1 00:00:38 skylark syslog.info syslogd started: BusyBox v1.24.1                                                                                   
Jan  1 00:00:38 skylark user.info kernel: [    0.090000] Calibrating delay loop... 1001.88 BogoMIPS (lpj=5009408)                                      
Jan  1 00:00:38 skylark user.info kernel: [    0.090000] pid_max: default: 32768 minimum: 301                                                          
Jan  1 00:00:38 skylark user.info kernel: [    0.090000] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)         

strange enough, the user.sh script was gone after boot and the guest password was back to the default but not the outernet password. How can that be?