Skylark 4.4 images for Dreamcatcher


Clarifying a few points.

  • Dreamcatcher is the name of our current hardware, which is an interested rtlsdr and CPU.

  • Skylark is the turnkey software that is used to receive the current Outernet broadcast. It is available for CHIPs and Dreamcatchers

  • Armbian is like Debian, but for ARM-based single board computers. It allows users to do whatever they want with the host computer.


For now, can you post them here? I’ll then take the post and edit the title and categorize is.


Skylark running on Dreamcatcher - opening News App Icon

Stuff is in the news folder – just can’t see it

Bug: News App Not Displaying Content

I’m impressed!! I bet Susan (my wife) a free dinner if it worked first time out off the box). I lost!

Standard setup procedures gave me an Outernet WiFi that I used to get into the Dreamcatcher to reset a network connection to my router. I set the satellite, and am on-line. Next, I need to get the Dreamcatcher outside looking at Americas. :grinning:

Congratulations, Ken in Annapolis, Maryland, USA


Anyone else seeing potentially doa boards? Tried 2 power supplies (up to 2.5 amp), two SD cards/different brands. red/green stay lit near power. green, red, 2 blue, green, white near SD card. Nothing blinks or anything. Slight high pitch squeal out of the board. I may try ARMBIAN to see if it behaves different.




got it working on the first try…

what a thing of beauty. This will replace my CHIP DIY kit - much more elegant…!!

Thanks Syed - absolutely beautiful…!!


Skylark 4.4 Passive Antenna Dreamcatcher Setup

Don’t know if anyone else tried the Passive Antenna image file (skylark-dc-1705141809.img), but I can’t get it come up properly. Standard procedure calls for burning the image to a micro SD, then boot up and find Outernet Hotspot. No Outernet hotspot appears, so I’m unable to get into the Dreamcatcher to make changes to get it on the correct satellite or my WifI.

As said before, the Active Antenna image file (skylark-dc-1706222246.img) works fine. Ken


did you burn it on the same sdcard that you had earlier burned the active antenna image on?


This is a good question/point. I had this same issue. Even though I re-wrote the image file to the same card, it still seemed to recover the previous data that was still technically sitting on the card. I had to do a full format (I just wrote zero’s to the first few GB of the card) and then I wrote the image again and it came up clean and as it should. Not sure what process is being used for the firstboot partition creation, but your card will likely just need a full format before you write down the passive image. HTH


@davidsaintruby - I had a DOA board, different light situation, but wouldn’t boot nonetheless. Would probably help if you could hook up a rs232 converter or USB to UART adapter to the board and see what its throwing when you apply power. Mine was that it detected zero RAM. @Syed replaced it quick after seeing the error and a picture of the board. PM me if you have questions on this process, I’ll help where I can.


partially correct:

the image is designed in a way that burning a new image over an old one without a full format will not overwrite the config or already received files. This allows for painless upgrades, for example.

So in @kenbarbi scenario, in all probability, his DC is already on his wifi network (hence the missing “outernet” hotspot).

If you do want a full reset though, of course you should first format the card and then burn the image.


Nice, good to know! That means you will need a format to switch between passive/active img files then. Which makes sense based on your explanation.


no. you don’t need a format to switch between active and passive. The config is the stuff you can configure on the UI - password, satellite, wifi details, etc.

active, passive, on the other hand, is part of the image. When Ken wrote the passive-antenna image over the older one, his config carried over…and as long as he remembered to use the correct rf port for the passive antenna, his system should be (barring unforeseen issues) fully operational at this point - correct satellite selected, wifi connected, everything.


Good info, thanks, wasn’t aware that wouldn’t be part of the config.



I wrote the passive antenna image to a new NTFS formatted 16GB micro SD chip I took out of my Canon camera. It never had an Outernet image on it.

I’ll try again with the same 16GB micro after doing a bunch of erases/reformats and report back. Ken


Update # 2

Success - - I did a complete erase/reformat to FAT32 of my same 16GB micro SD chip using SD Formater. I rewrote the same image file, and found the Outernet Hotspot this time and proceeded to set up the Dreamcatcher for Americas and my local WiFi. I guess it is important to start off the image writing process with a good chip cleaning.

By the way, SNR performance with the Passive Patch Antenna and the Active Antenna is the same. I did note the Active Antenna works just fine (same SNR and RSSI) lying flat at my latitude of 39 deg N. That’s good news to all. I wonder how some Forum members in far North Latitudes in Europe will do. Ken


My oriignal image failed. Precisely what are ALL the settings for the SDformatter?
When I plug it in and turn it on, the com port is not recognized. Should it be?
I also don’t get a wifi. Is there any reset on the board that is above and beyond the SD card? I’m confused. And frustrated.


Thanks Mr. Unix Punk. I tried burning an Armbian image with no luck. I tried doing a zero write to the entire SD and burning Skylark after that to make sure none of my old rPi file systems were messing anything up with no luck. I tried a third PS know to work with my rPi 2s and 3s and no luck. I have a UART cable from some rPi work, and no joy there either. As Bones would say, he’s dead Jim. Talking to Outernet about a return.




I used SD Formatter Version 4.0 from

I run it on my Windows XP or Windows 10 computer. After plugging in an SD card to my computer, I see (for this example) an F drive size 14.4 GB called CANON_DC"

In Format Option, I select FULL (OverWrite) and leave FORMAT SIZE ADJUSTMENT OFF

It takes awhile on a large SD card, but it worked fine for me yesterday.

Then I used _Win32 Disk Imager f_rom to write the Skylark image.

I hope this helps. Ken


On the Dreamcatcher v 2.03… I am trying to learn the leds by the antenna port. I assume flock flickering is a good thing, solid white pwr, and heartbeat on usr2 is pumping along, the usbh by the sma is on. But the others snr… do not seem to be enabled yet. I hope this what others see.