Skylark 5.3 for Dreamcatcher 3


Yes. It did work fine under 5.2. But I do have Comcast cable for my internet provider, and they have a hotspot, plus their IP is the same as the Dreamcatcher,, and I have difficulty getting connected. Ironically, both the cable modem and dreamcatcher are within 12 inches of each other, and it all worked fine up to now. My router is in another room about 20 feet away, and this has all been a mess this morning. Strangely, it has all gotten along up to now.


Put my second sd with rachel files in the second slot… the green light has been on for several
minutes… I think is now corrupted… … no I can still read it when i put in a laptop…

Dreamcatcher/skylark is NOT happly when I put in the second sd card


Can you get into the Comcast Modem, Jerry? If so, you should be able to change the Comcast Hotspot IP. I have Comcast too, but I provide my own Modem. Ken


Thanks, Ken. I can, however, time is gone for today, and I got the DC back into STA mode and it gets an IP, but the login screen does not load now, so will have to come back later… perhaps re-do the SD card…


I did a reboot, and now the packets are showing up normally. I don’t know if last time I didn’t wait long enough or not for the package count


Still can’t see my external micro SD card. Printing all pages in a frame using Firefox browser continues to work fine. Chrome, Opera, and IE Explorer only give you part of the first page as before. Ken


It took three reboots, but the external drive (second sd) finally mounted.


Here’s something I just found. My original 32 GB SD card (which wouldn’t boot) is nearly full with Othernet Download files. It has 3 GB of Othernet Download files plus all my Rachel database. It only has 512 MB left. I put a new 32 GB FAT32 formatted SD card in, and it was recognized immediately. I rebooted several times and it is always seen. I put the original full 32 GB FAT32 formatted SD card back in and it was not recognized.

So I think the issue is one of free space.

This begs 2 questions for @Abhishek, 1) If the SD card is full, does that cause a problem in recognition, and 2) Why is so much Download file storage being used (3 GB of data for 3 months seems high). Ken


Yeah, I tried to look at the /external-drive/downloads and crashed my skylark
I then tried to restart… it wouldn’t fully boot with the second sd still installed.
So. I restarted with only the operating system sd, that was ok
then in inserted the 32gb second sd…
after three minutes of “checking disk integrity” it timed out and that was far as I got

I know the skylark does a 7day cleanup of the files… some of them…
The question is “what is being mirrored over on the second sd card?”

These screen grabs are a little hard to read from the system messages log.


Yep - - that’s what we need to know. Ken


there is an option on the lcd setting.
called unmount the external sd card. It’s a little tough to get
there but I’m trying it to see if it does and help


I finally got to the home:///external_sdcard/downloads/Wikipedia
there are 4797 files for 2.2 GB on my secondary sd card (from the month of July)


2.2 GB seems too high. Let’s see what @Abhishek has to say. Ken


I’m back. The 3.02 is working again. The IP problems were related to distance, other 2Ghz devices in the area and other units disconnecting from the router at the time we were trying to get an IP and it had not rearranged the routing properly until it was rebooted. My second SD card has next to nothing written to it, and reports on the screen as soon as booting up. I see that my balloon came back green. Most of what we discussed earlier pertinent the audio is still valid, although it has cleared up and is very good in quality. A little stutter at the start of sentences occasionally, but not enough to be disruptive to the dialog. Apparently we no longer have an indication in TUNER as to audio frames received and frames played.


By the way - - I deleted the 3 GB of Othernet Downloads from my 32 GB SD card with Rachel, and now it works fine. I’m sure the answers lye in the fact that the card was full.

If the external card fills at the rate of 2 GB per month, for 24 months of operation, we’ll need at least a 48 GB card, so I’m thinking the solution will be a 128 GB SD card Fat32 formatted and loaded with the32 GB Rachel database. Ken


I also notice the flashing green led by the headphone jack is No longer flashing. It used to flash when decoding audio.


20kbps is 200MB per day, or 6GB per month.


Good evening all,

Did the upgrade a bit ago here and all went smooth, got it back on the network and am getting activity. However, it seems something is off… If I go into the news, I get

Not Found
The requested URL /FS/get/downloads:///News/2018-09-06.Al Jazeera English.How US sanctions on Iran will harm Iraqs economy.html was not found on this server.

Even though the downloads are there. Is there a pointer I am missing somewhere?



ok, so answers:

  1. Yes, the audio indicator LED is currently non functional. I am still working on it, but did not want to hold the release for it. Ditto for audio frames report in Tuner app. Those functions should find their way into the next release.

  2. Amount of downloads: Our wire-speed is 20kbps which amounts to over 6GB per month. In reality, about half of the wire-speed is being used up by the audio stream, which brings us down to ~3GB per month. Now, this is compressed data transfer, and a lot of the stuff we transmit compresses really well, like 25% of original size or even better. On the other hand, the files are repeatedly broadcast many times before they cycle out. Additionally, the weather gribs get locally expanded/converted into json files which are MUCH larger than the gribs. Given all this, actual monthly net data-written-to-disk is tough to estimate, but a few GBs a month is totally possible. The primary SD card has a maintenance script that runs hourly to clean out old files (messages, weather, news), which ensures that the primary SD won’t get full anytime soon.

  3. Backups to second SD: by popular demand, the backup to second SD happen before the cleaner bot removes the old files from primary SD. So the second SD backups saves all files. over a GB of accumulated files per month is thus totally realistic on the second SD.

  4. Failure to mount second SD: the second SD is checked for integrity when its inserted. On larger SD cards, SD cards that are close to full, or SD cards that have been heavily used and are closer to failing, this can take a long while. If this while is long enough, it triggers a watchdog which kills the integrity check (as @ac8dg noticed). Given RACHEL seems to be a popular use case, what I can do is exclude the integrity check from the watchdog. This will prevent failure to mount the second SD when theres a lot of data to check.

  5. If the SD card activity indicator is blinking, its a bad idea to unplug the second SD card - theres a very high chance of corrupting it in that scenario. Just wait until the activity indicator stops blinking. It may take a while.

  6. After the integrity check completes (successfully), a file backup process is launched immediately. This means on inserting the second SD card, there will be a delay while its checked for integrity, and if it passes, it will be mounted and then immediately files will be back-ed up to it. So expect a a LOT of sdcard activity, after insertion, both before and after it shows up as mounted.


Can you please share a screen shot showing this error?

Does the error persist if you reboot the receiver and then re-login?


Abhishek, I have revised the User Guide for the Dreamcatcher 3.03 with Skylark 5.3 with current instructions based on what we all have done. Are you going to be revising Skylark soon, and want to wait posting it on the WIKI? Ken



No, please share - I can post it now, and then update it as and when the next release drops.