Skylark 5.3 for Dreamcatcher 3


If I adjust the audio level with alsamixer, do I have to save the new setting using the command sudo alsactl store ?


I don’t know about saving the settings. When I did it, all worked well, but not saving the new settings required me to redo them if I rebooted Skylark.

Maybe @Abhishek can say for sure. I’m thinking one can’t make a permanent change to the Skylark program with SSH. Ken


@Abhishek, regarding your planned revisions to Skylark. Is it possible to add an Audio Icon (along with the underlying code) to the App Screen? Then we would to be able to render the audio through a web browser rather than to have to connect a speaker to the Dreamcatcher? Ken


On a different tack but similar, I find Audacity works quite well to capture a days worth of audio from DC and save it to play back later.


How do you do that, Donde? Are you feeding the DC’s audio line output into a computer to make the recording? Ken


Ken. yes exactly. I have been using a Linux Mint for almost everything. email, search. I put Audacity on it sometime ago. I think it’s a super audio editing program. So, I run a stereo cable from Line Out of DC to Line In of Linux box. It has alsamixer, very similar to the DC. When you first save it’s in .aup format. This is where you edit if you want to. Always keep this save. Then export it to MP3. All editing and recording is digital. Analog when hear from speakers.


Hi - - I tried the command but don’t have the context correct. Can you check it please and maybe show it on the SSH screen. Thanks, Ken


Volume adjustment, audio-over-wifi, mute/unmute - all of that is coming in the next release. I would just advise to wait till then.


Using Skylark on a phone browser:

Looking for ideas on which browser is good for accessing the skylark interface from my android phone.
I currently run firefox and it is definitely not optimized for clicking into icons or apps in the
skylark. In particular I’m looking for one that easily does the two finger zoom to make stuff more readable.


I use the DuckDuckGo Privacy Browser, and it seems to work well, Jim. Try it and compare. Ken


My Remote Access program will handle this very well. The only thing I’ll have a problem with is getting it to pull the micro SD card out of the Dreamcatcher and re burn it :heart_eyes:

Maybe there is a way to do a re burn via the SSH Program? Ken


OK Ken,


Work good for me.


Thanks Don - - I’m going to try it. Ken


I tried it, Don, and no luck.

When I changed the volume from the default up 90 and did the sudo alsactl store command and did a sudo reboot, my Dreamcatcher reverted to the original low setting of 40 when I came back into it. The sudo alsactl store command worked fine, but apparently did not permanently change anything in my gear. Ken


You are correct. The fact the command alsactl store completed with no error, I figured the editing of alsamixer Power Amp adjustment and the command would stick. But, as you say, it did not after reboot. Maybe the Team will fix this down the road.


After reading several Linux sites, the general consensus of the “experts” is that in order to restart and maintain the last set of instructions you gave using [alsactl store] in an “automatic” way would be to edit /etc/rc.local and add the line [alsactl restore]. The brackets are mine, don’t use them in the commands. I have not tried this, just adding a comment here. Jerry


You are probably right, however the version of Linux in Skylark does not have a file rc.local in /etc. In fact no where I can find.


There are also more complex methods involving writing start-up scripts, however, as @Syed advises, it is probably wiser to just wait for the next revision of Skylark.


You’re also right. I guess we should not complain, just wait. Hopefully, some of our wants will be granted.


I am running 5.3 and shifted to a couple of different power supplies. This caused the audio to start the stuttering like I heard on skylark 5.2.

I shifted back to my original power supply and it seemed to clear the audio. While this is not the scientific method… it is repeatable. Since I have to keep the little switching power supplies close to the dreamcatcher to prevent a large voltage loss… Several ideas…

  1. Since the power supply is generating RF, that could be the problem. A shielded case could solve this…

  2. Has anyone else noticed the stuttering with relative proximity of the power source

  3. I could be introducing problems with the cables I use… the power have awful small conductors.

  4. The DC boots fine, the display seems OK. leds all OK… no other power quality parameters are readily apparent.

  5. I did not change any of speaker output cables… so the stuttering seems to from the DC.

  6. I checked receive SNR and it bounces between -1.5 and -5.5