Skylark 5.4 for Dreamcatcher 3


just FYI. the update is going out over the air at this moment. If you have already updated to 5.4 (using any of the methods), the update will do nothing. if you are still running 5.3, you should get updated to 5.4 within the next day or so.

If you want to try it out, you may try burning a 5.3 card if you have the older image (not recommended though, just for fun!)


Can’t seem to do OTA for Skylark 5.4
I’m at this point.

select the update file you downloaded to your computer in step “a”. Click Ok/Open etc (as per your OS) to begin the upload.

And then:
Could not find any Applications with support for ‘application/octet-stream’ files

Failed to get file information for: downloads:///opaks/

Tried several times. Using Linux Mint 17.2 box. Same computer using for years. If I go to Archives download 5.4, and burn and install like new, should be OK?


Your computer should have handled it just like any other linux zipped file. Mine opened it in Firefox. Have you watched this weekend for the OTA update that is being sent out? It should load and update your DreamCatcher automatically.


That is what I followed, the #2 method. At step e it says
‘select the update file you downloaded to your computer in step “a”. Click Ok/Open etc (as per your OS) to begin the upload.’
I see the file where it’s supposed to be, but no OK or Open to begin the upload. Double clicking on the file brings up the error I mentioned in the previous post.


thats a skylark error - you seem to have already uploaded the file to skylark and are possibly double-clicking it in the skylark file manager. That is not needed.

Once the file is uploaded to the opaks folder in skylark file manager, you are on step “g”.

In any case, the update file is now being sent over-the-air. So if your update has still not happened, you just need to wait for the update file to finish downloading on your receiver, and the update will happen automatically. Just ensure you are receiving normally.

Are you sure you are still on 5.3 though? Given that you uploaded the file to the opaks folder, update to 5.4 would have already happened.

Thats always OK. If the update (either manual, or over-the-air) doesn’t work, or fails for whatever reason, you can always burn the full image file from Archive on the same sdcard (don’t try to format/partition the sd card) and it will work fine.


Abhishek, You are correct. I guess I’m on 5.4 from bottom right corner. And from About Skylark and Othernet Satellite Radio and I hear it. Mighty Fine! It was sure strange I got no indication of anything happening when the update was going on. And I didn’t have to click on the file which gave me the erroneous error. All I had to do was wait. In fact I probably shut down the computer and figured the update didn’t work.
Thank You Sir

New Question
Audio streaming only pertains to the local network I am on. True?


normally yes. Like the main skylark interface itself, you can only access it on your LAN. But some people have setup VPNs into their LAN for access when away from home (i believe @kenbarbi has a setup like that), and others have setup port forwarding on their router to allow external access. Audio works on a different port (normal skylark works on the default http port, 80 - while audio streams in port 8090). So a second port would need to be forwarded. Any decent router should have this capability.


Yes - - now, with Skylark 5.4’s native audio capability, I use a quirky method which works pretty well. (it’s a little scatchy). It is TeamViewer ( which is really a password-protected remote access capability that I have used for years to operate my Dreamcatcher remotely. It is installed on all my computers, and I leave it running when away from home. It is free for non-commercial use, and gives me full remote control (screen views, keyboard and mouse control) of all programs from a distant computer.

I have the audio output (earphone jack) plugged into the mic jack (on my home computer) to loop back the audio in Teamviewer so I can hear Othernet Satellite Radio thru my remote connection when I’m in the TeamViwer VOIP Chat mode. Ken

PS - - Now, I would sure like to port forward my Dreamcatcher, but my VPN Provider has been unable to figure out how to authorize me to do that.


This is an odd bug. If I start a web session logged in as ‘othernet’. then start a session logged in as guest concurrently.

The ‘othernet’ login loses it’s admin rights. for example it can not change tuner settings.


I’m the one who wants to show electronic gadgets to others, maybe to get them interested. Also expanding Othernet into the public Network can open up new problems. Thanks for saying it can be done. Ken just mentioned in his post using Team Viewer, which I’ve used a number of times, as a free method. Another subject: How about the login be changed to check a box for name Othernet to be remembered?


If the sessions are being opened in the same browser, then yes - thats as intended. A session cookie is stored when you login and it gets overwritten when you do the second login as guest - from then on you will operate with guest privileges only.


Thats non-trivial and not on the dev roadmap. I also strongly urge you to change the “othernet” user password to something secure and to NOT share that password publicly if you plan on allowing access to the receiver from outside. Guest user is intended exactly for this kinda use. Is there a specific reason you’d want general users to be able to login as “othernet”?

The othernet user is root, and can login to the system - which means you’d be allowing people access right into your LAN. Most stuff that lives on your LAN isn’t designed to be safe against such internal intrusions.


No, my intention is only to demo with myself being present. I will not show or tell any of the details to ‘outsiders’. I believe you have made yourself very clear in these the last posts. No problem. And I will drop the subject. Onward!



public demos, even sharing access is perfectly fine! Thats exactly why the “guest” user was implemented - including the prefilled username/password. “guest” can use the receiver/skylark fully, but in a read-only capacity. They cannot change settings and cannot login to the shell prompt, cannot upload files, or delete them. So please don’t let me discourage you from any of your efforts. (Note that when guest opens the Tuner app, theres a security message that gets displayed saying “guest isn’t allowed to use this app”. Despite that, “guest” can actually view the tuner stats. They just cannot configure the tuner/beam.)

The advice is only meant to prevent security breaches - I’d just hate for someone malicious to get into your LAN and do harm.


Thanks again,

The default password has been changed ! :sunglasses:


I am still have the ‘what’s new’ issues with a new sd card. even after the app screen populates, the rotating cross/circles are still present.


@Abhishek: Interesting to note that my unit has fallen off the “Othernet Status Dashboard” this morning, yet the unit is functioning perfectly from all appearances here. Apparent telemetry fail from Skylark?


I too have had 3 failures in the last 2 days. Each time the Dreamcatcher strops receiving but shows a few signs of life, but is not warm to the touch as it should be when operating properly. A reboot restores the DC to operation. Ken


Just a brief update on remote access.

Although I can’t port forward thru my VPN, with my VPN turned off, port forwarding Skylark works fine. As a result of adding the audio, one also needs to additionally forward port 8090 (the audio stream) as shown here on my Asus AC-68U router. Ken - -


I just noticed that I also have missed downloads recently. Re-booted at 1231 EST, and am now seeing what Jim @ac8dg reported, all busy wheels, no data. SNR is up to -11 from -7, RSSI -80, appears to be “hung”. Rebooted again at 1240 EST, unit appears to be receiving properly, same SNR and RSSI, but now audio sounds as though receiving two streams off-sync with each other. News files still at 11-04-2018, weather at 11-02-2018, may not have had time today to catch the new feeds. This report at 1250 EST 11-07-2018. Jerry