Skylark 5.4 for Dreamcatcher 3


Is the carousel not receiving new content since 11-30-2018? I have all indications that I am receiving content, however, News and weather and aprs have not advanced past 11-30. Audio is old-time radio.


I’m OK on all up to 3 Dec - - your Dreamcatcher is constipated - - suggest a reboot. Ken


Thanks, Ken. Never saw this situation before. The DC looked good, had 5 days uptime. Re-booted at about 5:00 EST and it took it about an hour to start showing/serving 11-3 content.


yep im having a new issue with the dreamcatcher just total locking up is there a way to look for the log files so i could possible debug the reason?


look in the dreamcatcher via skylark at the “log viewer” app


Please post an idea’s you come up to solve the ‘locking up’. I have had my DC stop four time in past week. Requiring a total shutdown / reboot.


Currently, several of us are experiencing this. Abhishek is looking into the possible causes, as there does not seem to be a consistency in what is happening. I changed my power supplies twice and currently have a power monitoring device attached, but not seeing any reasons from the power supply itself. Mine is now requiring a re-boot each morning to start the downloads over. The lockups have stopped, but this new symptom is now displaying, where the new day’s files don’t automatically download.


just rebooted mine again no logs to show that it got hung up or anything which makes me puzzled why it hangs up one day it did it twice in a day


All these strange things going on. Receivers locking up, file dates not moving forward…
Watching the DC receive many packets in one day. How many packets are sent from the carousel in a 24-hour period, including audio? If we are receiving 100% valid packets with a 0 PER as the DC reports, and the packet count continues to increase (as indicated in “Tuner”), why do I have to reboot in order to see the current day’s dated files. It is obvious that the files are received, or the count would not continue to rise all the time at a regular rate for the full 24 hours of each day. Have the DreamCatchers been sent unannounced OTA changes in the software? Either the count of packets received and valid packets as registered in “Tuner” is bogus, as in a counted clock tick, or something has been changed in the software. These numbers used to be reliable. Credibility is slipping. We are looking for 1 + 1 here, these figures are not adding up, and the stability of the DreamCatcher receiver from day to day no longer exists.


I think that the interleave between the formats is unstable:
Tuner-Status-Stream- ‘audio’ and
Tuner-Status-Stream- ‘files’

Probably has decreased reliability (I don’t have hard statistics). But ‘my opinion’ is
that getting only a couple of wiki articles and couple of very small aprs messages, two weather
updates, and two or three news packs has degraded the usefulness of DC.

Is the audio stream really what any user wants ?


So, is my DreamCatcher broken, or is the software broken? I have followed all your advice, however, these strange happenings persist in spite of all the tests. ???


As mentioned before, I am also having shut downs - - loss of network connectivity, loss of Bias T drive, and outright death.

I just completed a test turning up the amplitude of the Dreamcatcher audio output amplifier with the Alsamixer command from PuTTY. My first test ran well at the default level of -24 dB. Also I had no problem when I ran at -4dB. But when I turned it up to 0 dB, my board got hot and died. After cooling off, a reboot brought back service.

I wonder if other’s of you having shut down problems are running the Dreamcatcher audio output at high levels? Ken


I agree with Jim - - on the value of the current Othernet Satellite Radio broadcasts. But keeping this all in perspective, Othernet wants to incorporate an audio channel and test it out. This is what they are doing right now.

If, as Jim suggests, it is causing problems - - let’s get it fixed before we move on. Ken


i wonder if we can turn like alxa mixer down to min so it stops overheating the component that is causing the hang up since a lot of us now listen to the audio via the web interface. If that stops the freezing or doesn’t then eather way we can rule out that issue is what is or not causing the freeze up of the dreamcather


I have never turned up the ALSA on my DC, but still have the freeze-up and lockup problems. And I have not experienced any overheats since I moved my DC indoors back in June.


Right now, Tyler, my Alsamixer is at the default level, and my system is OK. That’s not to say it might fail for some other reason. But I have at least eliminated a potential problem area that I have seen to cause a issue.

That said, let’s see what others have to say on this matter. Ken


Sometimes after a ‘lockup/restart’ the Log Viewer-System Messages has data from before the crash, Sometimes it has cleared the log and all that is available is the current boot record.

It is tough to find the ‘cause/effect’ until the reason for the failure is confirmed: Here is some of the things I have tried:
-New SD card — still locks up
-different antenna/feed – still locks up
-different power sources – still locks up

My next idea is to put it in access point mode instead of wifi client.

edit: on hotspot host mode… everything looks OK. except
lot’s of system messages due to not being on internet and obviously can’t see
the telemetry
Dec 6 15:02:58 othernet user.notice root: UNCAUGHT EXCEPTION { Error: getaddrinfo EAI_AGAIN
Dec 6 15:02:58 othernet user.notice root: at Object.exports._errnoException (util.js:1036:11)
Dec 6 15:02:58 othernet user.notice root: at errnoException (dns.js:33:15)
Dec 6 15:02:58 othernet user.notice root: at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:76:26)
Dec 6 15:02:58 othernet user.notice root: code: ‘EAI_AGAIN’,
Dec 6 15:02:58 othernet user.notice root: errno: ‘EAI_AGAIN’,
Dec 6 15:02:58 othernet user.notice root: syscall: ‘getaddrinfo’,
Dec 6 15:02:58 othernet user.notice root: hostname: ‘’,
Dec 6 15:02:58 othernet user.notice root: host: ‘’,
Dec 6 15:02:58 othernet user.notice root: port: 443 } Error: getaddrinfo EAI_AGAIN
Dec 6 15:02:58 othernet user.notice root: at Object.exports._errnoException (util.js:1036:11)
Dec 6 15:02:58 othernet user.notice root: at errnoException (dns.js:33:15)
Dec 6 15:02:58 othernet user.notice root: at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:76:26)


I wanted to make sure everyone knew that we are well aware of the issue and are working to resolve it.


Thank you for the reply. There are at least 17 of us who are waiting for our Dream Catchers to operate in the manner which they did before all the radical changes. We have done all that we can do out on this end, including new SD cards, new power supplies, extensive re-booting and much wifi trouble, to get to this point. Jerry


Could we get a update to Skylark to make it save the log files to the fat32 section of the SD card so we have logs and more info to speed up the process of ending this issue of radomly freezing.