Skylark 5.5 for Dreamcatcher 3


Jim, you can do it without SSH, simply using the NETWORK app in Skylark. No hacking required.


tried to add a new user… to skylark, did not support that function

[Skylark][[email protected]:/etc]$ cat /proc/version
Linux version 4.10.6 ([email protected]) (gcc version 6.1.0 (Buildroot 2016.02-git) ) #1 SMP 2018-01-0

[Skylark][[email protected]:/etc]$ sudo useradd demo
sudo: useradd: command not found


Here are some pictures - -

Here’s where you go - - image

Type in the new Othernet password - - image

Then click Apply and Reboot and your admin password will change to the new one. Ken


adding a new userid means mounting the filesystem on a different system, then either editing /etc/passwd or making it a link into /mnt/conf/etc and putting passwd there. then log in and use passwd … in other words, you get to experience the joy of the once upon a time before there was a useradd.


Lessons learned: I tried to change the client (STA mode) wifi network for my dreamcatcher.

-If I changed the Access Point Name, and Password in Network tab (Wifi Client)
and pressed “Apply and Reboot”. It would NOT connect.

numerous reboots, shutdowns, etc would not get it to connect… something was still ‘cached or stored’

Solution: If I use the the LCD menu “Reset Configuration (reboot)” , then log into the
then change the network to client, re-entering the Access Point, password, and rebooting. The
dreamcatcher WILL connect.


I have seen this same problem before recently when I went back to a Dreamcatcher 3.02Q board (after my DC 3.03 burned up), and did exactly what you did.

As an aside, I also rebooted my Wifi but I can’t confirm if the Wifi reboot or the connect was the cure. Ken


I took the 3.02Q down this morning and extended the WiFi dongle about 14 inches away from the DC. The Tuner session has run all day today without needing a new login. It normally will only run about two hours and then stop blinking. All other functions seem to not be affected. On the first boot after moving the dongle, it acted goofy as you described above, but on the second, it picked up the lan and no further manipulations were required.