Skylark 5.6 for Dreamcatcher 3

I am using an EasyAcc 20000 mAh power bank to drive my DC v3.05. The EasyAcc is powered from an ICleaver Dual 2.4 amp charger with 2 short high quality cables. Ken


I upgraded to Skylark 5.6 a few days ago on my old 3.02 Dreamcatcher. I discovered the old 5.5 SD card was no longer writable, which would explain no new files for several days. I had to copy the 5.6 image to a new card and start over. There have been no crashes. The diagnostics log currently shows “up 5 days, 21:19.” I do not use an additional SD card for storage.

My Amazon Chinese power supply is a " Yuconn Micro USB with On/Off Switch Main Wall Charger AC Adapter Power Supply 5V 3A for Raspberry Pi 3 Model B B+ & Bose SoundLink Color Mini 2 II (1 x Power Supply) by CheTech.

Thursday, 10-10-2019
Another crash of 5.6 on the 3.02Q last night.

my DC 3.03 also crashed again, but only after 7 or 8 Days so not to bad.

Power Cycle did fix it.

I am trying various sd-card settings since it seems that “update” the boot sector may
be the cause of freeze.

My latest experiment is to (using minitool-partition-wizard)

  1. “wipe” a sd-card by writing zero’s into every memory location
  2. remove any existing partition (make it all un-allocated)
  3. the create a new single paritition that my win32diskmanager will recongize

This time I made the sd-card a single exFAT before writing the skylark image.

If that doesn’t work… I have other options for partitions (ntfs, FAT, FAT12, FAT32, Ext2, Ext3, Ext4, Linux swap)

@Tysonpower We’ve had releases that have run for months–almost a year. A change of office was the only reason the receiver shut down. So being up for only 7 days is a real problem. We are definitely experiencing the problem on our end, as well. There has been a fix that we tested internally, but the problem was not solved.

Apologies for this inconvenience.


This is Linux, can we SSH in and use normal CLI?
What kind of device is the sat feed/lora showing up as, some ttys writing to a file which is scanned and executed by a series of py scripts?

My upgrade to 5.6 failed. In trying to start over fresh the checksums for the 5.6 download don’t match ( nor the one for 5.5 either). While trying to flash the SD card with Etcher anyway, I get a failure due to corrupted file error message.

Please explain.

Maybe verify the SHA 1 checksum of the zip file after you have extracted it from the *.gz ?

10-15-2019 my 3.02Q running Skylark 5.6 crashed last night.

I will be away for a few days, so if it crashes between today and Saturday, there will be no backfeed.

One more “hint” of problems/solutions … both my dreamcatchers froze last night after
3 days of uptime.
last file
Oct 16 09:34:04 othernet2 ondd[496]: [carousel] completed: opaks/ae77-messages-2019-10-16_09_31.txt.tbz2

One had this message upon second reboot

Jan 1 00:00:43 othernet1 user.warn ondd[510]: [carousel] invalid signing certificate

and it had some problem with the system messages in log viewer… the entires were all
several days old… and on re-boot did not show the restart from Jan 1 until a second reboot

Note-- it’s assigned wifi hostname is othernet1

My Dreamcatcher v3.05 crashed at 0531 (around the same time as Jim’s) this morning after being up for 4 hours since its daily programed shut down/reboot. Ken

I’m surprised after reading about all the crashes. But my old Dreamcatcher 3.02 log is showing “Wed Oct 16 13:34:15 UTC 2019 up 12 days, 28 min, load average: 0.98, 1.15, 1.26.” As I stated earlier, this was a fresh install on a new SD card. My old card had failed.

Here is another clue on the freezing v 5.6

Looking at the “what’s new”. There are entries that are NOT being cleared from What’s New.

There is a weeks worth of news, messages, weather at the top of the listing , but some entries are real old… mostly the wikipedia articles are staying on list forever (not cleaned up weekly)

For example today is 18 October 2019… but here is bottom of the what’s new

My 3.02Q running Skylark v5.6 crashed last night again.


10/21/2019 2300 UTC
I have replaced the DreamCatcher 3.02Q in my permanent installation with a v3.05 running Skylark 5.6. It is available for public view at admin = othernet/j7m*2


10-23-2019 First crash of the 3.05 running Skylark 5.6 occurred around 0430 MDT this morning.

This is a very interesting post - - my DC v3.05 running SK 5.6 crashed about the same time this morning here too. It’s back up now, but is there something being transmitted causing a problem?? Ken

1 Like

Unfortunately, my DC v3.05 is experiencing the same problem as Willi @Zebra

Skylark 5.6 or 5.5 won’t work and I have exhausted all my alternatives. I am going back to the DC v3.03 running SK 5.5. Ken

My 3.03 running Skylark 5.6 crashed multiple times. I even wiped the card using SD Card Formatter. The touchscreen worked for a few hours and then stopped. Then the entire thing locked up at random.

I rewiped the card and went back to 5.5. So far, I now have 2 days of uptime. That’s with a 4GB OS Card (Kingston) and a 200GB DATA Card (PNY) (formatted with “ext4 -O ^has_journal”).