Skylark 5.7 for Dreamcatcher 3

I used ballenaEtcher to write the image after using Rufus. The boot LED remained on all night so reflashed with Etcher. After 15 minutes the boot LED is still on. How long should a normal boot take? And how long for a factor reset?


both, regular boot and a factory reset (which is also just a reboot) take less than a minute.

When you say “Boot LED” which one do you mean?

As far as I can tell, I don’t think your board is booting at all. Have you gone thru the user manual ? It explains what each LED does and how it behaves during boot and after boot.

What does your Heartbeat LED look like (Its called HBEAT on the board). It should a a regular blinking “heartbeat” like pattern once the board is booted.

Do you see the LED on the wifi USB dongle light up at any time?

LED1 and a bunch of other LEDs remain lit during early boot (few 10s of seconds) but then switch off (LED1) or switch to their standard patterns (see user manual for description of each). If it is remaining lit for longer than a minute or so, the board is not booting.

You may want to try a completely new SD card. Using Rufus is not needed - it doesn’t help except in some very specific cases. Just write a new sdcard with the image (please share a screenshot of etcher taken while its writing the image), and try booting from it.

Also, its possible the sdcard is ok, but you have a bad power source. But I can’t tell that without more details of how the LEDs behave.

(Also, just to be sure, please download the image again)

Edit: Just noticed you said a 3 foot usb cable. While thats not unreasonable, could you - just for testing - replace that with a short cable? Rpi has a larger tolerance for low voltage from the usb cable (it just throttles itself). Dreamcatcher browns out when theres low voltage - and the main cause of DC not working normally is bad power.

Perhaps this has been asked in the past, but again may be useful. Is there a reason the Othernet folks persist in using micro-usb for the power connector? It is much easier to build a good power source cable from commonly available wire with a coaxial plug, instead of having to purchase expensive USB cables that may or may not work because of the limited current-carrying ability of the tiny wires inside. Is it only because the USB cables are commonly available, or is there another (engineering) issue involved?

Thanks for the info. Yes, I’ve been using the manual. I’m referring to LED 1 when booting.
The power LED is lit, and the heart beat LED is flashing… Tried another re-flash, this time with Win32DiskImager but the results are the same. When I tried a “verify only” after flashing it failed at sector 16384, so I wonder if I might have a bad SD card What are some known good brands of micro SD cards? I’m using a Kingston brand. And I’ll see if I can find a shorter cable in town as the 3 footer is as short as I have.

Ken, something some of us have experienced in buying these cables is the nomenclature. It seems that the heavier (desirable) cables are labeled “charging and sync” cables. DeWalt, FuseBox, and several others make “armored” or shielded cables that seem to be heavier than the less expensive ones.

re sd card:

This is the one I use, and its worked well for me - even though I sometimes burn a dozen test images in a day.

Its primarily because of the availability issue: even non-technical folks either have a microusb charger already laying around, or know where to get one. Most non-technical people won’t know where to even start looking for a barrel-plug power unit.

What about the LED inside the wifi usb dongle? Any activity there?


Is it possible, then, for Othernet to provide a listing of available tested (reliable) cables (brand names and catalog numbers) that work, and the sources where these may be purchased, so that perhaps we can list that in the User’s Manual?

And referencing your reply “Most non-technical people won’t know where to even start looking for a barrel-plug power unit.”, I agree, and can sympathize 100 percent. I am a technical person, and I haven’t the foggiest idea where to find a good heavy-duty USB cable! I would add that my first success was using a RaspberryPi power supply, which has a heavy cable.

I was just typing that myself. The official Rpi power supply is probably the easiest to find guaranteed-working power unit out there. Maybe we can mention that in the user manual, @kenbarbi? Also - while I don’t have a list of working cables and adapters, its a good idea - if people can chime in with their known-good brands and links, maybe they can be added to the wiki and/or the use manual.

1 Like

Success!! I used the 64 Gb micro SD card. It verified successfully after flashing with Win32DiskIImager. I’m able to logon fine, so will now continue with the settings. The original 16 Gb card is in the trash bin!

I’m using an Anker USB cable.


Now receiving packets from SES-2 and will let it run for the day while I’m away from home. Still need to do the network configuration but will do that tonight.
Thanks for everyone’s help.

Looking for documents on settings for Astra 3B in tuner app.
I have switched my dreamcatcher v3.03 to

  • Europe
  • Active Antenna(tried passive)
  • Maverick 1
  • no change to custom
    Anything else?
    I have my 70cm dish(lowest level signal per map Dead Sea area) aimed but have nothing in status, no signal in the DC’s signal graph.
    here is relevant cut/paste from terminal
    I have a 15m run of RG-6 cable to a rooftop dish when I have use of it.

For Europe, you should be using the “Othernet Dual Band” setting with the universal LNB. Be sure to click the “apply” button when changing this.

1 Like

OK, will have to wait for that LNB to arrive, I currently have the Maverick.

How long did you have your unit running ? It appears you may have received some data. However, dated Jan 1 usually refers to startup events until actual streaming is achieved. With a 70cm dish, the pointing could be very critical, and I would encourage you to keep trying. You may not get best performance with the Maverick 1 on the Europe bird.
Incidentally, you can paste screenshots and quotes directly to this forum.

1 Like

where do you see me with rx packets?
I start it up and leave it running when I can has been up for maybe 10hrs.
(edit)thanks maxboysdad, in looking now!

I was just noticing in your uploaded page that there were recent packets showing in your diagnostic screen.
It is noted that they say “from file service”, so likely were not received, but from the boot up.

You may look at mine at, login as othernet with pw of j7m*2

1 Like

This release, Skylark 5.7 is the most stable yet. Up for 12 days! On both a Dreamcatcher v3.03 and a Dreamcatcher v3.05. Ken

While I have a copy of the PDF for HW v3.03 it might be nice for others to have an archive folder on the FTP for older hardware revs.
Will you offer a plug-in touch screen in the future as an accessory?
Is that even an option, it looks like there is where to add the risers on the 3.05 PCB.