Skylark Release 4.4


Thank you for finally fixing this :slight_smile:


Received DC + active antenna + Skylark 4.4 on 4GB uSD.
Powered with solid power system (12V-14Ah battery - USB power converter - good USB-to-microUSB cable), all good so far…
Booted, pretty flashing lights, WiFi up, logged in as Outernet, config’d Tuner for APAC (I’m in Melbourne, 38S 145E) pointed ant to sat in clear view…
never locks, SNR bouncing between 1 and 2dB regardless where it’s pointing, in fact I get same result if I disconnect the ant all together, RSSI stuck on -132.88…
oh, yes ant connected to SMA closer to LEDs, as per instructions stuck on the box (now me think, possible something wrong with the software switching of the two SMA connectors or even got wrong image?)

Any suggestions, please?

TIA, Luigi M

  1. Solar panels and Power packs interfere with the signal. Please ensure they are a fair distance away (a few feet) from the receiver, the coax cable and especially the antenna. Also keep some distance (a feet or two) between the Antenna and the receiver.

  2. Make sure you have the right image for the antenna. Active antenna requires this image:


thanx Ahishek,

2- I’ve checked the contents of the SD shipped with the kit, 5 files on it: boot.scr, freshburn, skylark-dc-1706222246, sun5i-a13-dreamcatcher.dtb and image… all good, right? But, I will try to re-burn the image on a diff SD card…

1- yes, I am aware of noisy power sources, the problem is happening with the D.C. powered from the laptop USB as well as the 12V battery + USB/5V converter (ran all night and used 6.7Ah over 10 hours, getting barely warm - few degrees above ambient temp.)
10in coax shipped in the kit. I will try to source a longer one this weekend BUT, as I said, the symptom doesnt change with or w/out antenna attached… I will also try to measure whether the 4.8V bias is present on the LNA-BYPASS SMA.

My gut feel right now is either DOA antenna or broken RF stage(s) on D.C. Any further troubleshooting hints, please?




done a bit more… checked bias voltage on LNA-BYPASS SMA, yes 4.8V comes up during boot sequence.
Onboard LEDs:
2 FLOCK ON flashing @ 10Hz
3, 4, 5, 6 SNR1-4 ALL OFF
8 USR2 ON flashing @ 2Hz
11 AGP3 ON

Question: what are are these things for…?

  • LIPO-BATT holes (round and square) external battery…? single 3.7V? 2Serial 7.4V?
  • JP1 holes (round and square) next to USB-OTG…?
  • CHG-IN pins…? Another power connection option…? 5Volt?
  • SW-FACTORY switch.?

Given that the DC is meant to be “for tinkerers, etc” would it be possible to have the circuit diagram…?



I second the request for the schematic… :slight_smile:


done more tests. Burned another SD (remember, the first SD came with the kit) with the same image (LNA-BYPASS ANT), freshly downloaded, and the symptoms are the same, no change whatsoever…

I also notice something else in TUNER, with both/either SD’s, the FREQ OFFSET is continuously varying by +/- a few Hz, occasionally though, it will jump to + or - 1000, 1500, 1700Hz and more for a few seconds and, when this happens, the LOCK STATE goes from SEARCH to SIGNAL DETECT, again with or without antenna connected…

I’ve also been able to connect via UART1 to PuTTY on another laptop and had a look around while booting. Mind you, I’m not a Linux person and I couldn’t do much with it but at least I could follow suggestions based on linux access.

I can’t see how I’m doing anything wrong to cause these symptoms hence, I’m more and more convinced it is a problem with the antenna.

Now, if there is anyone in Melb/VIC/OZ with this kit willing to test my antenna, please let me know.




done one more test…
found an old GPS passive patch antenna thinghie with 1m long cable and SMA connector…
flashed yet another SD with the Passive Ant image and booted SkyLark w/o issues…
connected the GPS ant to the top SMA socket and started watching Tuner…
SNR was jumping around Minus 0.3-1.8dB and Plus 0.5-1.7dB with no signal lock
RSSI no longer “stuck” on -132.88dB (like before with the Active Ant setup), but now bouncing around Minus 110-115dB, that must mean something good, right?
When I put it all back to Active Ant mode,all was back as before but I’ve also noticed that the LNA metal can at the back of the Patch, feels very cool (dead cold) unlike the LNA on the DC board, could this be another indication of DOA antenna?
Anyone with opinions/ideas before I put in a request for replacement?


luigi m


last weekend I got a GPS active antenna, removed the 1575 filter, bridged the filter empty spot and connected the 80cm cable to the DC’s LNA_BYPASS port, and as per usual, run the ACTIVE 4.4 image…

exact same results as with the proper active antenna.

The RSSI was still at -132.88dBm and never-ever moving from there (is’t this an indication of NO/ANY signal EVER reaching the RT820 circuitry…?).

This behaviour now seems to point to the DC board itself, maybe the antenna changeover switch (would that be U11? or U23? Oh boy, how nice it would be to have a circuit/block diagram!!!) is not switching.
Remember, as mentioned before, the antenna does receive the 4.8V from the DC board, measured that several times…




Well, tried few more things and made some progress after replacing the coax cable to the Active Antenna with a longer one, about 80cm, and moving the DC board that distance away from the antenna.
Finally getting packets at 2.5-3.5dBm and RSSI=119-121 (before had always been down to 132.88) and 97% valid packets…
Next I will take it all outside and see if things improve.
BTW, do you still have Passive Antennas for sale? Would like to experiment with that as well




Yes, we do still have passive antennas. Quote a few, actually. I’ll post them on the website over the weekend.

So the Dreamcatcher works, but the active antenna does not. We can definitely replace it if that is the case. Would you be able to show a screenshot of SDR# tuned to the APAC frequency? I’m assuming you have a separate rtlsdr dongle?


Syed, thnx for getting back… I’m winning at the moment, 5.5-6.5dBm -119-ish RSSI…
I mis-blamed the Act Ant when all my problems are probably due to my location i.e. apartment block with all sorts of PCs, smart phones, smart TVs smart everithing-bloody-else generating God-knows what kind of RF-crap all over the spectrum…
I’ve set up my DC + Act Ant in a diff room with a better and unobstructed view of THAT point in space, and today is a beautiful sunny day as well (past week, clouds and rain and 2.5-3.5dBm readings).
I don’t have an SDR# setup yet nor modern components but working towards it though.
thanx & regards


while waiting for the beam to come back, I’ve been playing with Skylark and a bit of Armbian to get more familiar with their features.
One thing, amongst many, that got me curious is the “Custom” tab in Tuner and also at the bottom of the three satellites choice in the drop-down menu… clicking on the tab does nothing. Clicking “custom” in the menu, brings up a “pseudo” sat with no name, same frequency as 25E and a symbol rate of 8400… what is that all about? Is there anyway to dial different frequencies? Missing page from the manual.:wink:? future feature/option in 4.5?

BTW, received the two SDRx and passive antennas of my order, thank you Syed, and itching to figure out what to do with them… Anyone out there been playing with them on things not related to Outernet?



Its only a partially implemented feature for a manually specified satellite. Mostly, it provides a placeholder in the config file to allow a custom specification to be done manually.


Hi Abhishek,
thanx for your reply… it seems Syed is going to get us the new frequencies for 25E and 144E… in the meantime I’ve been doing a bit of poking around in the /etc config file and found where the sat frequencies are as well as the “custom” one… While waiting, I intend to play with the custom frequency to find a signal, any signal, so I can get some decent SNR values back for me to play with different antennas… Can you suggest some close by frequencies (for APAC) or where to look for them?


keep getting 404 not found?


Can you see Inmarsat 3F3? If so, try 1541.448. It’s a Safety Net signal which can be decoded. I have in past and other day tried it again. Very low in Elevation for me on West Coast US, but works fine using RTL-SDR, SDR#, and 10 turn Helix.


Thanx Don,
yes, 3F3 is the POR (Pac. Ocean Region) and sits at Long 178E… I’m in Melbourne at 145E, so it shouldn’t be a problem for me even with either active/passive Outernet antennas. Once I fully recover from the shock and sadness of having lost the use of one of my best toys, I’ll get back into it, soon, and start playing with EGC-SafetyNet decoders and SDR#, I did buy a couple of SDRx boards after all.
Happy to hear that you can actually pick up POR from the WestCoast, that’s brilliant!


Yes, for Safety Net, I’m shooting right over a freeway sound wall, toward the West at 15 degrees. About 100 meters from it. Outernet is much better, about 40 degrees elevation.

I’m temporarily turned off. Playing with 40 watt solar panel and batteries to use with Outernet. Probably fire it up again tomorrow. Sure hope Syed can give us all positive surprises soon. I think he needs big time backing to sustain his effort.
Have fun, Don


Actually, we are working on a way to provide a better/more useful service without needing any backing at all.