Adding content to ORxPi


#1

Hi branko. It seems that the LNB I dug out of the back of a cupboard is duff. Is there any way to download or copy the library to my ORx via the web? I really want to demo Outernet terminal and concept to a colleague, but its a bit flat without content. Cheers.


#2

We had an archive, but it’s too outdated. We’ll see about putting up a new one somewhere that gets updated from time to time.


#3

For a minimal demo you can choose some zip files here:
http://archive.outernet.is/
and navigate to your ORxPi system to /mnt/data/downloads/content directory, and use for example this command:
wget http://archive.outernet.is/003669cf61a1f17115b0bf74256114ea.zip
(maybe you need to use su or sudo -s command access to this spaces as root)
If you downloded some similar zip files, you will see them on librarian web page in the Updates manu. From here you can select and unzip/install as browseble contents through the Library menu.


#4

Great. That’s nice and easy.

So I could go get any zip i like out of the archive and put it in there.

That’s a good call tjanos!


#5

As I mentioned before, some of those zips are old, and no longer compatible with later versions of the UI (they get rejected and deleted). Some may still work, but I’m not sure how many nor whether they’re useful.


#6

Yes, it seems, the last file creation date is end of may in this archive.
JohnSpace, if you need some newer zip files for demo, I can send you by mail. You can access me on gmail, at hg5apz account.


#7

Thanks for the updates.
I am trying to load the zip files i saved from the archive, but im having trouble. My ORx is not connected to the internet, so I was going to drop the files in over the LAN with WinSCP, but there is no FTP client running on my ORx. Perhaps as you say branko, they might not work anyway, as they were both 2014 files.

Got a few options while i wait for a new LNB…

Cheers


#8

Please try this method and let me know how it goes.


#9

Thanks branko. Going to try that now. Quick question, are the zip files packaged content? And are they imported as content of files?

(Going off to try both ways…)

Cheers


#10

Tried with a zip file as both import_content and import_files. Appeared to be activity on the USB stick, but no apparent change in the GUI. Is there a particular file system the USB stick needs to be formatted to?

On edit:

Formatted my USB and copied the extracted pdf from the zip file to the import_files folder.

Plugged into my ORx and it notified me of an update. Clicked add file to library and its there, but only as a pdf.

How do I get the cover view to work? I assume this uses the other files that are zipped?

Is the zip file the packaged content?

(New LNB arriving tomorrow too)


#11

Content is a specially crafted zip file that contains metadata. These files appear in updates section. What we call ‘files’ are arbitrary files that appear in files section. They have no metadata associated with them, and therefore do not appear in Library.

As for troubleshooting import issues, these activities are logged in syslog with a label of ‘hotplug.scsi’.


#12

Thanks branko, that makes sense.

I will have another go at importing a zip through a USB stick with import_content folder tomorrow and report back.

It looks like a good supporting way to bring in content.


#13

Bringing in zip files through USB worked perfectly. I’m now going to download some more from the archive, to supplement what I get over the air!

Really like the UI. It’s simple yet effective.


#14

Just finished importing all 1500+ files from the archive.

Strangely 300+MB of zip files is only showing as 30MB of used library space. But hey ho.

Is this the “final” version of the Library interface?

Is there any intention to segment content into WIKI, news articles, etc?


#15

It is possible that some of the zip files were rejected due to invalid metadata.


#16

To follow up on your other two questions;

No this is not the “final” version of the Library interface; more like a sneak peak of what we’re aiming towards.

Yes, there is intention to separate content in a meaningful way; however what that way is hasn’t been decided yet.


split this topic #17

I moved 2 posts to a new topic: Writing ORxPi image to SD card


#18

@branko will they get rejected and deleted depending on the timestamp in info.json file?

for an example:

{"url": "http://en.wikipedia.org/wiki/Central_African_Republic", "title": "Central African Republic - Wikipedia, the free encyclopedia", "is_sponsored": false, "images": 20, "timestamp": "2014-08-10 19:42:46 UTC", "archive": "core", "keep_formatting": false, "domain": "en.wikipedia.org", "partner": null, "license": "GFDL"}

#19

Metadata is validated for correctness using outernet-metadata library (here). That Python package comes with a command line tool for verifying metadata as well, so you can extract the zipball and run the info.json file through it and see exactly why it got rejected.


#20

I am getting following output for metacheck --version. I have installed Python 2.7.10 and pip 7.1.2 on my Windows 7 machine.

E:\>cd outernet-metadata-master

E:\outernet-metadata-master>metacheck --version
Traceback (most recent call last):
  File "C:\Python27\Scripts\metacheck-script.py", line 9, in <module>
    load_entry_point('outernet-metadata==0.8.post1', 'console_scripts', 'metache
ck')()
  File "C:\Python27\lib\site-packages\pkg_resources\__init__.py", line 552, in l
oad_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "C:\Python27\lib\site-packages\pkg_resources\__init__.py", line 2672, in
load_entry_point
    return ep.load()
  File "C:\Python27\lib\site-packages\pkg_resources\__init__.py", line 2345, in
load
    return self.resolve()
  File "C:\Python27\lib\site-packages\pkg_resources\__init__.py", line 2351, in
resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "C:\Python27\lib\site-packages\outernet_metadata\validate.py", line 19, i
n <module>
    cn = conz.Console()
  File "C:\Python27\lib\site-packages\conz\console.py", line 57, in __init__
    self.register_signals()
  File "C:\Python27\lib\site-packages\conz\console.py", line 273, in register_si
gnals
    signal.signal(signal.SIGPIPE, self.onpipe)
AttributeError: 'module' object has no attribute 'SIGPIPE'