APRS Txt - HTML What is coming down

works here too instantly!

Are y’all checking the “Test Port” box?

Just got an e-mail back from the author of YAAC noting:

I hope you don’t have the Test Port checkbox checked on your setup, because that tells YAAC to ignore the entered IP address and port and go to findu.com instead. I did this because I don’t have an Outernet receiver and needed to test that YAAC would understand the file format.

If you’ve checked that box…and you’ve got an internet connection from the computer you’re using to interface to your ORx, you’re probably seeing data from findu.com not from your ORx.

I’ve got some troubleshooting steps to take that the author has suggested. Will let y’all know how those work!

thanks much,
ben

I’ve exchanged a couple more e-mails with Andrew, the author of YAAC. Below is an except of the e-mail I just send to the yaac-alpha-testers list:

Hello again Andrew and all,

On 10/10/2016 7:30 PM, Andrew [yaac-alpha-testers] wrote:

Hmmm… this is odd. The reason the port address is showing up as
localhost/127.0.0.1 is that it didn’t get copied from the text field
into the internal port configuration data structure. I’m making a code
change for the next build that will ensure the address copy happens
before YAAC tries to open the port, but in the meantime, type in the
address and then press the ENTER key while the cursor is still in the
text field (before clicking the Save button); that should cause the
address to be copied. Things are probably hanging because YAAC is trying
to open the webserver on your own machine instead of on the Outernet
receiver (since the wrong address is stored), and your webserver isn’t
responsive (or you just don’t have one to respond).

I tried this - it still hangs when I hit save…so I then have to hit cancel…but I can confirm now that when I hover over the RF box it says “OUTERNET:/10.0.0.1” as it should.

The Outernet folks tell me there is a webserver on the Outernet
receiver, which is how YAAC is trying to read the files, from the
specific URLs where the APRS data is supposed to be stored. You can try
using the web browser on the computer running YAAC to surf the webpage

http://10.0.0.1/direct/Amateur%20Radio/APRS/APRSAT/messages-a.html

Copy-n-pasting this into the browser gives me a “File Not Found” error.

If you can’t find that file, then I need to talk to the Outernet folks
and find out where they actually are storing the APRS information.

Looks like that may be the case…unless I’ve got something totally messed up. (which is highly possible…I’m great at breaking things)

So I decided to do some surfing around. I can find an APRS-looking file here:

http://10.0.0.1/en/files/Amateur Radio/APRS/APRSAT

It’s time-stamped from 9 October, and its now the 11th of October in UTC time so this isn’t the latest file. However…browsing around in the interface of Outernet’s Librarian, it looks like the latest file is 10 October 2016 at 20:00 UTC, which when I click on it is located here:

http://10.0.0.1/en/files/Amateur%20Radio/APRS/APRSAT?selected=messages-2016-10-10%2020%3A00%3A01%2B00%3A00.html&view=html

If I use putty and SSH into the Raspberry Pi, I can find the individual html APRS files in this path:

/mnt/external/Amateur Radio/APRS/APRSAT

An example filename would be:

messages-2016-10-10 20:00:01+00:00.html

and there are others going back in time…IE:

messages-2016-10-10 19:00:01+00:00.html, etc…

Looks like YAAC isn’t looking for the files in the right place? And that y’all and Andrew need to exchange some additional information?

thanks much and 73,
ben, kd5byb

I think I have YAAC all working correctly.

ftp://192.168.xxx.xx1/Amateur%20Radio/APRS/APRSAT

I have set the port to 21

It appears to be finding the data and every hour I see different APRS messages.

Is there any way we can put a "TEST MARKER " data into the Outernet stream that will turn up Via Outernet and then if all is working correctly appear in YAAC,

and also do a “test data Marker” of Internet data that will turn up in YAAC, if YAAC is configured to receive data from the internet.

Hi Seasalt,

I just tried that on my setup…entering “ftp://10.0.0.1/Amateur Radio/APRS/APRSAT” into the YAAC port setup and I got an error message. Tried it several times, no joy.

However…in talking with Andrew the developer, he noted that there is are some file name differences between what he’s expecting in YAAC and what Outernet is sending down. Apparently that has been ironed out and he’s working on a new release of YAAC:

Watch for a posting announcing the new build#103 of YAAC (coming soon to a website near you :slight_smile:

As to a test marker…I think one thing you could do on your system would be to disconnect it from the outer world…so it can only grab information from the Outernet feed. :slight_smile:

Thanks much and 73,
ben, kd5byb

Excellent Ben.

I am really grateful for YAAC and excited by the APRS messaging potential of Outernet.

KW4QB

PS can you send me a APRS message KW4QB?

+1 for APRS on Outernet. Would be really awesome to get more frequent updates though (10 minutes or better?)

1 Like

Is it me only or did we all just start receiving the APRS messages again?

Has the improvements to YACC display program been implemented?

I tried YACC a few days ago and It did not find any messages?

Can some one please explain the YACC settings to me.