C.H.I.P Wifi Down


#1

The Outernet kit was running well connected to the Asia-Pacific Inmarsat then I tried to be clever and upload my stats to the stats website. Big mistake. I have removed the wifi connection. I thought I could fix it by getting back to Skylark 1.0 using a USBmicro connection to C.H.I.P and using the browser IP of 10.10.10.10 but this does not work. I have looked at the forum, read outernet and rxOS documentation but am no further ahead. What is the simplest way of recovering wifi in rxOS or do I need to reflash using Oracle VM ?

I have used linux recently but am stuck with a Windows 8.1 and Windows 10 machine at the present time.

Thanks
Lorne


CHIP computer broken?
#2

Do you have a usb to TTL serial cable? If so you can connect to GND-TX-RX on the CHIP to get the console connection.

Here are the labels…

Good Luck!


#3

I believe if it cannot find your wifi it will revert back to hotspot mode. Try turning off your AP and restarting your chip.


#4

Many thanks for the comments and sorry I could not find a USB TTL cable but thanks for the clear photo of the CHIP with the labels. Mine does not have any labelling at all.

I decided to try a re-flash using VM and that worked well. Now all I have to do is start downloading again.

I would still like to upload stats from my location (Christchurch NZ) but I see most NZers are less than 3 which pretty much corresponds with my experience so far with it sometimes going over 4. I will check the wifi connection instructions more carefully next time.


#5

Lorne,
if you do the 1.2 update gain ( there is an download here somewhere!) then you may find that you can see the outernet hotspot and connect but not get an IP address from it.
this is the “easy fix” for that issue
fixed this WIFI issue like this (cut & pasted from an earlier post)

After connecting to the outernet hotspot

  1. Opened the config of the IPV4 on the WiFi on my PC
  2. change it to NOT use DCHP, but manual settings
  3. set the IP as 10.0.0.5
  4. set the mask as 255.0.0.0
  5. set the gateway as 10.0.0.1
  6. in my browser I went to 10.0.0.1 and the page appeared
  7. Logged in as outernet
  8. went to “Network” in Skylark
  9. changed NOTHING as the settings were OK for me
  10. clicked “Apply & reboot”
  11. Set my local wifi back to DHCP
  12. waited for the CHIP to reboot , and connected to the outernet hotspot
  13. connected to 10.0.0.1 in my browser like normal
  14. there is no step 14!

I don’t have the CHIP on my network, it is separate and I connect one of my machines to the “Outernet” hotspot to preserve my local “OpSec” :slight_smile: Things get complicated once you change the Access mode…


#6

But note that you were just lucky that you could still connect the WiFi with manual IP address…
Both of the systems I have here would not connect to it anymore. The Outernet SSID still appeared.

I would recommend getting a USB-TTL cable and keep it as a spare to be able to rescue the CHIP.
It is also useful for a lot of other tinkering. Almost any device today has some internal connector
or pads where TTL serial console is available…


#7

Or for just a tiny bit more money than a usb-ttl_serial cable you could get…

A BUS PIRATE! It is a handy multi tool for electronics tinkering that also happens to do serial as well.

You can google search the term.

-C


#8

thanks for that one CRCasey thats going on to my to buy list for dealing with single board computers.


#9

That looks nice, but it depends a bit on how cheap you are if this is a “tiny bit more money”.
When shopping locally I can get a TTL-USB cable for under 10 euro, but checking at Aliexpress
I found this one for 1 euro including shipping:
https://www.aliexpress.com/item/CH340G-5V-USB-to-TTL-UART-Serial-Converter/32524218818.html
It comes without case and wires so you will need to have some jumper wires as well.
Another one that comes with wires for 1,48 euro:
https://www.aliexpress.com/item/1pcs-CP2102-module-USB-to-TTL-serial-UART-STC-download-cable-PL2303-Super-Brush-line-upgrade/32694152202.html
(this has female connectors so to connect it to the CHIP you need a header or some pins)

Of course the bus pirate can do a lot more so it might come in useful in other projects.


#10

Just in time HackADay does an article on the BusPirate.

Bus Pirate I2C

-Cecil