DC Boot problem

Hi everybody, I am trying to start using my just arrived Dremacatcher V2.03. I tried both Skylark and Armbian images on 2 different Micro SD (Kingston 8 GB and Samsung Evo Plus 32gb) but not getting any sign of life from Usb otg nor led blinking on the board. I get 3 led continuosly on (Power and red and green next to SW_PWR button) but nothing is happening. Power supply tested from laptop with one usb cable, then with 2…then tried with 2.1A powerbank but no success.
Any suggestions?

Did you plugin the SD Card into the right slot? Just curious.


SD Card is in SD0_OS slot, next to led lights. It should be the good one.

Make sure the card created properly… I use the application called “etcher” its fool proof…

1 Like

I also suggest you do a complete SD disk clean-up using Rufus 2.17 before you write the image. The settings I use with Rufus are shown here:


1 Like

Tried both , but no success. Any suggestions for understand what is happening? Tomorrow I will receive USB to UART adapter, can I use it to see where the process is stopping?
What else can I check?

Copy out any info you see there that will be a good start…

UART adapter arrived, installed correctly (I can see echo if tx and rx are jumpered), but not receiving any data from UART. No blinking…nothing…
Guys, I start thinking I received a dead board… Please help me!

This is the status, led not blinking, no UART. Power supply from 2.1A Powerbank.

1 Like

did you connected uart rx of the board to tx on your dongle and vice versa?

you need gnd, rx and tx, you don’t need usually the vdd until your dongle can handle 3.3V level

1 Like

Yes,tx and rx are crossed, dongle has 3,3V or 5V level selection via jumper, 3,3V selected. Settings of com port: 9600,8,n,1 no flow control.

1 Like

give it a try to format the SD card with rufus and try burning with win32 disk imager:

That was always rock stable to me, so at least the sd card issue can confirmed (if any)

A few thoughts…

I ran into a problem of not having enough power to my Dreamcatcher 2.03. It would start and get a little way into the boot process and then shut itself off. I think I got 3 or 4 leds, but not much blinking. Using a better power adapter resolved that issue for me.

I didn’t have any luck with the uart at a baud rate of 9600. I tried 115200 and it worked fine. 115200 is probably excessive and I suspect there are other baud rates that would work as well, but I just stopped experimenting as soon as I found one that worked.

Also, is this the serial adapter you’re using? I’m just curious to make certain that yours is on 3.3v rather than 5v.

– Nate - KE0PFS

1 Like

Hi and thanks for trying to help me. That is exactly the adapter I use, 3,3V selected on jumper. Tried at various speeds but not success. Power supply is a powerbank with 2 outlets (1,5A and 2,1A): I tried single power, double in parallel… no difference. Are the schematics of DC 2.03 board available to start an hardware fault search?

@ginaccio It appears that you have a defective unit. Please send an email to [email protected] so that we can replace it for you.

1 Like

Hello Syed,
Thank you for the support. Email sent!

1 Like