Dreamcatcher EDUP WiFi USB dongle off | No Wifi

I received my Dreamcatcher kit yesterday and was able to flash the 8 GB micro sd card with Armbian_5.27_Dreamcatcher_Debian_jessie_next_4.10.14_20170602.img and boot up.

Connections | USB_PWR | The power supply is 5 VDC 2.1 A
Connections | USB_OTG | Connected to Windows Computer USB port (device manager says port 7)

LED8 USR2 | Flashing yellow/light green (not sure what color it is)
LED9 PWR | White
LED10 STATUS | Green
LED11 AGP3 | Red

I can talk to it over USB using Putty in Windows 10 (Lenovo Win7 PC) with serial settings 115200 N 8 1. When I first received the board the WiFi dongle (small USB plug, EDUP 802.11N Model EP-N8508GS) there was a yellow or green light when power was applied to the Dreamcatcher board. I also tried a second time to relfash the microsd card after I issed the SUDO poweroff (actually my entire computer shut off immediately! - I wonder if it was trying to pull a lot of power during the power down sequence from my computer that caused it to shut down or something shorted during the same sequence?). If I plug the WiFi USB dongle it into my windows computer it does light up. I however never saw the outernet SSID on my WiFo network. I have used NMTUI to setup the connection to my wireless network but I don’t see how to activate it. It doesn’t come up in the NMTUI menu (Activate a connection). I thought the light did come on when I first had everything setup.

I am wondering if there are other files or drivers I need or a command line command I need to issue to turn it on?

iwconfig -a
no such device

ifconfig -a

Link encap: Local Loopback
inet addr: Mask
inet6 addr: ::1/128 Scope:Host
RXpackets: 384 errors 0: dropped: 0 overruns:0 frame:0
TX packets: 384 errors 0: dropped: 0 overruns:0 frame:0
collisions:0 txqueuelen:1000
RX bytes: 31104 (30.3KiB) TX bytes: 31104 (30.3KiB)

So is there sofware I missing or a process or step?



Had the same issue at one point.
I have to reboot my windows 10 and dreamcatch
then ran putty, click on serial and change to your com port, connect, once you get to the login i ran ROOT as User and outernet as password. or just " sudo su " then enter your password, should tell you that your are superuser or something like that.,
then i typed " nmcli d wifi connect <your_wifi_network_name> password <your_wifi_network_password>
that one didnt work so well for me so i Ran " nmtui " and connection then use your ARROW keys and spacebar to find your wifi spot. hit spacebar on theat and then arrow right to ACTIVATE
then hit quite. Now that should get it to pop. if not re load the image on the sd card and start from the begining

Note the Green Light on the Wifi Dongle does NOT blink with this setup… It does and Will blink and be a lot easyer when the new UPDATE rolls out this week (i Hope)

i hope that helps

Hi James,

Thanks for the good comments. I am using Putty to communicate and I can step through the NMTUI and setup a connection but it does not show up in the listing - it is blank. Actually it is sort a skinny screen grey screen with Activate and Quit on the right hand side. I do see the Activate a connection menu but there are no WiFi connections to Activate. I can edit my connection and all of the settings are there.

Also I followed the docs for loading the code onto the SD card. Are there specific future files coming that have to get loaded into certain folders or would there be a completely new image file to load onto the SD card?

Is Skylark specific to the CHIP version?

Are you able to connect over WIFI?

Is the current OS simply a core group of files to get things up and running and the satellite and wifi goodies are built yet…but coming soon?

Sorry for so many questions!

Thank you.


I have the Skylark image loaded and am able to login this far. I don’t know how to turn on WiFi from here or start the Outernet session. I am assuming that the user interface happens over wifi? There was also the original armbian image. I am assuming I simply run Skylark? Does the OS only run from the SD card or did that somehow get copied over?

Here is what putty shows. I don’t know what to do from here.

Skylark v4.4 / dc (16ba9bb)
built at 2017-06-22 22:46:51+00:00

Copyright 2017 Outernet Inc
Some rights reserved.

[Skylark][[email protected]:~]$

Sent ya. a PM

Wifi is on by default on Skylark. Are you not seeing the green LED flicker on the dongle?

no light at all , from what he told me

Let’s try the other USB ports.

I think the 5V is gone on the USB ports. I issued the Sudo power off command and lost power to everything immediately Including my computer for some strange reason. I had the computer and power supply for the Dreamcatcher plugged into the same outlet. It is like when the pseudo-power off command was issued that that some sort of component or programmable logic device shorted on the dreamcatcher to ground immediately which was at that point in time that I lost green light on the dongle and power to all USB ports. I think the process of issuing the pseudo-power of command did cause a short on the dreamcatcher power supply input which drew a tremendous amount of current off my computer USB port which is why I lost Wi-Fi on the Dreamcatcher and why everything shut down immediately. At first I thought it might be some ESD event but working in the electronics field I’m fairly convinced that this was a some short to ground that was caused by the command analogous to pressing the power button on the Dreamcatcher board.

Can you please initiate an RMA through [email protected] ? We’ll send you a label for this defective unit and then send you a replacement.

Yes. Thank you for your help.



The Dreamcatcher I believe should come with

  1. This EP-N8508GS 150Mbps mini wireless 802.11N USB adapter is the world’s smallest.
  2. It adopts Realtek8188CUS chip and 802.11n wireless transmission technology. The transmission rate is up to 150Mbps.

I am having a similar problem with WiFi not working. My Dreamcatcher did not come with a WiFi dongle so I have tried a

USB WIFI N - WIRELESS N Chipset RTL8188 - Wifi N USB Mini Adaptador hot wireless I bought from Ebay for my Armbian Orange Pi boards. It works fine with Armbian.

I guess the next test is download the Armbian image for Dreamcatcher and see if the WiFi RTL8188 dongle works with me Dreamcatcher.

My DC with the EDUP dongle sees wifi networks but won’t connect. At work, I thought it was my work network being extra picky/secure or something. It would connect to a wifi hotspot on my phone. At home, it sees my network, but won’t connect to that either. Why would it connect to a network on my phone, but not a wifi at work or at home?

I’ve tried the command line interface, and the gui interface, the command line says something about seven secrets that it didn’t know?!?!?

Using nmtui I get the gray window and it shows all my wifi (s) however the EDUP device does not show up?? The wifi green light is on but not blinking
Also where is the ssid and pw for the Wifi?

SSID is ‘Outernet’. It’s an open network. On Skylark, the login screen is pre-populated for guest access. Admin access is ‘outernet/outernet’.