Dreamcatcher first use problems

I’m trying to get Dreamcatcher working for the first time and running into problems with both the SD card that came with it and another card I flashed with Skylark Release 4.4 on it.

• The Outernet wifi network shows up, but trying to connect to http://my.outernet.is yields:
“Your receiver doesn’t seem to have reported in. Err: null”

What’s causing this?

• The lights on the Dreamcatcher are:

  • LED 11 is red
  • LED 10 is mostly solid green but I’ve seen it blink occasionally
  • LED 12 USB H: green
  • LED 1 packets: off (the board is indoors without the antenna connected.)
  • LED 2 Lock: flashing red
  • LED 3, 4, 5, 6: Off
  • LED 7 USR1: flashes only during startup
  • LED 8 USR2: flashes
  • LED 9 Power: white

• I tried to connect via the mini USB-serial port to Windows 10.
Device Manager shows"CDC Composite Gadget" with the bad driver icon. I haven’t been able to find a driver that works with Windows 10 - 64bit. The URL to a driver in one of the posts on this forum is broken.

One of the driver-update sites found a driver but the install reported that it was an incompatible version. Another driver that I found was reported to have a virus. I tried several .inf files but they weren’t seen by Device Manager’s > Update Driver.

Anyone have a working link to a driver?

• I connected the mini USB-serial to an Ubuntu Mate laptop that I’m not very familiar with. (I’m a Linux novice.) That caused the laptop to report that it now had a Wired Ethernet Connection and it dropped the wireless connection.

Is that what should happen?

• dmesg | grep tty
finds: ttyACM0
• But there’s not a ttyACM0 file in the /dev folder or anyplace else that I can find.

• lsusb yields
Bus 001 Device 008 (stuff removed) Linux-USB CDC Composit Gadge (Ethernet and ACM)

I haven’t had any luck opening a connection with PuTTY.
What do I enter to connect to USB Bus 1 Device 8, or ttyACM0. 9600 baud?


so here is the driver page.

goto your device manager and see what com port it went to.

then open putty, select serial , enter your om port, and change 115200 baud

see if that helps

Only install the driver from that link. Don’t follow any additional instructions regarding changes to the driver .inf file.

I’ve used this driver on three Windows 10 Pro/Enterprise 64-bit machines without issues.

1 Like

Thanks, that driver worked. I am now able to log in from Windows 10.


re: Outernet WiFi connection error:
“Your receiver doesn’t seem to have reported in. Err: null”

I’m stuck again, after successfully logging in using PuTTY on Windows. I get the prompt: [Skylark] [[email protected]:~]$

But I can’t find executables that seem related to outernet or Skylark. I assumed that I’d need to restart them and look for error messages. I found “outernet” and “skylark” directories in: /etc

I looked at: /var/log/messages and don’t see anything that’s obviously an error.

What do I do next?

What does the SW1 switch do?


re: Outernet WiFi connection error:
“Your receiver doesn’t seem to have reported in. Err: null”

This error for me was a problem with OS X 10.11.6 I happened to try to connect from my iPad and the Skylark Web interface worked.

The Outernet WiFi shows up as a choice in OS X but it can’t get the correct IP address range and thus can’t connect to I played with the OS X network configuration tool for awhile but I couldn’t get the Outernet WiFi connection set to the correct IP range.


that link my.outernet.is gives me the same error and im on my own network and not outernet.

is it possible that your not really connected to the DreamCatcher network? Try instead to insure your connected to the outernet network use you should see a login screen…

now when connected to outernet directly, any hostname you use in the webbrowser will redirect to the regular device home page… (this doesnt include subdirectories on the domain though)

that is if you connected to the outernet AP, then going to google.com will show you the outernet login page, but google.com/mydir/webpage.htm wont work…

check that stuff, check back in…


re: The Outernet WiFi shows up as a choice in OS X but it can’t get the correct IP address range and thus can’t connect to

After poking around in the OS X Network control panel for awhile, Outernet suddenly showed up as a “Preferred Network” and I can now access: and Skylark.

I have no idea why it didn’t work for 2 days and then suddenly started working. The whole time OS X was reporting that it was connected to an “Outernet” WiFi network with 4 bars.)

If you’re on OS X and are getting the: “Your receiver doesn’t seem to have reported in. Err: null”, look in your Network control panel and make sure that “Outernet” is showing up in the “Advanced…” option as a “Preferred” network.