[Fixed] Attempt to change wifi channel failure


K4RKR here. Got device yesterday 2/2/17. Got set up and over night captured 20K+ packets. Complete APRS mesages, etc. Yeah, FUN!

Noticed that outernet was working on wifi channel 6 a very congested channel here. So using the network widget in skylark I changed the channel to 3 and hit apply and reboot. After reboot no wifi, No ssid. Thinking it might have become hidden I tried that. Nope, seems like no wifi.

The question then is: Other methods to get into the C.H.I.P to fix?
USB? method, instructions please.
Re-flash? arg.
or last because I am most lazy (perl programmer) serial access?

Any info on WHY this happened so as to avoid in the future also welcome.
Was having fun now it becomes something like work…


OK I was ready to do a re-flash when I read pe1chl posts in the Skylark 1.2 feedback thread.
He said, "login, rm -r /mnt/conf/etc and reboot."
rm -r ??? could be bad but I am about to re-flash so why not try it.
(at this point I have not figured out the rxOS but have a hunch it is tinyCORE linux based, a RAM based linux. I LOVE tinyCORE linux, anyway…)

I performed these actions:
Plugged into linux PC using good USB data cable.
Waited for wired connection to come up.
In shell typed: ssh [email protected],10,10,10 password: outernet
Typed in the command: sudo rm -r /mnt/conf/etc
Entered password: outernet
Then typed: sudo reboot
But user ID was now missing and it failed so I pressed the power button on the c.h.i.p till it shutdown.
Powered back up and “outernet” SSID was seen on wireless and I connected and logged it.
WILL NO TOUCH the network widget until news of updates/fixes.
Shame as almost every visible wifi in my area is on channel 6. Like 11 of 14. FiOS auto select is WIN, Channel 3 would have been awesome.

Now will need to return c.h.i.p to RTL-SDR, Amp, antenna setup and see what happens…

Thanks to demandzm and pe1chl for help and hints.

Update so far…

Do not think any OTA was in play here.

Good USB cable from PC to c.h.i.p gives wired connection.
IP of c.h.i.p. is
webUI works.
ssh to [email protected] works.

grep for dhcp does not show wlan0 line as seen in the OTA update thread.


That apply and reboot has been a problem for some people before. Since you have access try changing network settings to connect to a router, and then change back to hotspot. But don’t use the apply and reboot, instead make the changes and use ssh to reboot.

OK. I will do that. I did try and change and reboot with the network widget, no luck. So this is what I will try:

change to router mode and back to hotspot mode and reboot via command line (ssh)
and if not that then try:
change to router mode, reboot via CLI. next change back to hotspot mode, reboot via CLI.

Thanks for the info.

Take 3…

The apply changes and reboot from ssh did not work for me. HOWEVER, at least it reverted to the AP, so I was back up and running in minutes. I will and see if there is a fix for this, unless I really get bored one day.

Tried both of the above methods. NOPE.

ifconfig lists wlan0 with IP
info for MY router is in wpa_supplicant.

Noticed that sometimes that info sticks in the webUI and sometimes it does not.

I have two laptops 1 linux, 1 windows 7. c.h.i.p wifi not seen on either or on MY router at anytime.

Also hotspot mode is what I am after long term.

Time to learn about re-flashing?

That would probably be your best bet unless someone else has an idea. here is the skylark manual, it should have all the info you need for re flashing.

Maybe “apply and reboot” does not properly sync the filesystem before the reboot?
It could be that files get corrupted resulting in problems after the next boot.
Removing the configuration appears to fix it, the default config files are put back on the next boot.

True that you cannot do 2 times sudo for this remove, I did this:
sudo sh
rm -r /mnt/conf/etc

1 Like

Yes. I think the trouble with the OTA and the “Network: apply and reboot” are both related to the same persistence issue. Might have to start looking under the hood to see what is going on. I mean I really want to get moved off of channel 6. What I am looking for is likely in the real config folder and not the copy /mnt/-ed (into RAM I am guessing). But thanks a bunch for the quick fix.

Also of note: Sylark 1.0. No OTA involved in my issue.
System now seems to be working just fine. Lost no files. Captured another 26K+ packets last night. Enough that stuff is showing on the weather globe now. Lots of APRS messages and some BBC news.

Took this time to replace the pine cone holding the box open to the “correct” angle with a pen so UPGRADED! Will look into a real mount as signal fluctuation is great and wild.

This may be kinda hackey, but you could use the user script and the iw command to change channels at every reboot if you can’t get the desktop manager to do it.


First I would try to just edit the /mnt/conf/etc/hostapd.conf file, sync, wait and reboot and see if that
works when changing it via the web interface doesn’t. At least that would point to a possible cause.

I have ifconfig, must have missed iw is that just short for iwconfig? I tried iwconfig and it was not there.

And pe1chl what exactly is sync. A command? A time frame for the OS to scan/update? But yeah that is the plan. My linux laptop had HD failure so there has been a playtime delay.

Yes sync is a command. It tells Linux to synchronize the updates of the file system stored in ram with the physical storage media. Seen used quite often before shutting down a system.

Yes it should be part of the reboot or halt process anyway, however I think that with flash memory
there is a required delay after sync to make sure the data really gets written to the flash pages.
It may be dat “write to file” immediately followed by “reboot” sometimes goes wrong?
That is why I recommend to edit the file, sync, wait (e.g. 10 seconds) and then reboot.
When that fixes it, the fix would be to put that sequence behind the “apply and reboot” in the WebIF.