Further instructions for wifi access necessary for Dreamcatcher


#1

Hi

I have got to this point in the instructions:

  1. To connect to wifi network, use command line:
    nmcli d wifi connect your_ssid password your_password
    or using the text UI:
    nmtui

but I do not seem to be able to get further.

I have seen a recent discussion that the wifi for the Dreamcatcher is not turned on; if this is still the case, what can I do with this device? Do I simply wait for the software to be written, or can I use the device without wifi? I recall that the whole point of the device was that it used wifi to connect with a wireless device so that you could access the downloaded files through a browser. Am I wrong?


#2

That command allows you to connect the Dreamcatcher to your own existing wireless AP. The Dreamcatcher does not have the software needed to get the Outernet data or serve it up via its own AP yet. That’s still being worked on. For now, the board is a general purpose SDR, at least until the Skylark-like software is available.


#3

In my case, the Dreamcatcher wouldn’t connect to my wireless router, because I have SSID broadcast off. If you have a “hidden” network, try unhiding it temporarily when setting up the connection on the DC.


#4

It took my brain a couple tries… but I had to try twice in nmtui… edit the connection by manually entering the ssid…(I didn’t have the caps on correctly the first time…) but then
it magically appeared in the activate a connection.

I am still looking for help so I can just powerup the dreamcatcher and connect to it using vncviewer (over the wifi). Right now I have to open a putty terminal and start vncserver. I am not smart enough to figure out either an autostart scripting, a systemd, or what is general system configuration: “armbian-config” that see after login.


#5

Is there a vncserver file in /etc/init.d? If so, try entering the following in the command line sudo update-rc.d vncserver enable.

That will cause vncserver to run at startup.


#6

Thanks, kinda got it running, I had to create the file vncserver So… I followed this link
http://www.abdevelopment.ca/blog/start-vnc-server-ubuntu-boot/
changed the line to USER="outernet"
Armbian wanted some LSB info in the header so I used:
### BEGIN INIT INFO
# Provides: vncserver
# Required-Start: $remote_fs $syslog
# Required-Stop: $remote_fs $syslog
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Start daemon at boot time
# Description: Enable service provided by daemon.
### END INIT INFO

After reboot the vncserver starts but it seems to have started before all the login env userspace is completed… meaning it is at pwd of / instead of ~/ and I get permissions denied on lxde menu items like logout

So. question - Does anyone have a better file vncserver?

–Update — I read further down and answered my own question see:
I too was having an issue where the VNC server was getting started, but I saw only a gray screen when I connected to it from a remote client. After some investigation, I realized the the VNC server was being started too early in the boot process, perhaps before the X windows subsystem had been completely initialized. I was able to solve this problem by removing the vncserver script from the startup sequence using:

sudo update-rc.d -f vncserver remove

and then adding it back using:

sudo update-rc.d vncserver defaults 99

The value of “99” indicates that this script should be run later in the startup process. Other values may work for you, but the value that was being used in my case by default was 20, and that caused it to be run too early.


#7

Everything is working again. Yeah!