Getting Started with HD Tuner and Pi 1 B

I have the Genstar HD Tuner and a Pi Model B. It has a 2A PSU and I’ve downloaded the latest Pi 1 ZIP (size suggests it’s the 3.1 build). I have used a Windows PC to format the 16 GB Sandisk 40MB/s SD Card (and tried with 16GB Verbatim too) using SDFormatter 4 (with the Format Size Adjustment ON) and have copied the latest unzipped ZIP contents onto the root of the card however I only get the rainbow boot up screen. I have tried one of these cards with a standard NOOBS build and it worked fine.
I do not have a wireless dongle to hand currently so the setup was a Cat5e cable to my switch and onto my router (which worked fine for the NOOBS build). I have a USB keyboard and HDMI too. I have tried with and without the HD tuner connected but it makes no difference. The Pi starts up and I see the small green LED light up with the red LED. This lasts about 2 seconds and the green goes out leaving just the red LED. I have tried leaving the unit for some time to see if it is caught in a long loop but no further progress. I note that the Ethernet port on the switch is not indicating any active connection either. My LAN (and DHCP) is on 192.168.2.x subnet.

Any thoughts welcome as I’m not sure I’ve got any other diagnostic opportunities open to me?


Can you double check the image location? This is the latest image for Pi 1.

Hi Pradeeka,

I was downloading the ZIP referenced on as which is 66,820,343 bytes and the 8 files in the ZIP are dated 20 or 22/4/16. This seems to be the same as the 3.1 build.
I’ve checked the SDCard having used it in the Pi and all the files still seem to be intact so I don’t believe the card is corrupted.
I’ll try with the 3.0 build and then the 2.6.1 to see if I have any luck with them.

Do you know if the build is dependent on the WiFi dongle being present? I hope one should be arriving in the next day or two.

BTW Pradeeka, What Pi board build are you using? Looking at my units (early buys) they appear to be BD1R11 marked close to the HDMI connector which I take to be a release 1.1

Looks like yours is a 1.2 if I can make that out from your photo.
Looks like I’m either going shopping or re-building the ORxPi from scratch :frowning:

Branko, is the rebuild feasible or is the demodulator functionality a library that would be incompatible with the HW?

will check and let you know.

Green LED should flash during SD card activity. Probably the problem is with the SD card. Can you try with another SD card.

For Pi 1, it will take about 10 minutes for the very first boot.

I tried with another card but same response. I also tried the card with a standard NOOBS copied onto it and that worked fine :frowning:

I presume the green LED is active on your system when it does that initial 10 minute boot?

I’ve tried the 3.0 and 2.6.1 builds too and same response so I’m leaning towards the issue being an old 1.1 board (as your board says © 2011.12 under the icon whereas mine just says © 2011)

Yeah, my one is Rev 2.0.

I think it’s better to purchase a Pi 2 and build your receiver. :slight_smile:

do you know , that i received this error
"Loading user interface…

If interface does not appear to load for more than 10 minutes, you should restart the receiver"

too, i cant connecct to wifi , any editin in interfaces file after boot clear

Hi Guys,

OK, got a Pi B+ v1.2 today but I’m having mixed success so far. The best I’ve got to was that Loading user Interface… and the 10 minute restart message but nothing more than that. The worst is just a blank on boot up with no activity on the Ethernet switch :frowning:
I’m working through a variety of different mini SD cards as I have a Pi Hut 8GB NOOBS SD card and a Samsung EVO 32GB card. So far the most successfully seems to be the 8GB card and I have the HDStar disconnected to see if that has any bearing.
Looking at the messages file in /var/log I can see messages about the DHCP and 10.0.0.x subnet - do I need my WiFi on that subnet?

This is part of the log file but not sure if this is occurring as the HDStar is disconnected so I’ll wait a while and restart the system with the HDstar reconnected (I also have the two hdmi lines in the config.txt file commented out just on case)
Jun 23 18:15:55 orxpi daemon.err lighttpd[265]: (mod_proxy.c.990) establishing connection failed: Connection refused
Jun 23 18:15:55 orxpi daemon.err lighttpd[265]: (mod_proxy.c.890) proxy-server disabled: 8000 8
Jun 23 18:15:55 orxpi daemon.err lighttpd[265]: (mod_proxy.c.1293) no proxy-handler found for: /
Jun 23 18:15:58 orxpi outernet.monitor: Could not connect to socket. Pausing for next attempt

1 Like

OK, back on the case as I now have the same model as Pradeeka (i.e. the 2011.12 text).
I now get the interface appearing OK. However, now I think I have a possible HW issue with the outernet Geniatech HD Star unit. I have tried to verify the unit using ProgDVB on my windows laptop to see if I can get any signal on it but no success (cables and signal verified with a separate satellite receiver unit). Is there any way I can do any verification on the Pi to check or does the lack of signal on my Windows PC suggest there is an issue.
Unfortunately the geniatech site is down at the moment as I was hoping to re-download the file and it doesn’t appear to be cleanly mirrored anywhere. I’m guessing as you guys are in the Linux domain, you probably haven’t got a copy of this driver file (4.95MB) that you could upload/email?

We use HDStar specifically for the purpose of building receivers, so we don’t have any drivers for it.

HDStar is not a fantastically great tuner, so it will need a stronger signal than a proper STB. Maybe that’s the issue?

What’s the general experience with them re. cables lengths to LNB and capability to operate a QUAD LNB?

I don’t seem to be getting any signal on the in line signal meter with about 8m of cable but I don’t have a fixed satellite dish in use so alignment is limited (but I was expecting to be able to get some signal as I moved the dish around, just not optimised).
I’ll try and repeat with the STB to confirm this approach at least gives me some signal.

Quad LNB with some form of switching or four individual LNBs in a quad LNB mount?

Andy, I can give you some very specific details.

I have an Invacom QPR-031 quad LNB using an 80 CM dish out 100 meters of RG-6 cable from my Manhattan DJ-1997. It works very well in the FTA mode. I see Galaxy 19 at 97 degrees.

When I switch it to my Lighthouse, I get fine reception. I use my FTA setup to point my dish - - the Lighthouse is not responsive enough to do the alignment. Ken