Hotbird broadcast alive?


#1

Are there any data/signal/broadcast on Hotbird-13 on 11470 MHz outernet?
t.janos


#2

Yes, we are definitely broadcasting on Hotbird and it was confirmed by staff this afternoon. Are you not able to receive anything?


#3

Syed,
Thank you very much for your answer.
This is the case here:
Some weeks ago I made a setup with the arch linux image, without any success.
Some days ago I started a new setup, used on the new official raspbian image. This based on 3.18 version kernel, and it seems, it contains all the modules, need for the PCTV 461e DVB-S2 device.
I have a dish on the roof, pointed to the Hotbirds -13, with an universal LNB.
After the setup, I received all the multiplexers from it, I disabled all, exept the 114700 MHz, which is the outernet. In the Services tab I started to Play it, it satarted but I didnot receive anything. I see this status on the Status tab.
I tried to check the situation “independently”, mean, I switched on the set-top-box, and checked the channel (actualy 660, this is the outernet). It seems me, there were not any signal that time.
Now I restarted the setup, and I was able to receive some files from the sat. It is visible on the Library. It seems, is it working.
In the Satus tab I see, it has 12 kb/sec bandwiths (during the downloads) and the signal strenght is 85 %.
But I have the feeling, the power to the LNB not enough: from the set-top-box it run 13-18V, but from the PCTV usb device, from it original power unit it run only 12 V. I have approx 15 m long coax from my desk to the dish, it seems, me it is not enough…
Have somebody any experineces in this topic?
best wishes:
t.janos


#4

Could you try 11,471,000 freqency please? The information in the documentation might be outdated.

Edit: if you don’t see it in Services, try adding the mux manually (more about it here).


#5

Branko,
thank you for the tip.
I tried it, changed the frequency to 11471000 kHz, with the Add muxes manually tab, with this parameters:
Frequency (kHz) – 11471000
Symbolrate – 27500000
FEC — 5/6
Constellation – QPSK
Polarisation – vertical

it start to explore the muxes, and the services, I enable the 11471000 channel only, and the outernet service, and start to Play. It start a Test state, but receiving nothing. The signal strenght is 87 %.

It seems me, there is another unshure setup in my config, this is the LNB type.
In the Tvheadend configuration --> TV Adapters --> Satellite config menu there is an LNB type tab. You can chose this options there:

add_to_lnblist(array, “Universal”);
add_to_lnblist(array, “DBS”);
add_to_lnblist(array, “DBS Bandstacked”);
add_to_lnblist(array, “Standard”);
add_to_lnblist(array, “Enhanced”);
add_to_lnblist(array, “C-Band”);
add_to_lnblist(array, “C-Multi”);
add_to_lnblist(array, “Circular 10750”);
add_to_lnblist(array, “Ku 11300”);
The parameters are described in the dvb_satconf.c file, it seems, my LNB more or less the Universal type. It seems, the parameters deal with the oscillator frequencies (?):
if(!strcmp(id, “Universal”)) {
*f_low = 9750000;
*f_hi = 10600000;
*f_switch = 11700000;
My LNB has this parameters:
Low: 10.7 – 11.7 GHz
High: 11.7 – 12.7 GHz
I hope only, I choosed the correct type here. If somebody have more info about this, it would be usefull to share.
t.janos


#6

I’m not an expert on LNBs but afaik most european LNBs are universal (and that’s the default setting in TVHeadend). When you play the Outernet service, do you see the info card image? It’s a white image with black icons and text. If you see that, then you need to give it some time and check the ONDD logs.


#7

Branko,
I dont see any info card image. Is is appears through a browser plugin? (video player or similar?) I tried different browsers, with different plugin sets, an old Mozilla, a Chrome, and a new Firefox too, but I dont have such info image.
I dont know, where is the ONDD logs, you refferred.
But I made some looks-around in the logs, here are some messages, I found:

syslog
Feb 19 13:31:32 raspberrypi ipd[2137]: [ipd] Continuity error: 0 => 10
Feb 19 13:32:04 raspberrypi tvheadend[2212]: subscription: “HTTP” direct subscription to adapter: “Montage M88DS3103”, network: “Satlink”, mux: “Satlink: 11,471,000 kHz Vertical (Default (Port 0, Universal LNB))”, provider: “Satlink”, service: “Outernet”, quality: 100
Feb 19 13:34:51 raspberrypi ipd[2137]: [ipd] Continuity error: 11 => 6
Feb 19 13:34:51 raspberrypi tvheadend[2212]: TS: Montage M88DS3103/Satlink: 11,471,000 kHz Vertical (Default (Port 0, Universal LNB))/Outernet: H264 @ #64: Continuity counter error
Feb 19 13:38:05 raspberrypi ipd[2137]: [ipd] Continuity error: 9 => 3

user.log:
Feb 19 13:31:32 raspberrypi ipd[2137]: [ipd] Continuity error: 0 => 10
Feb 19 13:34:51 raspberrypi ipd[2137]: [ipd] Continuity error: 11 => 6
Feb 19 13:38:05 raspberrypi ipd[2137]: [ipd] Continuity error: 9 => 3
Feb 19 13:41:00 raspberrypi ipd[2137]: [ipd] Continuity error: 10 => 4
Feb 19 13:44:21 raspberrypi ipd[2137]: [ipd] Continuity error: 12 => 5

On the State manu page, it appeares Test state/job, try to check the Bandwiths, and the Errors, sometimes a Running state with similar changed values in Errors and Bandwiths. But I havenot any downloaded new files.
I have an option, to changed the LNB, I have an old one.
t.janos


#8

Looks like you’ve got a lock. Continuity error is normal. To see the info card, you will need VLC plugin. Not sure what browsers are supported, but Firefox usually works.


#9

Branko,
many thanks for your support and help.
Finally I installed the latest Firefox version, and enabled on it some plugins. I didnot find the VLC plugin, but there is a mplayerplug or gecko-mediaplayer plugin. It support play some video format, for example the mpeg2 too. Finally I was able to watch/listen the tv programs in the browser with it, and appeared the outernet white info card too.
Now I am waiting to receive any files from it.

The question remained: on the whiteboard.outernet page, on “View broadcast list” can we identify somehow on which satellite are the broadcast, appeared with the ON AIR green label? I have the feeling, not on all the satellites happened in the same time the broadcast process, labeled the files/sites with green.
t.janos


#10

@tjanos Could you confirm whether you are now receiving files? The feedback from Whiteboard is not accurate from a scheduling perspective, but Librarian will soon carry the live global broadcast. This should be available in a few weeks.


#11

@Ben Can you check your G19 setup to make sure everything is functioning as it should? HB and G19 both originate from the same server, so your feed should be identical to @tjanos


#12

In this time the conditions here arenot optimal to test the downloads:

  • at night arrived big clouds and continuosly raining. This is not a good situation to test an unshure dish/LNB setup.
  • I see on the tvheadend Status page, how the bit rate error values inceased compared to the values on previous days.
  • I wasnot able to install the VLC plugin for the firefox browser.
    I have running an old debian linux, installed on it some important programs. This progs use old libs. It need to update this libs to install the VLC plugin, but if I make this, the other progs, important for me, will not be run.
    I need to install a fresh, new system, maybe the recent ubuntu, and try to use the proposed VLC plugin.
    The mplayer/mediaplayer plugin, I used now, with the firefox, have two different behaviour with the received outernet data:
  1. start to “play” the downloaded data, in this case I see the outernet info page, on this picture I see, it changed time-to-time a little the contours of the characters.
  2. dont "play’, only push the received data into the cache. I see, how the cache file increased continuously.

Maybe there are access/permissions problems:
the tvheadend run under the hts user. The broswer on the host run on “normal” user, but I able to change it to root user too.
Maybe there are some permissions problem to write the downloaded outernet zip files to the filesystem on RPi with this setup?

On the tvheadend Status page I can check, the receive process runing normally, it displays the used bandwiths (usually this is 48 bps) and the errors, occured the actual downloads, but under the librarians, I dont see any updated/downloaded files. The signal strenght is 83 %.
(I made the actual run at 8.30 UTC)
Another small notes:
I tried to ask 2 URLs for downloads, and checked some in the list. I see, there are some, pointing to pages, shure will not work on outernet:
for example the gmail login page, or the youtube front page.
I think, it need a small notes about this pages: if the page need some “interactions”, mean need to click to choose something, or need some keyboard input, it will not work at all. If somebody want to see video from youtube, for exampl., he/she need to choose and ask the actual/exact url of this desired video.
t.janos


#13

Do you see “Continuity error” from time to time in your system log? If so, you should be receiving data.


#14

Branko,
I see in the user.log, messages log files this “Continuity error: x => y” error messages, but in the syslog appeares this version:

Feb 27 19:13:36 raspberrypi tvheadend[2195]: TS: Montage M88DS3103/Satlink: 11,471,000 kHz Vertical (Default (Port 0, Universal LNB))/Outernet: H264 @ #64: Continuity counter error
Feb 27 19:16:26 raspberrypi tvheadend[2195]: TS: Montage M88DS3103/Satlink: 11,471,000 kHz Vertical (Default (Port 0, Universal LNB))/Outernet: H264 @ #64: Continuity counter error

On the internet there are some explanations of this error, but it seems me there arenot applicable in my situation.

If I click two times the “Play” in the Services menu, it start in the browser the stream-player plugin, actually a version of the mplayer, and I see continuously the white info page with the text: Outernet, Humanity,s Public Library

I tried to stop the ond daemon (in /etc/init.d) and start it manually. In this case, it send this messages to the system console:

[email protected]:/usr/sbin# ondd -o /home/pi
20:22:03.788 [main] v1.0.1
20:22:31.662 [ipd] Continuity error: 9 => 3
20:25:21.672 [ipd] Continuity error: 8 => 2
20:28:31.687 [ipd] Continuity error: 11 => 6
20:33:22.684 [ipd] Continuity error: 3 => 13
20:35:23.679 [ipd] Continuity error: 13 => 6
20:36:51.712 [ipd] Continuity error: 8 => 3
20:40:08.683 [ipd] Continuity error: 0 => 9
20:43:42.697 [ipd] Continuity error: 1 => 11
20:45:52.706 [ipd] Continuity error: 9 => 3
20:48:27.689 [ipd] Continuity error: 8 => 3
20:51:05.705 [ipd] Continuity error: 8 => 2
but not anymore

Finaly, I tried to check the contents of the downloaded/broadcasted data with the dvbsnoop dvb/mpeg2 stream analyzer tool.
It seems, it arrived to me only 2 different packet data, these are:

Container_data:
Private Data:
…e1…&…n…TM.c…t .[j9cX…N…$.7…E.i…v…EX…0S…1II…j*…7…/w’.:,[…)…=…f.0LU…u…zv…E…U.W...D.......k..F4.."VDwm..Dct..Bu.........}........A.}....=jR........n+...."+Y...E.;..N.5..A.4...!.&..+...n.<p...3R...(.C..].EKRh_.1..;LH...{[email protected]{....GM0^...#z....7.
CRC: 1854735154 (0x6e8d0332)


SECT-Packet: 00000005 PID: 64 (0x0040), Length: 483 (0x01e3)
Time received: Fri 2015-02-27 19:00:31.883

…)…%3)…S…[email protected]…K-............B. ....h.......e...4.....$..S/....L.. ......XS.....C.vlG.x./5..j...........g.6.4.....6.6..z. ....L.%R.5.........b...P;0..2…t…".a…J.V.yv…x…y…^;.uh…c[t lm.sn..W....g.K..".."K...t.%.<…?GH[$…073.f…oA…yB.(.-.%…U…P-… t.n…2…I…}…i…Y…p.In…%…H.,.5l.T…+W|…m-…y=…j…<…c…!/…M:.c…>o8…a…JU0…H…{kD:]…h.0…+[ZD…=…`E…r8O.

PID: 64 (0x0040)

So, I think this system is working. Maybe

  • I am not enough patient to wait for a “real” broadcast time
  • my config has some hidden permission problem, and dont able to save the arrived data in the defined place.
    t.janos
    (sorry for long quoted error messages)

#15

Hmmm… it seems, the editor automatically formated my text…


#16

Yeah, I’m not receiving any files on HotBird right now, so there’s definitely something fishy going on. Talking to sat engineers right now to see what is going on.

Please also check out PM I sent you and let me know how it goes.

Edit: Forgot to mention there’s also IS20 that is visible from Europe. I haven’t yet tested it, but it is supposed to be live.


#17

Branko,
I have a plan to install a second parabola pointing to the Intelsat. I have a spare 60 cm dish, but not here in the city, it is in our weekend house. In the last weeks the weather here isnot really friendly, continuous raining and windy, not the best time to build parabola dish on the roof.
Now I am ready to receive from the Hotbird only.
Thank you for your attention to my problem:
t.janos


#18

ITS WORKING!!!
Start the download stream at 10.54 and now, when I checked it, the time is 11.58 UTC. Arrived 75 zip files, in 7.5 Mbyte size.
On the Status page I see, the download channel bandwith has 48 kbs speed, and the signal strength is 87 %, and counted 7 errors (maybe CRC errors)
The dish pointed to the Hotbird, and the outernet chanel frequency is 11471000 kHz
Many thanks to possibility for me to test my setup, and congratulations to your hard works!
t.janos


#19

Excellent! :smile:


#20

In the last hour it harvested many new files, there are in the …/download dir, 115 zip files, the total size is 12.7 Mbyte. It seems, majority of the files are part of the core contents.
The next step for me:

  • I plan to make a small presentation in our local ubuntu-linux user group. We meet regularly, on the second weekend of each months, I would like to make a “mobile” setup for this demonstration.
  • I found for this a small dish, for “camping use”, 35 cm diameter,

    I hope, it will be enough to demostrate the minimal prerequisite for recieve the data.
    I will use it, with a “mobile setup”, try to receive at the meeting place. It is a nice community place here, in the city:
    http://agrund.hu/
    t.janos