Hotfix firmware 2.2.000 for Lighthouse and ORx

Many thanks for testers. We’ve released firmware 2.2.00 for Lighthouse and ORx.

As mentioned in the summary for the last snapshot, this firmware fixes the following issues:

  • FSAL not picking up new downloads
  • Monitoring fixes
  • Twitter date update glitch
  • Issues with filemanager when typing in full folder paths into the search bar

Known issues:

  • It is possible that the tuner settings panel sometimes reports no lock even though the lock is not physically lost. You can tell the difference between this bug and actual no-lock condition by checking the IPC response from ONDD. If ONDD fails to respond to IPC calls, then you are observing this issue. If ONDD’s responses are normal, then you have actually lost the lock. This condition may manifest itself every 5 minutes. We have removed some 12,000 files from World Possible in order to minimize the effects of this bug and are working on a proper fix.


NOTE: Lighthouse should receive the firmware update as part of the downloads. You don’t need to do anything to have it updated. If you can’t wait for the update, you can use the download link and flash manually.

1 Like

Lighthouse 2.2.000 automatically loaded into my Lighthouse (which was running 2.1.003).

All looks fine - - I am seeing 4 carousels instead of 5, and my Monitoring ID code has changed. I also see the Status page is working fine again. Merry Christmas :evergreen_tree: all you Outerneters. Ken

Merry Xmas to you too!

@kenbarbi Thanks a lot for all of your help on this. Glad to see the update worked without issue.

im on 2.2.000 LH and:

-the tunner is randomly disconnect and not get new signal look, i must login and presss “update setting” to get new tune or reboot the LH. status page on situation

-i suppose that the LH its no using external sd storage, since 2.2 update the size has no change , but there is downloads ongoing image

-some old bug , i can not delete old content from gui on non supported languages

log here

feliz navidad :smiley:

You may be seeing an issue I mentioned in the release notes.

I don’t see any mention of any attached storage in the logs.

Can you describe step-by-step what you were doing?

in the image, the LH shows the sd external storage

its this internal storage or external ? im confuse :confused:

internal storage
 9.44 GB of 58.56 GB (49.12 GB free)

df -h

[email protected]:~$ df -h
Filesystem                Size      Used Available Use% Mounted on
devtmpfs                427.7M         0    427.7M   0% /dev
ubi0:rootfs              26.2M     26.2M         0 100% /mnt/rootfs
tmpfs                    80.0M      7.6M     72.4M  10% /mnt/tmpfs
unionfs                  80.0M      7.6M     72.4M  10% /
ubi0:persist              5.6M     56.0K      4.7M   1% /mnt/persist
ubi0:data                 3.3G    197.6M      3.1G   6% /mnt/data
/dev/mmcblk0p1           57.5G      5.5G     49.1G  10% /mnt/data/downloads

That looks about right.

Hey, everyone. I have been a bit busy lately, but am back in the Outernet again!

I just loaded 2.2.000 from scratch on a Pi2.

  • initial boot gave me an error 500 when trying to connect to the web interface.
  • I watched the initial boot on a monitor, and it looked normal, although I may have missed something.
  • after I could not access the web interface, I rebooted the Pi. Same result - no web interface.
  • I recalled an older post about booting with no Ethernet cable connected, so I tried that. I let the Pi boot fully with no Ethernet cable.
  • once I connected to the lan after the boot, then the initial Outernet config screen came up. All looks OK now.

One of the first files I saw was outernet-rx-2.3.000. I am I on an old version already? I had not seen anything about 2.3.


Ooops - just saw the 2.3 release. Will give that a go right now …

We released 2.3.000 an hour or so ago. It probably fixed the issue that lead to 500 page on your first attempt.

Am now on 2.3

Just tried it with the same result. The initial access to the web interface after a fresh start (fresh install on an SD card on a Pi2), on the initial boot, resulted in the ‘500’ error. This time all I did was disconnect the lan cable, and plug it back in and it was fine.

After that , I ran through all the initial setup stuff and am receiving files.

It looks like an issue with the first initialization of the LAN interface.

This looks pretty repeatable - should I re-do the initial SD setup again and send some log files?

FYI, 500 error page is a misleading pain in the behind that we still haven’t fixed. It only means that the application hasn’t started (yet), and on first boot it may actually take up to sevral minutes. I would advise that you reflash a new card and leave it to boot for a while. If it fails to boot into a completely functional web GUI, then we have a problem.

Ok - let me give that a try …

It came up with the web GUI pretty fast that time - no intervention on my part (no LAN disconnecting or rebooting).

Booted with LAN cable, tuner plugged in. I may have given it a couple more minutes to boot …

Looks good so far …