Hotfix firmware 2.6.1 for Lighthouse and ORx

Hello everyone. We have released a small 2.6.1 hotfix update for Lighthouse and ORx last night. It fixes and issue where Library view fails to update after removing and reattaching external storage.

Lighthouses should update atuomatically but if you are in a hurry, you can download the new firmware here:

ORx users (including DIY kit) can download the new firmware here:

I noticed a 2.7a3 Lighthouse version in the Drop Box you put up at the same time as the 2.6.1. Should we try that one? Ken

2.7a3 is completely experimental. It has some dramatic changes, and even more dramatic ones coming in the next releases. This is a much bumpier ride than the previous snapshots. If you really want to try, sure, I won’t stop you. Just be warned that it’s not too stable. :smile:

Good advice! I’ll wait for the more daring to try it :wink:

If you’re just curious about what changes it includes, you can use the Pi version. 2.7a4 is the latest with the same features. Of course, use a different card for it instead of updating your existing one. :smile:

I gave the 2.7a4 a try because I like living on the edge (Desktop runs SID). Anyways, I noticed that the data is now saved in to a data.img file instead of the whole drive. That is ok, but for some reason the drive is only 512mb. I guess that is to encourage people to use external storage… But this doesn’t seem to utilize the whole drive like it did before, is there any way to expand that virtual partition?.

Anyways, today I will install the ORxPi and attach it to this kickstarter board that I backed:

I will see how ORxPI handles the 120gb mSATA drive. I think if this works, it could be a good addition to the Outernet ecosystem now that the bandwidth it is being fully utilized by downloading all the khan things.

The data.img is 512MB because it is only meant to store databases and settings. Downloads are stored in the DOWNLOADS folder on the SD card itself. However, if the storage stats in the settings section are showing you only have 512MB on internal drive, that would be a bug. It should show the SD card capacity.

Yes is only showing 512mb, but good to know the intended purpose is to store the data on the main drive as it did before.

Is the raspberry pi version 1 still supported?
When doing a fresh image install on SD-card with version and unzipping files from to the SD-card, the raspberry boots up but the web interface never becomes ready.
Yes, I have used image 2.5.3 earlier and it worked.
Yes, I have tried restarting the rasbpi.
Logfiles are here:
I use Win32diskimager to write image to SD card (32GB card) and 7zip to unzip files to SD card root after image write.
What am I doing wrong?

If you used the same SD card you used for 2.5, then the partition to which you copied the 2.6 image would be too small to accomodate the software. You need to remove the partitions created by 2.5 and reformat the SD card. (Or use a new SD card.)

The options as I see it are that either I burn 2.5.3 image to the SD card and then directly copy the 2.6.1 files without using the SD card in the raspberry in between,
or I burn 2.5.3 image to the SD card, boot it up in the raspberry and after that I copy the 2.6.1 files to the SD card…
Which method should be used? Is there another way to do it?
The wiki is a bit short on the subject…

To update ORxPi, including the Outernet receiver DIY kit, download and unpack the Raspberry Pi2 or Raspberry Pi1 image zip file to the SD card.

EDIT: ok, so I should delete the partition, partition the SD card to the full size and format it to FAT32, extract the files from 2.6.1 zipfile to SD-card and it should boot the raspberry?
EDIT2: started up fine now. I used SD Card Formatter v4.0 to make SD card just one big partition. Unzipped the to SD card and now it works. Tnx a lot :slight_smile:

Glad it worked and sorry about the confusion. We changed the image format completely with 2.6 because some folks were having trouble dealing with writing the image.

What format does the SD card need to be? Is FAT32 required, or is the default exFAT for large SD cards acceptable?

I’m pretty sure exFAT isn’t supported in any scenario.

1 Like

Thanks, @branko. I expected as much.