Lighthouse ip static


#1

as you configure static IP on port LAN?
ip 10.10.1.1 possible?
thank you


#2

Network configuration is currently only possible through an XML file located in /mnt/persist/config.xml. The format should be self-explanatory, but let us know if you run into issues. The <mode> field does not need to be changed. It is updated automatically by the networking script. You do need to change <conf> to ‘static’.


#3

as you enter telnet?, root?
with username, password initially set does not work


#4

SSH or serial connections should work. Username and password are both outernet.


#5

http://librarian.outernet/en/

http://librarian.outernet/en/login/?next=%2Fdashboard%2F

username=lucio
password=123456
access OK


linux terminal

ssh [email protected]
The authenticity of host ‘192.168.0.1 (192.168.0.1)’ can’t be established.
RSA key fingerprint is 4f:57:6c:43:90:f2:2f:fd:de:5c:79:9d:3a:d5:9b:17.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added ‘192.168.0.1’ (RSA) to the list of known hosts.
[email protected]’s password: 123456
Permission denied, please try again.


#6

SSH password and username are (currently) not related to web interface password. For SSH, use outernet as username and password.


#7

This is the files, but how to change it?

<conf>dhcp</conf>
 <address/>
 <netmask/>
<gateway/>
<dns/>




<conf>static</conf>
<address>10.1.1.10   <address/>
<netmask/>255.255.0.0   <netmask/>
<gateway/>
<dns/>

I tried this, but I can not save the files has


#8

Try this:

<?xml version="1.0"?>
<config>
  <version>1</version>
  <network>
    <mode>connected</mode>
    <conf>static</conf>
    <address>10.1.1.10</address>
    <netmask>255.255.0.0</netmask>
    <gateway>10.1.1.1</gateway>
    <dns>10.1.1.1</dns>
  </network>
</config>

I’m assuming 10.1.1.1 is the address of your router, but change that to whatever the actual address of your router is.


#9

password=outernet
group root
scp: /mnt/persist/config.xml: Permission denied
group config

password group config ??

you can not write the file


#10

Not sure what these refer to.

You can write to file, but you cannot transfer it using scp using outernet user. You would need to copy it to outernet user’s home directory, and then copy using sudo.


#11

I do not understand how …
which command

Terminal
ssh [email protected]

vi /mnt/persist/config.xml

save : Permission denied


#12

You need to use sudo vi /mnt/persist/config.xml.


#13

thank you


#14

How do you gain root access to Outernet Lighthouse? I checked and found that port for ssh (22) is closed. Can we somehow open it?
Also, is there some method to gain root access using serial cable? If yes, please explain.

Thanks


#15

Login is outernet:outernet. Are you absolutely sure SSH is not available? It comes standard with Lighthouses. Maybe it’s a wrong IP or some issue with the device?


#16

I checked using fing and nmap. The only open ports are 53 and 80


#17

That is odd. Are you able to use the GUI? If so, can you go into the settings section and get the system log, and post it somewhere so I can take a look?


#18

Please find the log at http://pastebin.com/8XZ0uUfb

I get a connection refused error

ssh [email protected]
ssh: connect to host 192.168.0.1 port 22: Connection refused


#19

Have you tried restarting the device?


#20

Yes. It does not help.