Lighthouse ip static

as you configure static IP on port LAN?
ip possible?
thank you

Network configuration is currently only possible through an XML file located in /mnt/persist/config.xml. The format should be self-explanatory, but let us know if you run into issues. The <mode> field does not need to be changed. It is updated automatically by the networking script. You do need to change <conf> to ‘static’.

1 Like

as you enter telnet?, root?
with username, password initially set does not work

SSH or serial connections should work. Username and password are both outernet.



access OK

linux terminal

ssh [email protected]
The authenticity of host ‘ (’ can’t be established.
RSA key fingerprint is 4f:57:6c:43:90:f2:2f:fd:de:5c:79:9d:3a:d5:9b:17.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added ‘’ (RSA) to the list of known hosts.
[email protected]’s password: 123456
Permission denied, please try again.

SSH password and username are (currently) not related to web interface password. For SSH, use outernet as username and password.

This is the files, but how to change it?


<address>   <address/>
<netmask/>   <netmask/>

I tried this, but I can not save the files has

Try this:

<?xml version="1.0"?>

I’m assuming is the address of your router, but change that to whatever the actual address of your router is.

group root
scp: /mnt/persist/config.xml: Permission denied
group config

password group config ??

you can not write the file

Not sure what these refer to.

You can write to file, but you cannot transfer it using scp using outernet user. You would need to copy it to outernet user’s home directory, and then copy using sudo.

I do not understand how …
which command

ssh [email protected]

vi /mnt/persist/config.xml

save : Permission denied

You need to use sudo vi /mnt/persist/config.xml.

thank you

How do you gain root access to Outernet Lighthouse? I checked and found that port for ssh (22) is closed. Can we somehow open it?
Also, is there some method to gain root access using serial cable? If yes, please explain.


Login is outernet:outernet. Are you absolutely sure SSH is not available? It comes standard with Lighthouses. Maybe it’s a wrong IP or some issue with the device?

I checked using fing and nmap. The only open ports are 53 and 80

That is odd. Are you able to use the GUI? If so, can you go into the settings section and get the system log, and post it somewhere so I can take a look?

Please find the log at

I get a connection refused error

ssh [email protected]
ssh: connect to host port 22: Connection refused

Have you tried restarting the device?

Yes. It does not help.