Lighthouse & ORx development snapshots 2.0.003


#1

Instructions and warnings are the same as before.

Following fixes are in this snapshot:

  • Fixed diagnostics not including FSAL logs
  • No longer mounting boot partition reducing chances of it becoming currupted when diconnecting power (ORx)
  • Reduced logs and no longer logging raw ONDD IPC calls
  • Removed hostname matching code so you will no longer see related errors in the logs

Still not confirmed:

  • ethernet not starting
  • ethernet not working when when WiFi is active

#2

It works now. First time that I read nicely edited articles with pictures (UNHCR, Wikinews and Malawi)! Config: Geniatech, 80cm-dish, RPI1. Will report more tomorrow.
Good work, Branko!


#3

Don’t think the WiFi and ethernet issues are relevent to Lighthouse Version 2.0.003, but they are working fine on my Lighthouse connected thru Galaxy 19. Ken


#4

Yes. I did several restarts. Every time I got the tuner LOCK successfully. Further I checked the SD card with my Windows PC. No complains about fixing for errors.

Success:
When HDStar tuner attached with LOCK state, WiFi hotplug works and not affected with the tuner LOCK

Failure:
WiFi hotspot gets disabled when HDStar tuner is hotplugged and also unpluuged (sometimes) from the Pi

NOTE: Still not tested with LAN


#5

Do you have HDMI out? If so, can you watch that while plugging in the tuner and tell me if you see a bunch of i2c-related errors pass by when you plug it in?


#6

Yeah. I have HDMI TV. Will check. :slight_smile:


#7

Can’t get the HDStar tuner LOCK when HDMI is connected. I have SAMSUNG LED TV. Here is the TV screen.


#8

What exactly do you mean by that?


#9

LED indicated green not red

Sorry. I just restarted the receiver with HDMI monitor connected. Got the tuner LOCK. But same screen output.


#10

So if I understood correctly, you:

  1. connected HDMI
  2. connected WiFi dongle
  3. started the system
  4. connected tuner

WiFi stopped working after that but no new output on the screen and the Pi did not crash?


#11

Oh. Sorry, I checked HDStar’s behavior. :innocent:

For WiFi, got the same screen output.


#12

So now I’m not sure what’s going on anymore. Iirc, the original problem was that you’d loose wifi connectivity when HDstar is plugged in. Is that still the case?


#13

yeah. is this a power related problem? shall I test this with a powered usb hub?


#14

GIve that kernel doesn’t say anything, yeah, please check that if you can.


#15

Yeah. Kernel is not saying anything. I unplugged and plugged the WiFi adapter again. but screen remains same. no any updates. seems it gets halted.

This is my WiFi adapter.


#16

I’ve got the same dongle, so I’ll give it a try later.


#17

Also Pi’s green led is steady.


#18

Yeah, I’m not 100% sure what that means. I know that it’s not a good thing before it boots. Once it’s booted, though, I haven’t noticed anythig wong happening when green LED is permanently on.


#19

http://elinux.org/R-Pi_Troubleshooting

Search this topic
Red power LED is on, green LED does not flash, nothing on display


#20

I thought you had output on display?