New ORx image for Raspberry Pi

Hello everyone!

Thank you for bearing with us, and sorry for the long wait. We have finally finished the new Raspberry Pi image. Currently, this image only supports Raspberry Pi v1. Support for v2 is in the pipeline.


The files and instructions posted here come with no warranty. You use them at your own risk. Outernet will only provide support as time allows, via this forum or GitHub issue tracker.

Support for new Outernet stream

As mentioned in one of my previous posts, Outernet data stream has been changed in a backwards-incompatible way, making all previous Raspberry Pi builds obsolete. The new image supports the new stream format.

Reduced image size and simplified updates

The new image contains a single 40MB FAT32 partition containing the kernel image. This has several important consequences:

  • Faster download
  • No more minimum card size requirement
  • Updating the entire system is as simple as dropping the new kernel image into the first partition (usually visible to your computer) without having to write the whole image again
  • More space for storage

Despite the size, the ORx system will automatically expand to take up the entire card on first boot, so no space is wasted. You can use as large a card as you wish to increase the storage capacity.

Downside is that the kernel and root filesystem needed to be slimmed down to bare essentials. There is no package system, no build tools, etc. In other words, the system is no longer as easily customizable as before.

Setup wizard

On first boot, you will see the new setup wizard, which will guide you through basic system setup, including administrator account creation and tuner settings.

No more TVHeadend

The new image includes a version of Librarian that provides the tuner configuration interface with convenient presets for our existing transponders and C-band support (China).

Enhanced hardware support

The new image includes drivers and firmware for several satellite tuners and wifi devices.

Image incldues the drivers for the following DVB tuners:

  • Pinnacle PCTV USB 2.0 DVB-S/S2
  • Geniatech HDStar
  • Pinnacle 400e USB 2.0 DVB-S
  • Opera USB 2.0 DVB-S
  • DVBWorld USB 2.0 DVB-S
  • TeVii USB 2.0 DVB-S/S2
  • Prof USB 2.0 DVB-S/S2
  • Azurewave AZ6027 USB 2.0 DVB-S/S2
  • Technisat USB 2.0 DVB-S/S2
  • DVBSky USB 2.0 DVB-S

Please note that we do not have the ability to obtain and/or test all those devices. The devices we have tested are:

  • Pinnacle PCTV 461e*
  • Geniatech HDStar SU3000 v3.0

We would appreciate information about any working or non-working hardware you run into.

[*] PCTV 461e may have issues on model B (not model B+)

Drivers for the following USB wifi chipsets are included:

  • Realtek 8187
  • Realtek 8187B
  • Realtek 8192C
  • Realtek 8712U
  • Realtek 8712SU
  • Realtek 8188EU
  • Atheros AR5008
  • Atheros AR5523
  • Atheros AR6003
  • Atheros AR6004
  • Atheros AR9001
  • Atheros AR9002
  • Atheros HTC (AR9271)
  • Atheros AR1000 family (IEEE 802.11ac)
  • Qualcomm Atheros WCN3660 and WCN3680
  • Ralink rt2500
  • Ralink rt2501
  • Ralink rt27xx
  • Ralink rt28xx
  • Ralink rt29xx
  • Ralink rt33xx
  • Ralink rt3573
  • Ralink rt53xx
  • Ralink rt28xx with unknown chipset
  • Ralink rt8192e

As with DVB equipment, we could not test all supported chipsets. Here is a list of devices we have tested, and the results of testing:

  • Tenda W311MI (Ralink 5370 chipset), works with AP mode
  • TP-Link TL-WN722M (Atheros AR9271 rev2 chipset), works with AP mode
  • Edimax EW-7188Un (Realtek 8192CU chipset), works, but AP operation unreliable
  • No name Realtek 8188E chipset, does not work as AP

Again, information about working and non-working hardware is appreciated.


Creating the SD card

For now, please follow the instructions found here (skip Obtaining the image file section). We will update the instructions in the coming weeks.

SSH credentials

The username and password for SSH access are both outernet. Currently, the password cannot be changed (it will be reset on boot).

Known issues

  • Currently, IS10 cannot be used with this image.
  • PCTV 461e may have issues receiving on model B (currently looking into the issue)
  • Booting with PCTV connected results in kernel error on model B (not model B+, workaround: connect PCTV after boot)
  • Wired network configuration fails on boot on model B (workaround: manual network configuration)

What about Raspbian and Arch Linux ARM?

This image marks the end of support for Raspbian and Arch Linux ARM distributions for Raspberry Pi. Having said that, if anyone wants to continue using these distributions (or any other distribution on Raspberry Pi), we are available on this forum to answer questions and provide assistance.

Where are the sources?

The sources are currently being cleaned up and documented. Once that is complete, they will be published online.

1 Like

Hello, I tried the new image on a v1 Raspberry Pi tonight and it showed a color gradient then got some standard linux boot messages. Eventually I got the error message “Unable to handle kernel NULL pointer dereference at virtual address 00000000” followed by “pgd = d37b4000”. I tried to upload a picture of the text but I am unable to yet.

FYI - I am using a PCTV 461e.

If you don’t mind, could you try the following for us?

  1. first reproduce the above issue
  2. reboot RPi with PCTV disconnected and copy /var/log/messages and paste it on or similar site
  3. with RPi fully booted, connect the tuner (give it a few seconds to initialize, and the relevant services should be restarted automatically)

I seem to recall issues with booting RPi with PCTV connected, but I forgot the details. I’ll have to recheck again, though I’m not going to have access to my equipment for a couple of days so Monday or Tuesday.

Also, this may sound trivial, but please make sure PCTV is connected to its own power supply.

Dear Branko,
I made a short try with your new system.
It seems, it is working for me: in this time I dont connected any pisitioned dish to the DVB-S2 receiver.
The main infos about the working state following here: (I use the outernet/outhernet authentication on ssh )
In the module list it seems, all the moudules loaded, I dont use this time any wifi devices
In the /dev there is the working frontend
In the procress list apperead the key programs.
My question is: need I starts any more progream to receive the data, or if it boot correctly, is it start to receive the data?
Best: t.janos
My RPi is version 1, modell B, and the DVB-S2 receiver is the Pinnacle usb device.

[email protected]:/tj/orxpi# file ORxPi*
ORxPi-0.2.2.img: x86 boot sector; partition 1: ID=0xc, starthead 0, startsector 1, 78125 sectors, code offset 0xb8

ORxPi v0.2.2 | [email protected]:/usr/sbin> lsmod
Module Size Used by Not tainted
rc_pinnacle_pctv_hd 710 0
em28xx_rc 7457 0
rc_core 14671 3 rc_pinnacle_pctv_hd,em28xx_rc
a8293 1243 1
m88ts2022 4417 1
regmap_i2c 1956 1 m88ts2022
m88ds3103 10455 1
em28xx_dvb 18457 2
dvb_core 61114 2 m88ds3103,em28xx_dvb
em28xx 58712 2 em28xx_rc,em28xx_dvb
tveeprom 11639 1 em28xx
v4l2_common 3623 1 em28xx
videodev 107621 2 em28xx,v4l2_common
media 10631 1 videodev
spi_bcm2708 4630 0
i2c_bcm2708 4639 0

ORxPi v0.2.2 | [email protected]:/dev/dvb/adapter0> ls -l
total 0
crw-rw---- 1 root video 212, 4 Jan 1 1970 demux0
crw-rw---- 1 root video 212, 5 Jan 1 1970 dvr0
crw-rw---- 1 root video 212, 3 Jan 1 1970 frontend0

ORxPi v0.2.2 | [email protected]:/usr/sbin> ps x
1 root init
2 root [kthreadd]
3 root [ksoftirqd/0]
5 root [kworker/0:0H]
6 root [kworker/u2:0]
7 root [khelper]
8 root [kdevtmpfs]
9 root [perf]
10 root [khungtaskd]
11 root [writeback]
12 root [crypto]
13 root [bioset]
14 root [kblockd]
15 root [cfg80211]
16 root [kworker/0:1]
17 root [rpciod]
19 root [kswapd0]
20 root [fsnotify_mark]
21 root [nfsiod]
38 root [VCHIQ-0]
39 root [VCHIQr-0]
40 root [VCHIQs-0]
41 root [dwc_otg]
42 root [DWC Notificatio]
44 root [deferwq]
45 root [kworker/u2:2]
52 root [kworker/0:2]
64 root [mmcqd/0]
68 root [kworker/0:1H]
71 root [jbd2/mmcblk0p4-]
72 root [ext4-rsv-conver]
85 root /sbin/syslogd -n
88 root /sbin/klogd -n
89 root /sbin/udevd -d
107 root [bcm2708_spi.0]
118 root watchdog -t 5 /dev/watchdog
144 dbus dbus-daemon --system
178 root /usr/sbin/ondd -d --pid-file /var/run/ -o /mnt/data/down
179 root [kdvb-ad-0-fe-0]
188 root udhcpc -R -n -p /var/run/ -i eth0
207 root /usr/sbin/ifplugd -r /etc/ifplugd.action -i eth0
214 root /usr/sbin/ntpd -g
226 root /usr/sbin/dropbear -w -d /opt/orx/dropbear/dss_host_key -r /opt/
234 nobody /usr/sbin/dnsmasq -C /opt/orx/dnsmasq.conf
251 root python -m
252 root /sbin/getty -L console 0 vt100
271 root /usr/sbin/dropbear -w -d /opt/orx/dropbear/dss_host_key -r /opt/
272 outernet -ash
280 root sh
295 root [kworker/0:0]
300 root ps x

Ok, I prepared now the coax cable to the dish, and connected it. I found the next step on the web interface, filled the Setup fields, and now it seems, it is ready to receive something…
I found the new dashboard interface. I can say, it was confortable for me to follow the state of the download channel on the tvheadend tools: the signal strenghts, the error rates, the used bandwiths, and so.
This new is more “user-freinedly”, maybe can find something similar display tool to follow the receive process on low level.

I found the new log files too, here are the last lines of my running system. It seems, there is a time-sync error (?)

Jun 5 10:06:43 orxpi authpriv.warn dropbear[252]: lastlog_perform_login: Couldn’t stat /var/log/lastlog: No such file or directory
Jun 5 10:06:43 orxpi authpriv.warn dropbear[252]: lastlog_openseek: /var/log/lastlog is not a file or directory!
Jun 5 10:08:48 orxpi ondd[178]: [main] tuning to 1721 Mhz 27500 KSym
Jun 5 10:08:53 orxpi user.warn ondd[178]: [main] timed out waiting for PMT
Jun 5 10:16:50 orxpi ntpd[214]: kernel reports TIME_ERROR: 0x41: pll unsync Resource temporarily unavailable
Jun 5 10:17:53 orxpi daemon.notice ntpd[214]: frequency error 92929 PPM exceeds tolerance 500 PPM

librarian log:
[2015-06-05 11:39:12 (+0000)] DEBUG ONDD: sending payload:
[2015-06-05 11:39:12 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>yes760.00
[2015-06-05 11:39:16 (+0000)] DEBUG ONDD: sending payload:
[2015-06-05 11:39:16 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>yes760.00

Next question:
Are there any safe shutdown command?

Branko, thank you for the suggestions. I tried booting the Pi without the tuner card plugged in and got through the wizard without any issues. I then plugged in the PCTV card (yes, external power) and rebooted with no issues. I am plugged into a dish now too.

My problem now is that while the librarian.log shows my signal is 100 (I spent some time aiming the dish until is showed 100), but there is no lock. I am not certain if my LNB is Universal or “North American KU Band” but I have tried both with no difference. I am in North America (Maine) and pointing to Galaxy 19.

Some logs:
librarian.log -
[2015-06-06 02:10:18 (+0000)] DEBUG ONDD: received data: <?xml version="1.0" encoding="UTF-8"?>no1000.00
[2015-06-06 02:10:23 (+0000)] DEBUG ONDD: sending payload: @

dmesg | grep
ORxPi v0.2.2 | [email protected]:~> dmesg |grep em28xx
[ 28.911541] em28xx: New device PCTV PCTV 461 @ 480 Mbps (2013:0258, interface 0, class 0)
[ 28.916447] em28xx: DVB interface 0 found: isoc
[ 28.919079] em28xx: chip ID is em28178
[ 29.426300] usbcore: registered new interface driver em28xx
[ 29.810445] em28xx: Registered (Em28xx dvb Extension) extension
[ 29.963436] input: em28xx IR (em28178 #0) as /devices/platform/bcm2708_usb/usb1/1-1/1-1.3/rc/rc0/input0
[ 29.984046] rc0: em28xx IR (em28178 #0) as /devices/platform/bcm2708_usb/usb1/1-1/1-1.3/rc/rc0
[ 30.012466] em28xx: Registered (Em28xx Input Extension) extension

I’m not sure what to try next. Suggestions?

tjanos - I see that ‘shutdown’ is not an available command. ‘reboot’ will make the system go down gracefully and then you can remove power once the link on the ethernet is lost.


Is your Pi connected to Internet? If not, this is normal. ONDD will set the time itself using signaling data.

Not right now. It may be present in the dashboard in the next release (v0.3, ETA Jul 7) if we are able to squeeze it in. Otherwise, we are postponing for v0.4.

I’ve observed the same on RPi model B (without plus). I’ll look into it as soon as I have access to my equipment again. Not sure what it could be.

Branko, do you have any other suggestions for me to try? Is there any other log output or commands you would suggest I run to determine the problem? I am a sysadmin so speak frankly and I’ll do my best to help troubleshoot.


Does this image support the new outernet tuner? And does it have the Rachel archive on it?

Sorry, no break on tuning using this image on model B yet. There’s a new image I’ll be releasing soon, but it has nothing specific to this issue. Perhaps you could still try it. I’ll post in this forum as soon as the image is uploaded.

I’m not sure what you mean by ‘new Outernet tuner’. If you mean the one from the store, it’s identical to Geniatech HDStar (SU3000 v3.0) for all practical purposes, and this image supports it (the kit does include a card with the image and preloaded content, though).

This image does not and will not contain any content, since that would make the image huge (there’s over 30GB or Rachel content). It contains the base system and drivers, and software for consuming the content. I’ll see if the Rachel content packaged for Outernet can be released via a torrent or something like that.

Thank you for clearing that up. The store is long on hype and short on tech details. Having the big data payloads such as the rachel archive available via torrent or other P2P mechanism would be a great idea. I know from other comments, a number of people would find this useful.

We’ll work on improving it.

Ok. We’ll see what the options are.

Branko, I just downloaded and installed your new ORx image for Raspberry Pi and PCTV 461E after returning from England, and connected to Galaxy 19 here in Washington, DC. I received 18 messages! Things seem to be working here now.

Now my next question is: how often do you send updates? My Dashboard looks as follows:

I have lock and get varying bit rates, but nothing else after the green “Has Lock” box. I did not watch the system overnight, but this morning found 18 updates for June 2015, so suspect they were sent during the night. In otherwords, I don’t expect to see a constant stream of messages - - but will receive them when you put them up. Is my understanding correct? Ken

That’s correct.

We currently don’t have a regular schedule for broadcasting new content. This may change soon, though, so I’ll keep you posted.

I have been running my Raspberry Pi/PCTV461e system for the last 3 days and have downloaded 186 Deutsche Welle news articles. They generally arrive on Galaxy 19 between1100 GMT to 1400 GMT.

However, I have noticed after about 4 hours of reception, my system loses LOCK and LOCK does not return unless I power down and reboot. This always restores LOCK for approximately another 4 hours.

Has anyone else notice this type of behavior and have a cure? Ken