New sd card does not write

I installed a new harddrive
result = 8 hours left

Content library is currently empty
There are no sites in the library.
No apps found.

I put on my computer Hard Disk EXT_STORE
result =

EXT_STORE/downloads/content
398 files 87.3 Mb
type files 1ac6fd3d3a96f37bc3c339546ee2c5cf.zip

EXT_STORE/downloads/files/Lake of Stars/Konkolozi
Konkolozi - Track 3.mp3

EXT_STORE/downloads/files/database_backups
db_backup_2015-10-25_20-26-37.sqlite

I received the new firmware version: 0.4.post8 / Lighthouse 1.4.201

with the new card does not work

I am past 72 hours

[2015-11-15 09:52:27 (+0000)] INFO added 722eb9d8db683c6dfb4bab9b940279dc to library
[2015-11-15 09:52:27 (+0000)] DEBUG Deletion of ‘722eb9d8db683c6dfb4bab9b940279dc’ failed: ‘[Errno 2] No such file or directory: ‘/mnt/data/librarian/zipballs/722/eb9/d8d/b68/3c6/dfb/4ba/b9b/940/279/dc’’
[2015-11-15 09:52:27 (+0000)] DEBUG Extraction of ‘/mnt/data/downloads/content/722eb9d8db683c6dfb4bab9b940279dc.zip’ failed: ‘[Errno 1] Operation not permitted’

no longer receives new content even with the original memory.

I assume you are using FAT32 external storage. This issue has been reported by others as well, and I think I’ve finally found out what causes it. I’m testing a fix right now, and will create a patch for the existing release tomorrow.

thank you

I didn’t announce it, but update is now OTA for Lighthouses. For ORx, I’m just finishing the updated build. I will announce it in the forum when it’s ready.

If you are using Lighthouse and can’t wait for OTA update, you can grab the new firmware here:

https://archive.outernet.is/images/Lighthouse/1.4.300/

Copy the .pkg file to USB stick, rename it to wt200.pkg, and plug it in.

I updated Lighthouse with version 1.4.300.
I formatted again sdcard.
Now add the content, but in all languages.
It is a problem because I can not choose, so the card is filled immediately with files that do not serve me.

I would like to add content only in Italian.

That’s on our roadmap, but I’m pretty certain we don’t have any content in Italian right now.

There are contained in Italian language unknown.
This also applies to French, Chinese, German and so on.

it is important to choose the language, now it’s all confused

Lighhouse with hard drive and new .300 version still not working correctly.

My Lighhouse auto updated to the new .300 version, and allowed the transfer of files from the Lighhouse to the hard drive, but would not run the Outernet WiFi hotspot. I unplugged the device and repowered it several times. All three lights were on (in the Lighthouse), and I used a powered hub each try. I tried to run up on all the USB ports, but they all had the same problem.

Perhaps I should give the system more than 15 minutes to run up each try? Comments - - Ken

I formatted sd card and began to work properly.
Now I feel even with hard drives.

I’ll try an SD card and a USB stick to see what happens. By the way, the hard drive only had the downloads, ondd, and Librarian folders copied, but they had no content in them. I’ll report back on the SD card and USB stick in a while. Ken

On Lighthouse as of 1.4.300, when you plug in the external storage, it does not copy over anything.

So are you saying that WiFi hotspot is not activated in general using 1.4.300, or only when external storage is plugged in?

I upgraded version 1.4.300 Lighthouse.
sd card is not working.
I formatted again, now works
I connected hard drive and not working.
I formatted the new hard drive 120GB.
now it works perfectly

you must update after the fact reformat sdcard / hard drive.

Both the USB stick and an SD card both start up fine. Each has to be tuned to my satellite before they start receiving traffic. Neither one copies the original data from the Lighthouse to the new storage device - - as you say.

That all said, my 500 GB hard drive does get all the appropriate directories copied onto it, but my Lighthouse won’t start. By that I mean, my satellite lock light blinks (rather than stays on solid) and the WiFi HotSpot does not start up, so I can’t see what’s going on inside the Lighthouse with my Putty program.

Perhaps I should try another hard drive? Ken

By the way, I should mention my 500 GB hard drive gets its power thru the USB plug rather than having a separate power source as the really big hard drives have. Puzzling??? Ken

Lighthouse perhaps not feed it properly.
test with external power supply.

I will try that. My other hard drives (1 - 2 TB) with external power have stuff on them and are NTFS formatted, so I will look for a blank one to work with. All my small hard drives (less than 1 TB) self power from the USB ports. Thanks for the hint. Ken

I’ve tested external storage with a 500GB USB-powered drive, and it was working fine. LH is also able to charge most phones, so it’s USB ports seem to provide enough juice to connected devices (unlike RPi).

To confirm, this only happens with external USB-powered hard drive?

EDIT: Also remembered something form the Pi days. If you have a powered USB hub, you could try connecting the disk using that. If that works, then yeah, it’s probably a power issue.

1 Like

That’s correct, Branko. I only have 1 hard drive to test with - - all my other hard drives contain files in NTFS format.

I’m going to reformat my test hard drive again (in FFAT32) and hook it up again in the house where I can connect a monitor and keyboard to the LH and see what’s happening. As I mentioned before, the LH (as opposed to the ORxPi configuration) can receive Outernet data 100 meters away in my house from my satellite antenna. But to do that, I have to take the DiSEqC and antenna motor out of the path from the LNB.

I’ll run the test and wait longer before I remove the hard drive and see what gets copied to it. Then I’ll report back. If their is some file I should look at during this process, please let me know so I can copy it for you. Ken