ORxPi v0.2.7 released


#1

The updated image is now available for your ORxPi receiver (including the DIY receiver kit).

The new firmware features Librarian interface v0.4.post4, with the following fixes since last release:

  • Updates to Spanish and Catalan translations
  • Fixes related to associating with access point using Windows or iOS devices
  • Minor layout fixes for iOS devices
  • Diagnostics page that appears at /diag/ URL while setup wizard is active
  • Fix for tuning with NA Ku and C band LNB which disables tone in the presets (prevents interference with exotic setups)
  • Download progress bar which shows file download progress in real time
  • Fixes related to searching with non-English characters in the search bar
  • Adds confirmation to file deletion in the file manager
  • Fixes issues with script execution in the file manager

The images can be obtained from: http://archive.outernet.is/images/ORxPi/0.2.7/

Please refer to instructions for updating your existing build or creating a new SD card.


#2

Cool. Look forward to trying it. Pity I’m on the opposite side of the world to my rig right now!


#3

Does this version come with rpi2 support yet? I found a way to compile a 0.2.5 orx install on the rpi2, but I don’t know how to update it, and it doesn’t work very well… (no wifi is working right now)


#4

Did you modify the code we published, or something else?


#5

I didn’t modify any code, just how it was configured in menuconfig.

  1. I compiled the toolchain
  2. I downloaded the latest buildroot and rpi-linux
  3. I ran make menuconfig
    3a. I loaded the orx_defconfig as the config
    3b. I enabled uboot and the corresponding options in Bootloaders (build system = legacy, board name = rpi_2, uboot version = 2015.7)
    3c. (a bug in the menuconfig for rpi2 builds) you absolutely HAVE to enable RPC support and have your current gcc version selected to be able to build it
  4. I saved it as .config in the buildroot directory
  5. I ran make B=rpi2
  6. After that was done, I ran make image
  7. NOTE: errors were encountered and the .img build failed. I don’t know how I thought of this, but I proceeded to copy all of the FILES in the orx_rpi/output/images/ to an empty Fat32 micro SD card. (this includes the files in the rpi_firmware folder but not the folder itself. Also note, the overlays folder is not needed.)
  8. Finally, I made 2 more changes.
    8a. Remember the kernel? Well, I copied the kernel7.img from the raspbian wheezy image to this one and changed kernel=zImage to kernel=kernel7.img
    8b. There is a commented option about initramfs. I uncommented it.

This made all of the functions work EXCEPT the access point (the nl80211 driver wasn’t initialized or something weird like that…). The web-server works via Ethernet connection if you connect to the ip address.

On a side note, can you make the new source available on github? I would be happy to continue testing the source in my raspberry pi 2b!


#6

I got a bit lazy and the make image requires sudo (direct access to loop devices).

Yeah, I probably forgot to push. Will take care of it in a few minutes.


#7

You guys should start supporting the orx-install repo again because people can get it to install on the raspberry pi2(b). I just don’t know how to get tvheadend to work (there are no good tutorials for it and it’s not user friendly enough).


#8

TVHeadend is no longer needed. As for orx-install, we’ll consider it, though I think we’ll get RPi2 support going before we revert to the install script.


#9

I tried the new ORxPiv0.2.7 on my system and it does not work. I get the Outernet WiFi, but cannot connect to the Librarian. The micro SD chip looks fine with all the MS level files to include the ZImage, but does not boot the Pi.

I’ve restorted the old v0.2.4 and my system works fine. Ken


#10

Could you explain a little more, what did you make with the new ORxPiv0.2.7? What this mean: “I get the Outernet WiFI…”?
Did you used the “update” image, or used the new system image to write it based on the wiki,s howto?
I made a new SD card on linux with dd command, put on the ORxPi-0.2.7.img file and it started without any problem. After some minutes it received the first, actually broadcasted files.
Sometimes I have problem with my (cheap) card writer/reader. It has some hw problem with the Lock/write protected switch. It sense the inserted SD card as write protected, and it mounted in read-only mode. If I try to write on such a config with the dd command the image file, it “made”, send a message, that the card is ro mounted, but it didnot write anything to the card. Ofcourse, from such an “update” it canot boot.
t.janos


#11

Lets say I do want to use raspbian… Which packages should I install?

(If this needs a new topic, I will gladly switch.)

Compiling the different packages individually on the system should be eaiser than a kernel.


Raspbian support
#12

I used the Wiki procedure to write a brand new SD micro using the Win32 Disk Imager as usual. This the same procedure I used to create the older OPxPIv0.2.4 SD micro which has worked fine for a long time (with the exception of the change Branko made to the Galaxy 19 transponders). Ken


#13

Forgot to mention - - once the Pi boots up, I use Firefox to navigage to the Outernet WiFi gateway 10.0.0.1. My browser can’t connect to what used to be the Librarian. Ken


#14

How do you know that your RPi dont have boot? If you switch on the power on RPi, do you see something happen on its LEDs?
If I understand well, you dont use ethernet connection, but use the wifi to try to connect into it.
Have you any possibility to connect to the RPi a hdmi monitor and a keyborad, and check on it the boot/init process?


#15

Can you SSH into your Pi? If so, please check that Librarian is running with ps ax | grep python | grep -v grep. If Librarian is not running, the next step would be to run it manually to see what the issue is:

sudo python -m librarian.app --conf /opt/orx/librarian.ini

If it is having problems coming up, it should show some error messages.


#16

branko:

Just repointed my dish (was on a tripod and blew over). I have loaded 0.2.7 and it is working great - downloading files as I write this. As always, the issues are finding the satellite.

Once you have struggled through the process of ensuring you have the correct LNB, the correct skew on the LNB and the antenna pointed in the correct direction, some slow scanning back/forth and up/down on the antenna does the trick. I am still thinking of how to ensure that DIYers have access to some good pointing info, and the correct tools to locate the satellite.

Ok - now, the question. I see that the status pages shows 5 (oops, now 3) active devices. How can I tell if I am one of those devices? I presume I can see something in the logs that shows I am ‘calling home’ to inform you my system is connected.

Cheers,
Brian


#17

You can look at the system log for lines that contain ‘outernet.monitor’.


#18

OK - I see lots of outernet.monitor:connect to socket messages, so it looks like my connection messages are getting through.

Cool!

Cheers,
Brian


#19

Connect to socket messages mean that the monitoring daemon has connected to ONDD socket to collect the data. This happens approximately once every minute. Once every 5 minutes, the daemon will attempt to transmit the collected data. These are usually ‘Transmitting’ messages.


#20

Yes, saw the transmission messages:

Sep 7 22:37:19 orxpi user.info outernet.monitor: Transmitting buffered data
Sep 7 22:37:19 orxpi user.info outernet.monitor: Transmission complete, claring local buffer

Spelling error in the code? Claring for clearing? (there is a correction that should be at the BOTTOM of your code bug list!)

Cheers,
Brian

PS: Keep up the good work!