ORxPi v0.2.8 Testing and Issues

I reformated the hard disk with FAT32. Shut down the Pi and plugged the hard disk into the hub. I re energized the Pi. When the Pi came up, I was asked to reenter the superuser password after which I could go to the Dashboard. When I looked at my files on the Dashboard, I had no updates, apps or downloads, and a message that said I was running low on disk space.

I didn’t see any obvious way to look at the hard drive from the Librarian to search for the files if they had been copied there…

I shut down and removed the hard drive then started the Pi. All the files were back on the Pi. I checked the hard drive to discover all my files had been transferred to it as you see here

I could read all the articles with their relevant graphics in the Library folder.

So bottom line now:

  1. The previously downloaded information was copied to the hard drive.

  2. I could NOT see this information from the Librarian with disk drive connected.

  3. The Librarian responded strangely advising me I was running low on disk space.

  4. With the disk drive removed and the Pi restarted, the Librarian worked as before.

What next?? Ken

With attached storage, please run mount command and tell me what the output is. Also, please email me at apps(at)outernet.is the main.db file on your external storage device if you can.

Is anything coming over 13E right now? I’m set up an pointing but no updates.

We’ve recently discovered a bug in the server that handles constructing the TS. It is possible that something got stuck. Try restarting ONDD by ssh-ing into the box and:

sudo /etc/init.d/S90ondd restart

Are you on a version of Librarian that shows downloads in the settings area? If so, tell me if you see all 4 carousels.

I’m on 0.2.6. Fresh install a few hours ago, usually I see some updates as soon as it gets going…

ORxPi v0.2.6 | [email protected]:~> sudo /etc/init.d/S90ondd restart
Stopping ondd: FAIL
Starting ondd: OK
ORxPi v0.2.6 | [email protected]:~>

FWIW, 0.2.8 still hasn’t killed Ken’s new tuner. :smile:

1 Like

Point taken! I have a copy of 0.2.8 here, I’m gonna go for it…be back in 10 mins!

OK, i’m up on 0.2.8.

I notice a downloads in progress bar (actually, now 2) on my tuner page. Nothing in there yet, so i’m going to make a cup of tea and wait a while!

On edit, still no progress:

The progress bars may take up to 5 minutes to populate (that’s the interval for signaling data transmission, without which the bars can’t be associated with files). If they don’t populate in that time, then something’s probably wrong.

This morning, I’ve only received up to 2 downloads at any one time on Galaxy 19.

This picture shows only 1 at this time, but normally I get 4 downloads coming in. Ken

Yeah, it seems the server is tripping again. Will be fixed some time on Monday.

I have some mp3 tracks coming in now.

I formatted my main SD card, so will it be Monday before I get regular library updates again?

I believe so.

Good - - that gives you a weekend to figure out the hard drive issue :grinning:

Ken

Hopefully, we’ll have that fix early next week.

I left it alone and i’m getting library content now. So 13E is still broadcasting!

This is my gear in my sunny garden!

1 Like

I’ve messed with server parameters a bit. It may get stuck again, so we’ll still look for a permanent solution.

I updated to v0.2.8 seem i have lots of duplicate content in today’s stream. Glitch maybe? Should i go back to the previous version?

Based on what do you come to this conclusion?

When I am in librarian and hit the bottom of the screen click more content it loads most of the same articles with a few new ones. I have attached some screen caps of a search I did for Adolph it found the exact same article twice some time it finds four times.