ORxPi2 2.0.x not booting with tuner attached

This is a thread to collect info on Pi2 not being able to boot with tuner attached.

If you are experiencing this issue, please chime in and share your findings.

In particular:

  • exact tuner version
  • PSU power rating (volts and amps)

If you can connect a HDMI display to your Pi and observe the output while booting with the tuner, that would help us a lot.

SSH port available on my Pi2 - you should still have access.

My tuner was ordered from you guys - the one with the nice plastic Outernet case.

How do I actually determine the tuner version? Is it reported when the tuner is hot-plugged, or do we need to look at the actual tuner PC board?

Are you looking for the Tuner power supply? I am using the one that came with the outernet tuner - 9V, 1.5A.

Impossible on the Pi2 to try to see where the boot process fails. The screen flys by with a couple of pages of test in a couple of seconds, then the screen immediately goes blank when the Pi reboots.

I think I need to pull the power on the Pi just after the boot fails (before it restarts), and look at some log files on the SD card. Can you direct me to the directory where the log files may be?

What is the power rating of the Pi’s own power supply?

Pi is being powered from USB port on PC.

I can dig out a separate 5V power supply and try this in a day or 2. I can certainly find a power supply that has more current capability than a typical USB port. I never thought to check the Pi’s current spec!


Some people say Pi2 required as much as 2A of power (most likely depending on software running on it). It’s possible that at some point during operation, it tries to draw more current than a PC USB port can handle, and just reboots. You could try a phone charger if it provides more than 1A of juice. I haven’t had any issues with phone chargers yet.

My Pi2 is working with 5V/2A power supply.

You mean it boots with tuner attached?


Ok, so then it’s not a power issue.


No Pi Boot Up - - when connected by HDMI cable to a monitor, I just get the multicolored Pi screen with no software loading as before. I’m using ORxPi -2.0.002.img.zip which is an 81,920 MB img file dated 12/10/2015 4:07PM. I verified my Pi is working by booting a 64 GB Rachel Pi chip which did a complete Pi Boot Up (I even left the HD Star connected).

My Pi is a Model B+ V1.2 running with 5 volts 2.5 amps. I have an HD Star connected to the Pi thru a powered HUB. Alternately I connected the HD Star directly to the Pi with a similar result.

Alternately I tried the ORxPi2-2.0.002.img.zip which is also an 81,920 img file dated 12/10/2015 4:07PM - - again with no success.

When I used yesterday’s version of the ORxPi-2.0.002.img.zip which is an 81,920 MB img file dated 12/09/2015 6:32PM, I had to start up the Pi with the HD Star unplugged, then power it down and back up to get the same colored screen again with no Pi Boot Up. Ken

This is only for Pi2.

I just tried 2.0.002, and just rebooted with the tuner attached, and it worked!

Here is what I did:

  • fresh install of 2.2.002 on an SD card
  • first boot after fresh install was done with NO tuner connected (was simply testing that the web server was active, which it was)
  • logged in, changed password, etc. All was OK
  • hot plugged the tuner - was recognized and I saw the ‘waiting for data’ on the download page. I did not wait for any data to be downloaded … was pretty sure all was OK.
  • rebooted the Pi with the tuner connected, and it came back to life with no issue.
  • looked at the tuner page, and saw files being downloaded.

This is the first Pi2 image I have tested that was able to restart with the tuner attached.

Do you want any logs or anything?

Anything else that needs to be tested with this image?


What is your tuner version? Does it has a LED indicator for signal lock?

EDIT: I have SU3000 V1.5

If the tuner comes in a clear case, you can probably see the tuner version printed on the top or bottom of the board. It should say something like SU3000 vX.Y. The X.Y part is the version.

SU3000 V 3.0 is the receiver model/version.

I also noticed that I am getting loads of downloads, but only a couple of items in the library. I restarted fsal as I saw in another post with this issue, and I now see loads of content in the Library.

How can I tell that FSAL is running? I may try to restart the Pi and then check to see if FSAL is still running? If I see the fsal-daemon in the process list when I run TOP, is that good enough to tell if it is running?


The way indexing works in general is, FSAL indexes all incoming files as they come in, and then, if it runs into files that are named info.json or .contentinfo, Librarian indexes them and makes them available in the Library. As you can imagine, this isn’t instantaneously done when downloads complete. Instead, it is done on an interval (60 seconds at most, depending on the number of incoming files).

Branko, in another post to Ben about FSAL, he suggested:

Alternatively, FSAL may have gone down, so you could try sshing into the box and doing a /etc/init.d/*fsal restart.

It worked, so I asked him, (but probably you’re the right person to ask) if this occurrence was a one-time quirk, or something I have to do on a regular basis. Ken

Hard to tell without the logs, but if it went down, it’s very likely there is a bug.

I sent you my log by e mail. Ken