[ORxPi2 2.6] No micro SD card persistence on regular 1GB sandisk card (fat32)


#1

I did a fresh install using the new ‘ORxPi2-2.6.zip’ file by formatting an extra 1GB Sandisk SD card.as Fat32 (note that it isn’t SDHC or anything special like that) and extracting the files to the card.

And… Everything worked perfectly. All of the functions worked fine as well. It even started up with my 1TB harddrive already detected!

Then, I rebooted it using the sudo reboot command.

The boot-up screen looked normal, but when I tried to connect with http://librarian.outernet/, I got the setup screen again!

This happens every time I reboot.


#2

When you boot, can you get the system logs using the download button in the settings page, and post it somewhere (e.g., pastebin.com)?


#3

Here is my logfile on pastebin:
http://pastebin.com/CksA78g8

The things that I found most interesting in the log were:

ONDD:

Jan  1 00:00:17 orxpi2 user.err ondd: [main] Unable to load config: /mnt/persist/ondd.conf (null)

Hotplug:

Jan  1 00:00:22 orxpi2 user.warn hotplug.sda1: Checking this filesystem is not supported

#4

What format is the partition? We’ve tested Fat32, NTFS, and EXT3/4.


#5

For some reason, sdcard failed to mount. Is there a bootlog.txt on the SD card?


#6

Sorry for the late response, @Ben I believe it was Windows FAT.
It wasn’t Fat32. Also, It was an older SD card that came from a old Blackberry Bold (remember those?)

Finally, The SD card in question fell into a crack in the floor and broke in half when I tried to remove it :’(
Sorry!
Thinking about it, who uses FAT anymore? That was probably the problem…
Also, @branko it looked like the entire card was read-only on boot. It was acting like a CD-R more than a SD card. Thus, there weren’t any changes on the SD card at all.


#7

FAT no, but FAT32 is still widely used. (It appears it’s the only filesystem that works somewhat reliably on all three major platforms.)