PCTV 461e DVB-S2 Stick Won't Connect


#1

I have a new PCTV 461e DVB-S2 Stick just in from Hauppauge, New York, with a Raspberry Pi B+ connected as in the DIY receiver configuration. Looking at Galaxy 19 from Washington, DC, I can’t connect. Forum info talks about ways to power the Stick, and a new Kernel I need to operate the Raspberry Pi B+. Where is the new Kernel, and how do I download it onto the Raspberry Pi B+? Ken


#2

What operating system have you installed? PCTV will only work with Arch Linux ARM with upgraded kernel. The latest installation script (as of a few days ago) upgrades the kernel for you and you need to reboot the Pi after install.


#3

I am using Arch Linux ARM, but set up my Raspberry Pi 3 weeks ago, so I’ll have to either completely reload it, or perhaps you can direct me to just upgrading the kernel. Ken


#4

To upgrade just the kernel, you need to:

pacman -S linux-raspberrypi-latest linux-raspberrypi-latest-headers

You’ll get a warning about conflict with regular kernel, so you need to answer with Y to any prompts.


#5

Hello Branko. Yes I am using Arch Linux ARM, but when I try to upgrade just the kernel as you suggest, I am unable to retrieve neither of the two files from any of the mirror web sites.

I tried reinstalling the install.sh file but was told port 80 was not free and I had to disable the webserver or stop the librarian.


#6

I tried again to reload all the Outernet software, and now have a smiliar problem with port 80. My Arch Linux version is 3.12.35.1.ARCH. I got there by loading the latest version of Arch Linux from Raspberry Pi, then doing a pacman - Sy and pacman -Su to update the version as you suggested elsewhere in this Forum.

I can download both install.sh and setpap.sh, but when I try to load install.sh I get the following message: “Port 80 free . . . install.sh: connect: Connection Refused” and “/dev/tcp/127.0.0.1/80 Connection Refused”

Similarly, setap.sh fails to load for other reasons, that I suspect are caused by install.sh not loading.

Can you help me? Thanks, Ken


#7

kenbarbi, I had similar issues withinstall.sh but was able to install after some fiddling. See my response in this thread : https://discuss.outernet.is/t/build-your-own-outernet-receiver-orx-pre-alpha-install-scripts/566/31

As to the connection refused issue, I think that’s expected behaviour as the script is testing for the presence of something listening on port 80 and when the connection is refused it means there’s nothing there.

I haven’t tried setap.sh though.


#8

This is normal. The tool that we used to detect whether port 80 is available tries and fails to make a connection to that port (which means it’s free).

Can you tell me what the last message from install.sh is?

We also have an experimental Arch-based image file which you can copy to 8GB SD card (you can use dd on Linux/Mac or Win32DiskImager on Windows).

FTW, either way, Arch build is currently busted because of openSSL library compatibility issue. This will be fixed and updated image file / install script will be released.


#9

I tried the image file approach (in addition to the NOOBS approach) on a different SD card, and in both cases get the following message after I execute the wget https://raw.githubusercontent.com/Outernet-Project/orx-install/master/archarm/install.sh

Resolving raw.githubusercontent.com (raw.githubusercontent.com) . . . Failed: Name or service not known.
Wget: unable to resolve host address ‘raw.githubusercontent.com

Ken


#10

You aren’t supposed to run install.sh when using image method. Image is an image of an SD card after install.sh has run.

Do you have Internet connection at all? Can you ping raw.githubusercontent.com at all?


#11

Hi again - - I put the Image on a different 16 Gig chip, and yes, I can ping raw.githubusercontent.com from my router, and I have my Raspberry Pi plugged into the same router. Wget to that address is rejected.

With just the PCTV 461e and WiFi attached to my Raspberry Pi , the basic linux program loads, goes thru the outernet login screen, and then proceeds to scroll thru over1,000 lines of instructions, and never finishes - - it just keeps going. The Ethernet connection or Wifi never works.

PS Last week (before I reloaded everything) I was able to see the head end via Ethernet IP or Wifi (on Outernet), but couldn’t see the PCTV 461e. Now I’m not so lucky!


#12

The only thing that comes to mind is SSL issue (server certificate being rejected as invalid). I bumped into it on Raspbian once, and installing ca-certificates package fixed it (or something like that). Not sure if the error message was the same as yours though.

What is that?

It would help if you could tell us what kind of instructions.