Pi not booting from ORxPi images

Hi there,
I’ve run into trouble with my Pi 1 B+ booting any of the available images at https://archive.outernet.is/images/ORxPi/.

I’ve followed both the Linux and Mac instructions for several different versions of ORxPi, but all I get on the Pi is the rainbow start screen. The image never boots. Even with all hardware disconnected. Other non-Outernet images with the same SD cards work fine. I’ve tried both a B+ and an original Pi with no success.

Is there something obvious I’m missing when creating these images? Any suggestions would be welcome.


Try to access your Pi with a web browser.

EDIT: Sometime it will take about 10 minutes to boot the image on Pi 1.

What URL should I try to access?

Generally type librarian.outernet on your browser and hit enter.
If this address does not work, try

IP address assigned by the router (DHCP) to the Pi

Okay, I don’t think it’s ever getting that far in the boot process.While there is periodic flashing on the green SD LED, the rainbow screen never goes away and the Wi-Fi dongle never lights up and thus Outernet never shows up as a Wi-Fi option. Not getting an assigned IP when connecting through ethernet, either.

I let the Pi sit overnight, but still never seeing the Pi boot. I assume I should see the typical Linux boot process if I have HDMI plugged in? Or is the constant rainbow screen normal?

Thanks for the quick responses.

It is not mandatory attach the Pi to the monitor with a HDMI cable.

What is the brand and model of your WiFi dongle?

Try this:
Format the SD card again any copy the latest image to the SD card by extracting the ZIP file. Then insert the SD card and boot the Pi. Wait about 10 mins. Try to access it using the web browser.

Keeping the HDMI monitor is helpful in case you have a “stuck at rainbow” situation. I haven’t booted a Pi1 in a long time (it’s no longer officially supported), so I’m not sure how long the rainbow should remain on the screen, but it should definitely go away within the first dozen seconds.

That’s helpful, branko, thanks. I didn’t realize the P1 was no longer supported. The rainbow screen remains indefinitely. Even overnight.

I appreciate the help. Whenever I pick up a P2 or 3, I’ll give Outernet another shot. Thanks again.


Pi3 is not supported by the current image. So basically only Pi2. If you don’t mind getting your hands dirty a bit, Pi3 support can be patched in relatively easily, but we currently don’t have time to support it. It may come at some later date.

I’m currently running a Pi 1. It took about 10 minutes for the first boot. Sometimes there could be an issue with your SD card. I’ve experienced similar issue long time ago. If you have a spare card, try with it.


Hello Branko

I am want to test the ORxPI last version.

I downloaded the last version from: https://archive.outernet.is/images/ORxPi/3.1/ORxPi-3.1.zip

I tryed to install that version by using dd if=/path/to/ORxPi-0.2.4.img of=/dev/sdb bs=1M, but nothing happends. I think the image is not complete, when I do the unzip, I just can see


Is there another way to install the ORxPi-3.1.zip

Thanks in advance any help.

Best regards


You just need to copy all of those files to a blank SD card and it should be good to go.

Thank you Branko, it worked

Now I have to connect an antenna to receiver.

In https://archive.outernet.is/images/
there is a file: outernet-rx-latest.pkg
How do I install that file?.



That file is not for ORxPi. You are already on the latest version.

What is the latest version that you have running on your Pi 1 ?
For me ORxPi-0.2.8.img is the only possible one.
From version 0.2.9 on and upwards the images are bigger and mabe it has something to do with it.

Formatting a SD-Card as FAT32 and than put the files in the root does not work, dont now why.

Can someone explaint the above what each file each file is or does?