Powerswitch on CHIP (was: Overload by LNA or RTL?)

Today I received my kit and connected the parts together.
When I connect the powersupply, only a very short weak led flash is seen near the CHIP power connector
and nothing appears on the WiFi.
When I unplug the RTL stick, a bright led is lit on the CHIP and a weaker one. After a while the bright
one starts flashing. The CHIP is accessible via WiFi.
When I connect the RTL stick with or without LNA the leds immediately turn off.
I used an external adapter and the battery pack but the result is the same.
When I plug the RTL SDR into a computer, it is detected as:
Realtek Semiconductor Corp. RTL2838 DVB-T
So it does not seem it is bad.

What could be wrong?

this is expected behaviour

plug it all in then the two lights should flicker briefly , then just hold down the power button till they fully light

Try to power on CHIP by pressing it’s button, as the FW on power on now turning on for a few milisec and turning off immediately.

turning on: holding the button for about 2sec
turning off: holding the button for about 6 sec

Aha thanks! That wasn’t clear to me from the instructions.
Now it is receiving…
The WiFi range is ultra-short, though.

So just to clarify it was the power button causing the problem?

Yes, it was causing the problem (strange that it does power up without the RTL stick).
Now I am trying to get a usable WiFi… its range is very short and up to now it has failed to connect to my
network, I could only connect it from a laptop very nearby (on the Outernet SSID).
When I set it to connect to my network it does not show up and falls back to AP mode.

1 Like

After the usual familiarizing, all appears to be well now…

1 Like

Is there any chance that this power button problem can be solved in software?
I intend to put the whole kit in a lunchbox and place it on the roof or balcony.
Having to press a button whenever it is powercycled is a huge disadvantage when trying
to do this.
Can’t it be programmed to restore “last state” after powercycle? or is there some hardware
mod possible to bypass the power button?

1 Like

Are you running skylark? If so you should be able to auto boot when power is connected. If you are running skylark, check your power supply voltage. I had an issue that is very similar to yours and the problem was the USB power supply I was using dropped in voltage under load. It took some time digging in my power supply stash to find one that could keep close enough to 5v under load to allow auto boot. In my brief testing the cut off was around 4.8v.

Is it different when running Skylark? I have not tried powercycling it yet, my previous experience
was with the out-of-the-box unit which had Librarian on it. I was very confused when the CHIP worked
fine without the RTL stick but required a power-on button press when the RTL stick is connected…
I will try powercycling. Previously, the problem was not depending on power supply, I also have
the battery pack (though not currently using it)

There is a reboot button in “Network Settings” in Skylark if you asking for such a thing

I am running Skylark and it NEVER auto boots on powerup, regardless of what power supply , (and I have an “official” USB battery too) does yours???

If so I need to understand why, as I am often remote from my station and last time it simply died a day after I went …

DONT use the “Apply & Reboot” button in the network settings as a “reset”!!

@zoltan I just thought I would simply change nothing and try doing a “reboot” using that button and when it restarted the wifi was gone completely … No Outernet hotspot. nothing.
I have physically restarted it too now, and it is GONE

I will leave it turned off for a while, but It looks like I am going to have to reflash it :frowning: Bad news!!

Hmmm… strange… I’ve clicked now on that “Apply & Reboot” button and my Skylark CHIP lost too. However after powercycling it’s works very nice again. Maybe confusing that it changed IP address, not sure if yours have static IP or how you check.

Most of the wifi routers enable to use: my.outernet.is which gives you a list of Skylark devices on the LAN or bring you to the single device on the LAN.

At the end, when I’ve used this reboot button in an earlier release that was fine. @Abhishek might advise on this what’s causing this issue.

Thanks for sharing this!

1 Like

I didn’t try my RAVpower battery bank because it is impractical to use for me. The only power supply I had that worked for auto boot was a 5v 2.5a wall wart made by element and I’m feeding it through charge in on the header. This supply stays within ±0.02v of 5v under load. Just don’t try a PSP charger (rated 5v 3a), they drop to 4.57v and are the noisiest things on the planet, getting a signal was Impossible. Is there any other tests that I can do to help?

1 Like

Regarding finding Outernet IP addresses on my local LAN. I have not been able to do that with either Skylark 4.1 or 4.2. Seems as thou I was able to do it when I was running rxOS 3.1.

I get the following:

using Opera, Goodgle Chrome or Firefox. Is it my WiFi device preventing me from doing this? I can find them alright using Advanced IP Scanner program on my computer. Ken

Try internet exploder. Did you try a different computer, or a phone? I know opera on my windows phone does this but I could never figure out why.

strange… works for me on Chrome and Firefox too.
I guess it’s wifi router related not all supports this feature, but experts my correct me.

Also what I do usually is nmap, as Skylark opens port 22 and also it’s name can be speaky:

nmap -sn 192.168.1.*

I just connect to the wifi as a hotspot so it is on its own network, and I go to ( not my.outernet.is )

The ONLY way that my.outernet.is can resolve is if the CHIP tells outernet.is what it’s IP address is on you local network and the they tell you how to resolve it… I don’t allow that sort of info leakage on my network without my permission :wink:

If you have a linux machine on you network you could just type “arp-scan” (or whatever you network IP rang is , and find it like that… you could use an android phone with “Fring” installed to do an ARP scan, or you cont look at you home router and see what lease IP address it has given to the device…

Back to the issue of the power button…
I just tried (running Skylark) what happens when I just pull the power plug and re-insert it.
Same as before with Librarian: only a short led flash and the CHIP remains OFF.
When I press the button it powers up.
Should this have been changed? I would like it to just powerup when I apply power, especially
when it was up and running when the power was lost. It is not as much of a problem when it remains
off during the first run after flashing, as then I am accessing it anyway.
(not that this is convenient: for flashing that special jumper is required and I need to open the box or
mount a special switch for this)
What are the design criteria for this system? it should be obvious that when you want something that
can be used in the outback it is not convenient that tiny buttons on a PCB or wire jumpers are required
for normal operation or for updating the OS. (especially when that cannot be done by simply uploading
a new image using a browser, as is quite normal for devices using flash memory)