Problems flashing

I have problems flashing my chip. First the computer didn’t recognize the chip at all and took it for a CDC composite gadget. From the getChip website I got the latest driver installed it and the chip is now showing under libUsb devices as C.H.I.P. in flashing mode, which sounds right to me…

When I run the VM the operation is timed out because the program can’t find the CHIP in Fel mode (although, it’s visible in the device manager). Checking the USB settings of the VM the CHIP does show up, as Onda V972 unverified tablet in flashing mode.

I tried reinstalling the VM, used various USB cables but without succes.

It looks like a problem with the VM, When not in Flashing mode I can access the CHIP in a serial terminal , In flashing mode windows recognizes the thing for what it is, but somehow the VM doesn’t get it right.

Extensions are installed and virtualization is switched on… What am I missing??

You need to remove the windows drivers. If the windows driver grabs the device, the VM won’t be able to. Note how the instructions say to ignore the OS if it wants to install a driver for the device.

Thanks. yes true I did have a gut feeling the instructions actually do serve a purpose :slight_smile:

But even after removing the driver no luck, The CHIP isn’t recognized by either Windows or the VM… I’ll study the instructions and because there might be some interfering leftovers still on the system, repeat the procedure on an other laptop in the morning…

Something that is real easy to do is connect the FEL jumper on the wrong header. Double check that your jumper is in the correct header strip and correct pins.

Also make sure the wire going into the holes makes contact. Don’t forget a clip’s wire diameter is TOO BIG to actually make contact although it fits into the top of the hole. I’m using a 22 gauge wire stripped out of a Cat 5 cable.

Sorry if this is too obvious a solution, but in this business, small things sometimes need to be said. :wink: