Problems with DIY L-Band Setup - was working, now isn't?

Good evening all,

I put together a DIY ORx with a Raspberry Pi 3, the Outernet USB receiver, Outernet patch antenna, and Outernet LNA / filter.

It worked really nicely for a couple of days - SNR in the 4’s and 5’s (signal state 4) and got lots of cool downloads. (Future Outernet Engineer picture, rocket stove plans, solar distiller plans, weather pictures, etc…) For the past few days, my setup struggles to get above an SNR of 1.0 and it rarely has a signal state greater than 1. The setup is unchanged, so I suspect something is not working right. It’s pointed properly both in azimuth and elevation.

I tested the patch antenna and LNA/filter by disconnecting the RPi and USB receiver. To the output of the LNA/filter, I hooked up an Airspy receiver with the bias voltage turned on. I can clearly see the Inmarsat signal at 1539.875 MHz and the SDRSharp program calculates an SNR of about 9. Using this setup, I confirmed that the pointing is good, and really, the patch antenna isn’t as sensitive as I thought it would be to errant pointing. I don’t know if this confirms that the LNA/filter is working properly or not.

Is it possible that there is an issue with the USB stick receiver? Has there been issues with the satellite, maybe? My next step is to buy another USB receiver and LNA/filter to see if they improve things.

Any hints greatly appreciated. :slight_smile: I’m in the southern USA and am a ham radio operator / amateur electrical engineer. :slight_smile:

thanks much!

Same thing has been happening to me.

I am sort of waiting until Outernet get all their initial testing sorted.

The Main thing for me is it already DOES work.

So if Outernet have to shake out a few bugs on their Data Carousel I will happily wait.

The other night when they turned the data Carousel back on I got 7 SNR ( usual 4 to 5) and lots of files.

Now I get little signal and one file yesterday. Have not checked today.

We never turn the carousel off…it plays out over and over again like a juke box. What happened previously was that there was a bug related to how the packets are reconstructed–but that happens after the demodulator does it’s job. But I do believe you when you said there was a correlation.

Testing the LNA is simple. SDR# will show you a ~30dB jump in the noise floor when you remove the amp from the RF chain. Can you confirm that? The next thing to check is the dongle in SDR#. Are you able to see the signal with our dongle and amp?

Good morning Syed and Seasalt,

Thank you for replying to my post. This morning I did some more testing on my setup and took a bunch of screen shots.

First, I performed the test you suggested. Using the Airspy, I decided to see what sort of NF jump I got when hooking up the amp. So there are two screen shots below:

  1. Airspy RX with just the patch antenna connected:

Airspy with patch antenna but without lna

Noise floor seems to be about -95 dB.

  1. Airspy RX with the amp/filter and patch antenna connected.

Airspy with patch antenna and lna

Noise floor seems to be about -80 to -75 dB, which seems shy of the 30 dB difference that should be seen.

I decided to perform the same tests using the ORx USB receiver:

  1. ORx receiver with patch antenna but without the lna.

ORx USB receiver with patch antenna, but no lna.

NF appears to be about -55 dB.

  1. ORx receiver with patch antenna and with the lna.

ORx with patch antenna and LNA

NF appears to be about -28 dB. This is pretty close to the 30 dB difference that would indicate that the LNA is functioning.

Based on the Airspy tests, I’d say that I’ve got a problem with the lna. But, based on the testing with the ORx receiver, it seems that the amp is working fine. It is interesting to me the amount of noise floor difference between the ORx receiver and the Airspy. The Airspy is a $200 device while the ORx stick is a $25 device, so perhaps that isn’t surprising or unexpected.

As a comparison test, I got out another E4000 dongle to see where its NF was. It seems to be about -60 dB, very comparable to the ORx device. As another test, I got out an R820T2 device from NooElec. The NF there also seems to be about -60 dB.

Now to see what the ORx can see outside in my backyard:

  1. With the ORx and lna attached to the patch antenna.

ORx pointed at satellite with lna and patch antenna.

It’s tough to see if there is any reception or not. There might be a little bit in the waterfall, it’s hard to tell. I could see this not resulting in a lock or any downloads.

  1. Now to swap to the airspy, with the lna and the patch antenna:

Airspy with lna and patch antenna.

Certainly, the Airspy / lna configuration is seeing the satellite. This version of SDRSharp works with the E4000, but doesn’t have the SNR calculator feature. Just to see what it is, I swapped over to a newer version that only seems to work with the Airspy but does have the calculation feature:

  1. Airspy with the SNR feature turned on.

Airspy SNR

Base on all the above, I’m not really certain where my problem is. Any advice would be greatly appreciated. My immediate thought would be to buy another ORx stick and LNA and see if that fixes the problem.

thanks much,

It looks like the dongle is the problem. If you don’t mind, I’d like to replace it.

Good morning Syed,

Very good - I just put in an order for another dongle and, just in case, another LNA. :smile: Should get here Tuesday, but I probably won’t have time to try it out until Friday. But when I do, I’ll let you and the forum know how it works out.

thanks much!

Good morning all,

A new development - decided to try an R820T2 dongle this morning with an external, battery-powered bias tee. I was able to see the satellite without any issues. So I swapped back to the E4000 outernet dongle, and guess what? I’m seeing the satellite without any issues:

Today’s Signal

I’ve got the dongle back on the RPi now waiting to see if it will lock to the satellite.

thanks much,

Good afternoon all,

Left it on for several hours and never got a lock. :frowning: Not really sure what’s going on…the new dongle and LNA should be here Tuesday. :slight_smile:

thanks much,

Perhaps a related problem?

Long story short - while continuing to struggle with a CHIP (see related post), I took delivery of a Raspberry Pi 3. Created an rxOS chip, and off we went. Up and running quickly. A few days ago, the SNR was hovering around 4-5, but now around 2 and lower. 8-10 % bad packets, and nothing showing up in Librarian. Even after ~ 3000 packets with ~ 8% bad.

So, went over to Windows and SDR# for trouble shooting. With the pre-amp/filter in line, here is what I see -

Assuming the E4000 is on frequency, I have a very poor signal it would seem? QTH is Bristol, RI so I see signal peaking at SSW and 35 - 45 degrees elevation.

Also, in Librarian, loooking at the signal strength meter I either see no bars, or generally one bar. Tonight I saw this

and this

No idea what the difference.

Lastly, I tried to manually tune the E4000 using the Custom feature to 1539.892 GHz but even after saving the settings, a frequency change was not evident.
I must admit to also wondering if the E4000 is off frequency? Or, despite a pretty clear shot at the sky, there’s a lot of noise around?

Ok, everything back in the box for a few days.

Thanks for listening.

If it’s any consolation, we’re not getting packets here (Chicago HQ), either. It’s possible that we’re seeing some atmospheric/ionospheric conditions that are degrading the signal, but that’s pretty localized from what I understand. My problems should not be the same as yours. Plus, we just had a report of someone downloading without issue in North Dakota while driving.

At this time (2152 UTC 12 Sep) I am receiving low signal levels here in Annapolis, MD, (20 miles east of Washington, DC) on I-4 F3 Americas. Signal are down about 2 dB from normal at a current 3.3 dB. Sky is clear so go figure. Ken

Is your packet count increasing?

Oops - - my time was wrong - - not 2152 UTC but it should have been 2352 UTC.

Anyway, now 1 hour later at 0057 UCT (really) my packets are increasing as is the size of the file being downloaded.

Ken I notice that your Donald_Trump.html file has a very high packet failure count and low signal state!

Interestingly enough, the Trump article never finished and is not among this morning’s downloads. Signal strengths here are back up again into the 4 - 5 dB range, and packet failures are low again. Old articles are reappearing as the carousel turns. Ken

I noticed another attempted download of a “Trump” article with many packet errors. It never showed up in Updates, and when I checked the App log for any activity, I saw nothing had been logged.

Is there a problem with the file causing the system to respond strangely? Ken


Running rxOS on a Rasberry Pi. Using, I was also finally getting a good signal (not saying SNR and software are related). Maybe RX conditions simply improved.

Alas no decodes!

Yesterday noticed a new version of 2.0a2-xxxx
Flashed that and tried again

Voila! Success!! SO, Pi based system up and running. Happy!

Syed - agree with Seasalt - some sort of change log please on SW revisions would be nice.

OK, now back to trying to figure out why I cannot communicate with my CHIP in FEL mode. It has a CHIP Debian OS at the moment, and communicates just fine via the UART-USB interface. More head scratching!

Need to add one more screenshot - The second one above shows a previous mid-day loss of signal quality as shown by a jump in packet failures. In got even worse as the day went on. However, yesterday things improved quite notably. This is from this morning. I was very surprised at SNR!

Wow. I’ve never seen four bars before.

Wow is right! What is your antenna and RF path setup? It is a winner! :grinning: