Rachel on external SD card DC V3.xx

@kenbarbi, would you mind sharing how you got Rachel working on the current DC. I would like to put it on the SD card and have it available. I have downloaded the Rachel Pi image and am currently extracting it to my computer HDD. Are there specific folders one should move over to the SD or does the whole image need to move? Also, do you have any experience making a custom Rachel image?


"Most people will want to download the RACHEL-Pi image using FTP. We recommend using a modern FTP client like FileZilla that can recover from network hiccups. You will want to connect using the information below:

FTP server: ftp.worldpossible.org
User/Pass: anonymous/anonymous"


I found one of your posts that describe it.

It looks like all the files are located in var/www/modules.

I think this what your are asking:
I have the usb 32 GB usbEN unzipped onto a sdcard, then after a while the “outernet downloads” also show up on the data drive.
Here is my view of skylark file manager, clicking on external_sdcard
To use Rachel I click on the START_HERE.hml and choose download to computer.

Thanks for the reply. Basically, I would like to install Rachel without the RaspPi OS and extra fluff that comes along with it. I have identified the main folder where the files reside. Var/www/modules. There might be more somewhere else, which I will look for a little later. But the 64GB image shows the above folder at 53GB. Other modules can be downloaded from here:


I drilled down into the Rachel folder
these are modules in the 32 gb usb ENglish . Yes you can add more.

I download the Rachel 32 USB then unzip it


I then copy the entire result to the 32GB data card


Once installed in the Dreamcatcher, it shows up in the external_usb folder



I then Download to computer to run

The Dreamcatcher won’t run the complex Rachel “drill down” html files with the reader:


Jason, the real trick is going to be making the Rachel HTML file pop up and be able to be drilled down into. @Abhishek recognizes the issue here with Rachel-like data bases and is problably going to fix this so the Skylark Reader works like your computer does when you download to the computer. To do that, you have to be able to correctly render the START_HERE.html file with the reader.

I’m going to try a 64 GB Sandisk tomorrow for both data storage and the basic Skylark OS. Based on what you want to do, the 128 GB SD card starts to make sense. I havn’t recently tried a 2 TB Western Digital hard drive as external storage, but will later this week. It worked with the 3 year old Lighthouse terminal, but hasn’t worked since with Pis or CHIPs. Ken

1 Like

Ken, @ac8dg
me2 … I’m listening to the conversation. I’m very interested in getting Rachel going on my DreamCatcher as well.

–Konrad, WA4OSH

As to downloading bigger Rachel files, I can only find 64GB Rachel Pi zips in English, Spanish, and French:


I’ve been using the 32GB USB versions as I can load them on an SD card with a Windows machine. I know you can obtain other Rachel Modules in the zipped-modules section. Ken


Having Rachel is a nice addition to the DC. I am currently copying the full library to a 500GB drive, would like to pair it up one day with the DC and a hub just to test it out. Might come in handy one day.

Jason, before you download to the 500 GB hard drive, have you selected a format for the drive so is recognized by the Dreamcatcher? I didn’t run that test yet. I’ve only been able to get a 64GB SD card to work when formatted with Large FAT32 using Rufus. Ken

Are these size limits only for the sd card, or do they apply to plugging in a usb thumb drive or even a usb hard drive? into a hub so the wifi adapter is still functional.

I don’t know - - I didn’t test a USB Flash drive or hard drive with the Dreamcatcher/Skylark 5.2 - - just micro SD cards. That said, I am successfully using a 32 GB FAT32 Flash drive with one of my Dreamcatchers/Skylark 5.2 (connected thru a passive HUB that also holds the WiFi dongle).

The USB Flash drive worked fine under Skylark 5.0 and 5.1 too, but I never went above 32 GB; and I could not get a 1 TB Western Digital Passport hard drive to work under Skylark 5.0 and 5.1. I’m guessing I might have used the wrong format.

How about you try those options with Skylark 5.2 and reporting back. Ken

I am currently downloading all the file to a HDD, but I haven’t started to unpack them. When I do, I will create a large fat32 partition.

1 Like

OK let us all know how the hard drive works. Ken

1 Like

mostly for the benefit of others who encounter this message thread:
other names for the precise FAT32 filesystem to use are: FAT32 (LBA), and VFAT. the original Win95 FAT32 (no LBA) is not suitable.
DC v3.03 w/Skylark 5.5 accepts 64GB microSD cards in both slots (Samsung EVO Select UHS-3).

My Rachel is installed on a 128 Gb Samsung EVO Select U3 SDXC I (formatted VFAT) in SD2 on my portable Dreamcatcher 3.03 running Skylark v5.5 and it works fine, with no problems.

I have installed RACHEL 4.0 (https://worldpossible.org/rachel) according to these steps:

You need at least 45 Gbyte on your sd card.

First you have to download the zip file with the Rachel database via ftp client. You can use WinSCP (https://winscp.net) for Windows, gftp for Ubuntu or Cyberduck for Mac OS X(https://cyberduck.io). Use this configuration to connect to the ftp server.

Protocol: FTP
FTP server: ftp.worldpossible.org
User/Pass: anonymous/anonymous

Now you have to download this file:

The download takes a while. After download you have to extract this file:
On Windows you can use 7zip (https://www.7-zip.org).

That’ll take some time, too. After this copy the folder rachelusb_32EN_4.0 to your external sd card.
In Skylark you have to open the file manager, go to the rachel folder and open the file START_HERE.html with the Reader.


You can download other modules from /zipped-modules, extract the zip archive and put the folder on your sd.

Up to here everything works very well.

My problem is:

I downloaded the German version of Wikipedia ( /zipped-modules/de-wikipedia.zip ). But there are no .html files in the archive. It contains index.htmlf and index.php. However, these cannot be executed with the reader. You may need Kiwix for these modules.

How can I use this module under Skylark?

1 Like

Have you tried to rename index.htmlf to index.htm? I don’t know if that will work, just something to try.

This page may help explain some of the confusion:


It appears that a few years ago the Rachel folks went through some similar problems when updating the Rachel Plus devices. You may get some hints by reading through their blog:

Perhaps Abhishek @Abhishek can cast a light on this