Receiving packets but no files in librarian (RxOS 3.1/Pi3)


I’ve set up my R-Pi3 with the latest RxOS 3.1 SDimage. After configuring with the wizard to use the APAC satellite I4-F1 shortly after I was receiving packets with signal state 4. However, I’ve been running the system for over 24 hours and still no files are showing up in the librarian, and this is after I witnessed one of the files (had ‘Clinton’ in the filename) tick over 99% and then a new file start.

It looks like /mnt/cache is growing with a bunch of files but these aren’t getting unpacked to the librarian?

Attached screenshot of tuner settings and app logs:

Scott Bragg VK7LXX

PS - Originally I used the Raspbian installer to install the software stack on an existing Raspbian SDCard. In that case I was able to get CODE LK on the demod app but never anything more than that. Switching to RxOS SDCard I was able to receive packets (signal state 4)

No packet loss–yet no files? Which 3.1 are you using? The one from October 12 or October 30. In either case, this should be working @Abhishek

Can you go to and tell me what you see?

I am using the image from Oct 30.

It looks like the remaining space on my 8GB SDcard was not mounted. I’ve since plugged in a USB stick which did get automounted and the latest file got unpacked. I’m up and running.

What happened to the remaining space on the SD?

It looks like the partition was defined to use up the rest of the space on my SDcard (mmcblk0p8) but trying to mount /mnt/internal comes back with

mount: mounting /dev/mmcblk0p8 on /mnt/internal failed: Invalid argument

So it looks like this partition wasn’t formatted.

I ran mkfs.ext4 /dev/mmcblk0p8 and then mount /mnt/internal and there’s now an internal storage mount as well.