Request for assistance with new ORxPi Install

Hey All!

I finally worked my schedule (and wallet) to get my 90cm dish professionally pointed, but I can’t seem to get my ORxPi receiver working.

Some Specs:
90cm FTA dish with a linear Ku LNB pointed at Galaxy 19.
Raspberry Pi Model B. (Not a B+)
8 GB Kingston MicroSD card in an SD adapter. No external storage.
Geniatech HDStar Receiver, purchased from the Outernet store.
ORXPi v0.2.9 / Librarian 0.4.post9

When I first install with a new SD card, it will show a lock and good signal strength (though the signal strength and quality differs if I select a Universal or North American Ku Band LNB.

After a while, the indications that it’s downloading files stop, and it will often show no signal anymore. Sometimes, trying to change tuner settings will give an error that it cannot find any tuner connected.

Sometimes, rebooting the Pi, receiver, both, or disconnecting and reconnecting the USB cable between will bring back the connection. At some point, I think with v0.2.7, I managed to get several files to show up in the library, but trying to click on any of them led to a 404 page.

Can anyone share any suggestions on getting things working? I’m not a linux expert by any means, but I"m vaguely familiar. Links to some text data are below.

PuTTY Log including dmesg and lsusb commands:

Application Log:

System Log:

Hm, according to your application log at line 2268 content was added to your library. Can you confirm that no folders are in the /mnt/data/librarian/zipballs/ directory and no content shows up in the library?

Oh, upon examination of the system log i see ioctl is complaining about missing a device. It’s probable that there are unresolvable differences between B and B+ models, but i’m not certain. @branko would know more.

@Ben, I’m also having the same issue. I’m working on RPi2. Also getting 404 page. Will update…if found any solution.

Sent from my Windows Phone


Thanks for your thoughts. Initially I also thought that the satellite tuner might be defective or flaky, as it looks like it was disconnected.
I installed the HDStar driver on my laptop and can get a signal lock using Prog Finder (a satellite signal strength program), so it seems to be working, at least intermittently.

I’m just checking back hours later, and there is information in my library, a whole bunch of files, but the tuner page still shows no lock/not downloading/0 signal.
The library stats show 28 items and 112 KB used space. Seems like it should be more for several hours of downloading all day, even at 90 Kb/sec (which seems to be the most common download speed off of G19).

Being that the titles of content or some metadata to populate the library is making it through, I imagine it must be receiving something, but every title of a file I click (admittedly not every single one, but I have clicked several of them) goes to a 404 page.

I’m curious, does anyone know of a particularly stable firmware image? The Wiki page for the firmware images includes a download link to 0.2.4 - is that considered the latest stable build? I can easily re-do the SD card to any version for testing.
Alternately, I also have a Raspberry Pi 2 I can use, or I’m sure I could find somewhere to purchase a model B+ if that’s the standard version to use.

@pradeeka Thanks for letting me know! I’m glad I"m not alone. Do you also see the bizarre tuner statistics that I am?

So to be clear the issues both of you are experiencing are:

  1. Intermittent signal lock
  2. 404 response to attempts to load a content URL

I recommend including an application log from shortly after you have triggered the 404 error, as the error should be displayed in that log. I suggest using to post log files however, as they’re more readable and you can link to specific lines of the file.

You could try the latest image with your Pi 2 if you wanted, or you could try any previous image. All released images can be found at

Hi Ben,

I still haven’t seen a lock at any point since I last checked in - but I also only check in intervals of several hours. The library is (slowly) growing in size, so I assume it occasionally gets a lock and downloads some files.
That does cover both of my issues, yes.

As per your suggestion, I logged into Librarian, clicked on several items to get 404 pages, and then downloaded the logs. You’ll find them on a Gist here:

I also logged in with SSH. It looks like the /mnt/data/librarian/ directory exists, but it is entirely empty - no zipballs directory within it.

I’ll perhaps dig up another SD card and give 0.2.4 a try if I have a chance this evening.

Thanks for the help so far!


Sorry for not looking at this sooner. It’s a bit hectic at our camp. The location where content is archived is /mnt/data/library. We have two separate builds for different hardware and some of the locations are different, so even we get confused sometimes. From your logs, it appears the receiver is receiving files and adding content to the library without errors.

The interruptions may be caused by the following:

Nov 27 15:06:13 orxpi user.warn ondd[180]: [data] read() failed: (75) Value too large for defined data type
Nov 27 15:06:13 orxpi user.warn ondd[180]: [main] timed out waiting for PMT

I’m not 100% sure what these indicate, so I’ll have to look. I’m pretty sure those won’t cause no lock to be reported, though, so it’s unrelated to your not seeing a lock.

Hey @branko no worries on your response time. I totally understand.

The receiver/dish setup I have is actually in a rural area - and I’m back in the city. I did bring the whole kit back with me since it wasn’t working anyway, so I’ll boot it up when I have a free moment without the dish and make sure there is data in that directory.

Let me know if there’s anything else I can do without a dish to get you more information, if there’s any that would help.

Do you still get this with v0.2.9?

@branko that’s correct. I was running 0.2.9 for every issue described in the thread (intermittent lock, 404 pages primarily) but noticed during a test that the 404s also happened with 0.2.7. I don’t recall if it had the intermittent lock.

If you are able to trigger this again, can you please post a screenshot?

Tested with Librarian v0.4.post9 / ORxPi 0.2.9:

Currently there are 4 content archives in my library. But I am still getting 404 error. For example when I click on the ‘WHO Director-General speeches’ wiki, the browser navigates to the following url.

It complains index.html is not found

But all files are there under /mnt/data/library/

index.html file and info.json files:

.sqlite db backup file

This issue should be fixed in 0.3.0 release. Please give it a try and let us know if it works for you.

1 Like


It works :smile:

@pradeeka thanks for the information in my inability to provide it!

@branko I’ll burn a fresh SD card with the update and let you know how it works. I’m at this point also (somewhat blindly) hoping that the problems with getting a lock will also be fixed.

1 Like

I haven’t done anything specific regarding that but I think we’re on to a solution. We will be releasing a new version soon, so when that happens, it should get resolved.


Hey All,

I updated my Pi model B to 2.0.000 and got it up and running. I’m still seeing the intermittent lock issue - the tuner just seems to go unplugged (according to the interface, it’s not really unplugged) a few minutes at a time. I also double checked the dish, it’s locked down and definitely not moving. Weather is favorable.

The content is browsable, though, so that’s definitely a step forward!

I’m just downloading the RasPi2 image now, I’ll be testing that later to see if the lock maintains itself better.

The IT Consultant in the back of my brain is yelling about how the tuner hardware is flaky, but I’d like to try with another Pi at least, and also check back and see if anyone else is seeing the issue or if it might be a known software bug.


I con confirm that the intermittent lock issue also happens on my RasPi 2. Though, the web interface is a lot more responsive and seems to perform a lot better with the better hardware. Might opt to keep that for the future.
Any thoughts on how to proceed? No rush on response time.

No thoughts yet, but can you power cycle your Pi2 and get the system log as soon as the GUI is up? Also, please try to wiggle the coax while monitoring the dashboard and see if it affects the output in any way (e.g., cause it to loose the lock, etc).

1 Like