RPI2 wifi dongle support

Hi, I’ve installed the latest rxos image on the pi b 2. It boots up and I can ssh it via the ethernet port. It does not create a hotspot, Unsure of the wifi dongle I’m using but it works automatically with raspbian. I also can’t view the webserver by typing in the ip address of the ethernet ip address? Any thoughts?

What is the model of wifi dongle you are using? And the IP address?

I’m unsure of the specific brand, it was just a generic one which I bought from modmypi.com, works fine with raspbian. My question more is I’m just wondering why the webserver didn’t work over ethernet, the ip address was just the dynamically assigned ip, ssh worked.

Can you provide the exact build you are using so I can replicate this?



Should the webserver work on a PI2 even if it has no WIFI dongle?

Yes, I used to regularly access over LAN.

Hmm… I re-flashed the RPI2 with the latest version of rxos (released 26/09). Didn’t worry about wifi, put rtlsdr dongle in, booted it up. I can connect to it via ssh, but when I type the ip into the internet browser I get nothing.

@Abhishek This is strange. Any thoughts?

Is there a way I can troubleshoot the webserver etc through ssh?

could you show the output of “ifconfig”

and “ps aux | grep lig”

Problem solved, it tuned out to be just a setting in my router which I believe blocked port 80. Thanks for your help.
I read somewhere that at some point the outernet software will offer a wider range of wifi dongle support, any idea when that would be available?

It will be some time before we can support a lot more wifi dongles. We have a few other major projects that need to be completed before then.